summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author Benjamin Trigona-Harany2017-01-23 18:50:29 +0100
committer David Spencer2017-01-24 01:21:54 +0100
commitb907db2508d40631bf1623b7e525383b7b6c3dec (patch)
treeb2ed6f3516aed3b1f8e1e8b3d789e8fa9b1b4f3a /development
parentd58f83bb3924a7dc730538d2f405bf051d107cdc (diff)
downloadslackbuilds-b907db2508d40631bf1623b7e525383b7b6c3dec.tar.gz
python/ipython: Moved from development/, upgraded for version 5.1.0.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'development')
-rw-r--r--development/ipython/README12
-rw-r--r--development/ipython/ipython.SlackBuild80
-rw-r--r--development/ipython/ipython.info10
-rw-r--r--development/ipython/slack-desc19
4 files changed, 0 insertions, 121 deletions
diff --git a/development/ipython/README b/development/ipython/README
deleted file mode 100644
index 3f141871f4..0000000000
--- a/development/ipython/README
+++ /dev/null
@@ -1,12 +0,0 @@
-IPython is a replacement shell for Python programming. It offers an enhanced
-Python shell for the terminal.
-
-The following additional features may be enabled by installing the listed
-optional dependencies:
-
-* parallel computing: pyzmq
-* Qt console: Pygments, pyzmq
-* nbconvert: pandoc, Pygments, Sphinx
-* notebook: Jinja2, jsonschema, pyzmq, tornado
-* plotting: matplotlib
-* LaTeX in notebooks: ipython-mathjax
diff --git a/development/ipython/ipython.SlackBuild b/development/ipython/ipython.SlackBuild
deleted file mode 100644
index 50da8a8dd2..0000000000
--- a/development/ipython/ipython.SlackBuild
+++ /dev/null
@@ -1,80 +0,0 @@
-#!/bin/sh
-
-# SlackBuild for IPython
-
-# Copyright 2008-2011 Carlos Corbacho <carlos@strangeworlds.co.uk>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-# Maintained by Benjamin-Trigona-Harany
-
-PRGNAM=ipython
-VERSION=${VERSION:-3.1.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-DOCS=${DOCS:-no}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-python setup.py install --root="$PKG"
-rm $PKG/usr/bin/ipython2
-
-mv $PKG/usr/share/man $PKG/usr
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-
-# Delete now empty directory
-rm -rf $PKG/usr/share
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-
-cp COPYING.rst README.rst $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/ipython/ipython.info b/development/ipython/ipython.info
deleted file mode 100644
index dc40104cb7..0000000000
--- a/development/ipython/ipython.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="ipython"
-VERSION="3.1.0"
-HOMEPAGE="http://ipython.org"
-DOWNLOAD="http://archive.ipython.org/release/3.1.0/ipython-3.1.0.tar.gz"
-MD5SUM="a749d90c16068687b0ec45a27e72ef8f"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Benjamin Trigona-Harany"
-EMAIL="slackbuilds@jaxartes.net"
diff --git a/development/ipython/slack-desc b/development/ipython/slack-desc
deleted file mode 100644
index dd49fc8430..0000000000
--- a/development/ipython/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-ipython: ipython (an enhanced Python shell)
-ipython:
-ipython: IPython is a multiplatform, Free Software project (BSD licensed) that
-ipython: offers:
-ipython: * An enhanced Python shell designed for efficient interactive work.
-ipython: * A library to build customized interactive environments using
-ipython: Python as the basic language
-ipython: * A system for interactive distributed and parallel computing
-ipython:
-ipython: Home Page: http://ipython.scipy.org/moin/
-ipython: