summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author Matteo Bernardini2013-12-07 10:09:47 +0100
committer Erik Hanson2013-12-14 17:52:34 +0100
commitd02d5c81191439f84d80cc42b0cac7453ec6a802 (patch)
treedb5a5479cddf1d47f871e28ed75b7f4d1c32f871 /development
parentb4c324d2a44862f43c8a6e2722c3a45b6c53ef83 (diff)
downloadslackbuilds-d02d5c81191439f84d80cc42b0cac7453ec6a802.tar.gz
development/MySQL-python: Avoid downloading distribute during build.
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'development')
-rw-r--r--development/MySQL-python/MySQL-python.SlackBuild5
-rw-r--r--development/MySQL-python/no_distribute_download.patch12
2 files changed, 16 insertions, 1 deletions
diff --git a/development/MySQL-python/MySQL-python.SlackBuild b/development/MySQL-python/MySQL-python.SlackBuild
index d006af0263..7c68cb94ca 100644
--- a/development/MySQL-python/MySQL-python.SlackBuild
+++ b/development/MySQL-python/MySQL-python.SlackBuild
@@ -7,7 +7,7 @@
PRGNAM=MySQL-python
VERSION=1.2.4
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -52,6 +52,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+# Avoid downloading distribute
+patch -p1 < $CWD/no_distribute_download.patch
+
python setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
diff --git a/development/MySQL-python/no_distribute_download.patch b/development/MySQL-python/no_distribute_download.patch
new file mode 100644
index 0000000000..2a94802373
--- /dev/null
+++ b/development/MySQL-python/no_distribute_download.patch
@@ -0,0 +1,12 @@
+diff -Naur MySQL-python-1.2.4.orig/setup.py MySQL-python-1.2.4/setup.py
+--- MySQL-python-1.2.4.orig/setup.py 2012-10-08 13:46:54.000000000 +0200
++++ MySQL-python-1.2.4/setup.py 2013-12-06 20:34:36.214964072 +0100
+@@ -3,8 +3,6 @@
+ import os
+ import sys
+
+-from distribute_setup import use_setuptools
+-use_setuptools()
+ from setuptools import setup, Extension
+
+ if not hasattr(sys, "hexversion") or sys.hexversion < 0x02040000: