summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author Matteo Bernardini2013-12-16 10:14:11 +0100
committer Erik Hanson2013-12-17 18:00:31 +0100
commit62789fa15c705e1a5426bc47378caaf89dc2cffd (patch)
treeccc2c5f06d9b2a52ce5ba19004633aa69fa2e75e /development
parent64e3484c8e02bf5f8698dd6c8a8bbea47c05fb30 (diff)
downloadslackbuilds-62789fa15c705e1a5426bc47378caaf89dc2cffd.tar.gz
development/amaya: Removed (not compatible with gcc-4.8.x).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'development')
-rw-r--r--development/amaya/README5
-rw-r--r--development/amaya/amaya.SlackBuild128
-rw-r--r--development/amaya/amaya.desktop9
-rw-r--r--development/amaya/amaya.info20
-rw-r--r--development/amaya/doinst.sh3
-rw-r--r--development/amaya/patches/amaya-fix-thotlib-png14.patch56
-rw-r--r--development/amaya/patches/explicite_linking2.patch24
-rw-r--r--development/amaya/patches/gzread.patch21
-rw-r--r--development/amaya/slack-desc19
9 files changed, 0 insertions, 285 deletions
diff --git a/development/amaya/README b/development/amaya/README
deleted file mode 100644
index f21e1240bc..0000000000
--- a/development/amaya/README
+++ /dev/null
@@ -1,5 +0,0 @@
-amaya (W3 Web Editor)
-
-Amaya is a Web editor, i.e. a tool used to create and update documents
-directly on the Web. Browsing features are seamlessly integrated with
-the editing and remote access features in a uniform environment.
diff --git a/development/amaya/amaya.SlackBuild b/development/amaya/amaya.SlackBuild
deleted file mode 100644
index b59881fddd..0000000000
--- a/development/amaya/amaya.SlackBuild
+++ /dev/null
@@ -1,128 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for amaya
-
-# Copyright 2010 Vincent Batts, vbatts@hashbangbash.com, http://hashbangbash.com/
-# Copyright 2010, 2011 Vincent Batts, Vienna, VA, USA
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-# Modified by the SlackBuilds.org team
-
-PRGNAM=amaya
-VERSION=${VERSION:-11.4.4}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf Amaya${VERSION}
-tar xvf $CWD/$PRGNAM-sources-${VERSION}.tgz
-cd Amaya${VERSION}
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-# Apply some patches (thanks to archlinux)
-for i in $CWD/patches/* ; do patch -p1 < $i ; done
-
-mkdir -p Amaya/build
-cd Amaya/build
- CFLAGS="$SLKCFLAGS" \
- CXXFLAGS="$SLKCFLAGS" \
- ../configure \
- --prefix=/opt \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --mandir=/usr/man \
- --docdir=/usr/doc/$PRGNAM-$VERSION \
- --with-gl \
- --enable-system-wx \
- --enable-system-raptor \
- --build=$ARCH-slackware-linux
- make all || exit 1
- make install DESTDIR=$PKG || exit 1
-cd ..
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-# silly hack to link correctly
-if [ -d $PKG/opt/bin ] ; then
- rm -r $PKG/opt/bin/
-fi
-mkdir -p $PKG/usr/bin
-( cd $PKG/usr/bin/ ; ln -s ../../opt/Amaya/wx/bin/$PRGNAM )
-
-mkdir -p $PKG/usr/share/{applications,pixmaps}
-cat $CWD/$PRGNAM.desktop > $PKG/usr/share/applications/$PRGNAM.desktop
-( cd $PKG/usr/share/pixmaps
- ln -s ../../../opt/Amaya/resources/icons/misc/logo.png amaya.png
-)
-
-# Install the foreign dictionaries (English and French are already there)
-for i in Dutch German Italian Spanish Swedish ; do tar xf $CWD/$i.tgz ; done
-for i in G I N S W ; do
- install -m 0644 -D ${i}princ.dic $PKG/opt/Amaya/dicopar/${i}princ.dic
-done
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/amaya/amaya.desktop b/development/amaya/amaya.desktop
deleted file mode 100644
index ce3931bc1f..0000000000
--- a/development/amaya/amaya.desktop
+++ /dev/null
@@ -1,9 +0,0 @@
-[Desktop Entry]
-Exec=amaya
-Icon=amaya
-Type=Application
-Categories=Network;Development;WebDevelopment;
-Name=Amaya
-GenericName=Web Editor
-MimeType=text/html;text/css;text/x-javascript;text/x-python;text/x-perl;application/x-php;text/x-java;text/javascript;text/x-php;application/x-cgi;application/x-javascript;application/x-perl;application/x-python;application/xhtml+xml;text/mathml;text/x-csrc;text/x-chdr;text/x-dtd;text/x-sql;text/xml;
-X-KDE-StartupNotify=true
diff --git a/development/amaya/amaya.info b/development/amaya/amaya.info
deleted file mode 100644
index 5719c9ceff..0000000000
--- a/development/amaya/amaya.info
+++ /dev/null
@@ -1,20 +0,0 @@
-PRGNAM="amaya"
-VERSION="11.4.4"
-HOMEPAGE="http://www.w3.org/Amaya/"
-DOWNLOAD="http://www.w3.org/Amaya/Distribution/amaya-sources-11.4.4.tgz \
- http://www.w3.org/Amaya/Distribution/Dutch.tgz \
- http://www.w3.org/Amaya/Distribution/German.tgz \
- http://www.w3.org/Amaya/Distribution/Italian.tgz \
- http://www.w3.org/Amaya/Distribution/Spanish.tgz \
- http://www.w3.org/Amaya/Distribution/Swedish.tgz"
-MD5SUM="e8072c7b1d06b983951c56e9f51fbacf \
- 3edb9cce5ce160d7270b23808c1d5981 \
- 400eeeae974a64d23de4fcdd609c30bc \
- 05e2d25ee8af11faaaa25a33da89d504 \
- b504a75cd0f789a3046bf2041067b18b \
- 6536ab2e31e3f58618ba79d9fddc7f76"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="raptor wxPython"
-MAINTAINER="Vincent Batts"
-EMAIL="vbatts@hashbangbash.com"
diff --git a/development/amaya/doinst.sh b/development/amaya/doinst.sh
deleted file mode 100644
index 5fb28930db..0000000000
--- a/development/amaya/doinst.sh
+++ /dev/null
@@ -1,3 +0,0 @@
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
-fi
diff --git a/development/amaya/patches/amaya-fix-thotlib-png14.patch b/development/amaya/patches/amaya-fix-thotlib-png14.patch
deleted file mode 100644
index 2231db2de2..0000000000
--- a/development/amaya/patches/amaya-fix-thotlib-png14.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-diff -aur Amaya11.3.1/Amaya/thotlib/image/pnghandler.c Amaya11.3.1.new/Amaya/thotlib/image/pnghandler.c
---- Amaya11.3.1/Amaya/thotlib/image/pnghandler.c 2009-09-09 11:54:50.000000000 +0200
-+++ Amaya11.3.1.new/Amaya/thotlib/image/pnghandler.c 2010-08-17 20:42:10.823505508 +0200
-@@ -10,9 +10,9 @@
- * R. Guetari (W3C/INRIA) - Initial Windows version
- */
-
-+#include "png.h"
- #include "thot_gui.h"
- #include "thot_sys.h"
--#include "png.h"
- #include "constmedia.h"
- #include "typemedia.h"
- #include "picture.h"
-@@ -128,13 +128,13 @@
- png_byte **ppbRowPointers;
- unsigned char *pixels;
- unsigned int i, j, passes;
-- unsigned long lw, lh;
-+ png_uint_32 lw, lh;
- int iBitDepth, iColorType;
- double dGamma;
-
- /* Checks the eight byte PNG signature*/
- fread (pbSig, 1, 8, pfFile);
-- if (!png_check_sig (pbSig, 8))
-+ if (png_sig_cmp (pbSig, 0, 8))
- return NULL;
- /* create the two png(-info) structures*/
- png_ptr = png_create_read_struct (PNG_LIBPNG_VER_STRING,
-@@ -169,13 +169,13 @@
- png_set_strip_16 (png_ptr);
- /* Grayscale =>RGB or RGBA */
- if (iColorType == PNG_COLOR_TYPE_GRAY || iColorType == PNG_COLOR_TYPE_GRAY_ALPHA)
-- png_set_gray_to_rgb (png_ptr);
-+ png_set_expand_gray_1_2_4_to_8(png_ptr);
- /* Palette indexed colors to RGB */
- if (iColorType == PNG_COLOR_TYPE_PALETTE)
- png_set_palette_to_rgb (png_ptr);
- /* 8 bits / channel is needed */
- if (iColorType == PNG_COLOR_TYPE_GRAY && iBitDepth < 8)
-- png_set_gray_1_2_4_to_8(png_ptr);
-+ png_set_expand_gray_1_2_4_to_8(png_ptr);
- /* all transparency type : 1 color, indexed => alpha channel*/
- if (png_get_valid (png_ptr, info_ptr,PNG_INFO_tRNS))
- png_set_tRNS_to_alpha (png_ptr);
-@@ -822,7 +822,7 @@
- TtaReadClose (fp);
- if (ret != 8)
- return FALSE;
-- ret = png_check_sig ((png_byte*)buf, 8);
-+ ret = !png_sig_cmp ((png_byte*)buf, 0, 8);
- if (ret) return (TRUE);
- return(FALSE);
- }
-
diff --git a/development/amaya/patches/explicite_linking2.patch b/development/amaya/patches/explicite_linking2.patch
deleted file mode 100644
index 8219763488..0000000000
--- a/development/amaya/patches/explicite_linking2.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-diff -Naur Amaya11.3.1.orig/Amaya/amaya/Makefile.in Amaya11.3.1.new/Amaya/amaya/Makefile.in
---- Amaya11.3.1.orig/Amaya/amaya/Makefile.in 2012-01-14 18:53:00.000000000 +0100
-+++ Amaya11.3.1.new/Amaya/amaya/Makefile.in 2012-01-14 18:55:12.000000000 +0100
-@@ -21,7 +21,7 @@
- $(GL_LIBRARIES) $(GTK_GL_LIBRARIES) $(FREETYPE_LIBRARIES) $(XFT_LIBRARIES) \
- $(AMAYA_LIBWWW_LIBS) \
- @AMAYA_RAPTOR_LIBS@ \
-- $(WX_LIBRARIES)
-+ $(WX_LIBRARIES) -lpng14 -ljpeg -lexpat -lwwwssl
-
- AMAYA = @top_srcdir@/amaya
-
-diff -Naur Amaya11.3.1.orig/Amaya/thotlib/Makefile.in Amaya11.3.1.new/Amaya/thotlib/Makefile.in
---- Amaya11.3.1.orig/Amaya/thotlib/Makefile.in 2012-01-14 18:53:00.000000000 +0100
-+++ Amaya11.3.1.new/Amaya/thotlib/Makefile.in 2012-01-14 18:55:45.000000000 +0100
-@@ -351,7 +351,7 @@
-
- ../bin/print : $(THOTK_OBJ) $(DISPLAY_OBJ) $(PRINT_OBJ) \
- ../amaya/libCSS.a
-- $(CXX) $(LDFLAGS) -o $@ $(THOTK_OBJ) $(DISPLAY_OBJ) $(PRINT_OBJ) ../amaya/libCSS.a $(LIBS)
-+ $(CXX) $(LDFLAGS) -o $@ $(THOTK_OBJ) $(DISPLAY_OBJ) $(PRINT_OBJ) ../amaya/libCSS.a $(LIBS) -lpng14 -ljpeg
- @$(ECHO) "====>" print is done
-
- CEXTRACT= ../bin/cextract
diff --git a/development/amaya/patches/gzread.patch b/development/amaya/patches/gzread.patch
deleted file mode 100644
index c2644dc197..0000000000
--- a/development/amaya/patches/gzread.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- Amaya11.4.4/Amaya/amaya/html2thot.c.old 2012-03-07 10:53:27.904494374 +0100
-+++ Amaya11.4.4/Amaya/amaya/html2thot.c 2012-03-07 11:20:46.931113208 +0100
-@@ -4349,7 +4349,7 @@
- WorkBuffer = FileBuffer;
- }
- // need to read a new set of characters
-- LastCharInWorkBuffer = gzread (infile, &FileBuffer[StartOfRead],
-+ LastCharInWorkBuffer = gzread ((gzFile) infile, &FileBuffer[StartOfRead],
- INPUT_FILE_BUFFER_SIZE - StartOfRead);
- // add previous read characters not managed yet
- LastCharInWorkBuffer += StartOfRead;
---- Amaya11.4.4/Amaya/amaya/Xml2thot.c.old 2012-03-07 11:21:30.994445257 +0100
-+++ Amaya11.4.4/Amaya/amaya/Xml2thot.c 2012-03-07 11:22:04.644444274 +0100
-@@ -5847,6 +5847,6 @@
- while (!endOfFile && !XMLNotWellFormed && !XMLInvalidToken)
- {
- /* read the XML file */
-- res = gzread (infile, bufferRead, COPY_BUFFER_SIZE);
-+ res = gzread ((gzFile) infile, bufferRead, COPY_BUFFER_SIZE);
- if (res < 0)
- return;
diff --git a/development/amaya/slack-desc b/development/amaya/slack-desc
deleted file mode 100644
index 9967e9ee67..0000000000
--- a/development/amaya/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-amaya: amaya (W3 Web Editor)
-amaya:
-amaya: Amaya is a Web editor, i.e. a tool used to create and update
-amaya: documents directly on the Web. Browsing features are seamlessly
-amaya: integrated with the editing and remote access features in a
-amaya: uniform environment.
-amaya:
-amaya: Homepage: http://www.w3.org/Amaya/
-amaya:
-amaya:
-amaya: