summaryrefslogtreecommitdiffstats
path: root/development/watchman
diff options
context:
space:
mode:
author B. Watson2021-12-09 22:50:11 +0100
committer B. Watson2021-12-10 08:43:41 +0100
commitc0e7bcadb024065d51f5777c5deb84704cc24d43 (patch)
tree43cf65ef08e2b2b6d0cd214b31872ac543334e7c /development/watchman
parent1b7487eb2969c81bac2be6a852223fd5ea2ebf64 (diff)
downloadslackbuilds-c0e7bcadb024065d51f5777c5deb84704cc24d43.tar.gz
development/watchman: Removed (needs boost-1.69.0, tries to download it).
Diffstat (limited to 'development/watchman')
-rw-r--r--development/watchman/README26
-rw-r--r--development/watchman/slack-desc19
-rw-r--r--development/watchman/watchman.SlackBuild124
-rw-r--r--development/watchman/watchman.info10
4 files changed, 0 insertions, 179 deletions
diff --git a/development/watchman/README b/development/watchman/README
deleted file mode 100644
index e55abe1ff9..0000000000
--- a/development/watchman/README
+++ /dev/null
@@ -1,26 +0,0 @@
-Watchman exists to watch files and record when they change. It can also
-trigger actions (such as rebuilding assets) when matching files change.
-
-Concepts:
-
-- Watchman can recursively watch one or more directory trees (we call
- them roots).
-
-- Watchman does not follow symlinks. It knows they exist, but they show
- up the same as any other file in its reporting.
-
-- Watchman waits for a root to settle down before it will start to
- trigger notifications or command execution.
-
-- Watchman is conservative, preferring to err on the side of caution;
- it considers files to be freshly changed when you start to watch them
- or when it is unsure.
-
-- You can query a root for file changes since you last checked, or the
- current state of the tree.
-
-- You can subscribe to file changes that occur in a root.
-
-Note: this is not the latest version of watchman. Newer versions
-require newer libraries than Slackware 14.2 has, so this build can't
-be upgraded.
diff --git a/development/watchman/slack-desc b/development/watchman/slack-desc
deleted file mode 100644
index 71feb4c4ed..0000000000
--- a/development/watchman/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-watchman: watchman (A file watching service)
-watchman:
-watchman: Watchman exists to watch files and record when they change.
-watchman: It can also trigger actions (such as rebuilding assets) when
-watchman: matching files change.
-watchman:
-watchman: https://facebook.github.io/watchman/
-watchman:
-watchman:
-watchman:
-watchman:
diff --git a/development/watchman/watchman.SlackBuild b/development/watchman/watchman.SlackBuild
deleted file mode 100644
index acf1c18a5b..0000000000
--- a/development/watchman/watchman.SlackBuild
+++ /dev/null
@@ -1,124 +0,0 @@
-#!/bin/bash
-
-# Slackware build script for watchman
-
-# Originally written by:
-# Ryan P.C. McQuen | Everett, WA | <email removed>
-
-# Now maintained by B. Watson <yalhcru@gmail.com>
-
-# This program is free software: you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2 of the License, or
-# (at your option) any later version, with the following exception:
-# the text of the GPL license may be omitted.
-
-# This program is distributed in the hope that it will be useful, but
-# without any warranty; without even the implied warranty of
-# merchantability or fitness for a particular purpose. Compiling,
-# interpreting, executing or merely reading the text of the program
-# may result in lapses of consciousness and/or very being, up to and
-# including the end of all existence and the Universe as we know it.
-# See the GNU General Public License for more details.
-
-# You may have received a copy of the GNU General Public License along
-# with this program (most likely, a file named COPYING). If not, see
-# <https://www.gnu.org/licenses/>.
-
-# 20170819 bkw: update for v4.9.0, BUILD=1
-
-# 20170810 bkw: get rid of /usr/share/doc, BUILD=3
-
-# 20170621 bkw: fix build on -current (--enable-lenient, removes -Werror)
-
-# 20170309 bkw:
-# - take over maintenance
-# - use long-form github URL
-# - /usr/var/run => /var/run
-# - BUILD=2
-
-cd $(dirname $0) ; CWD=$(pwd)
-
-PRGNAM=watchman
-VERSION=${VERSION:-4.9.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-PKGTYPE=${PKGTYPE:-tgz}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
-if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
-fi
-
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
- \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
-
-./autogen.sh
-CC=clang CXX=clang++ \
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure \
- --enable-lenient \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --enable-statedir=/var/run/$PRGNAM \
- --mandir=/usr/man \
- --docdir=/usr/doc/$PRGNAM-$VERSION \
- --build=$ARCH-slackware-linux
-
-make
-make install-strip DESTDIR=$PKG
-
-# don't know how to keep python/setup.py from installing docs here, easier
-# to blow it away after the fact.
-rm -rf $PKG/usr/share
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENSE README.markdown $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/development/watchman/watchman.info b/development/watchman/watchman.info
deleted file mode 100644
index 93c590a973..0000000000
--- a/development/watchman/watchman.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="watchman"
-VERSION="4.9.0"
-HOMEPAGE="https://facebook.github.io/watchman/"
-DOWNLOAD="https://github.com/facebook/watchman/archive/v4.9.0/watchman-4.9.0.tar.gz"
-MD5SUM="d5dc483f70f82d8cd2b0787bbea25ae4"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="B. Watson"
-EMAIL="yalhcru@gmail.com"