summaryrefslogtreecommitdiffstats
path: root/development/tstoolbox
diff options
context:
space:
mode:
author Dimitris Zlatanidis2014-02-18 12:29:11 +0100
committer Erik Hanson2014-02-18 21:59:56 +0100
commitf6819ce1afe3e08b17cb546ff462b7c492519c02 (patch)
treeb36885e04ac45d1d389bcccb2016a6d851c3918d /development/tstoolbox
parent27b5237b601250b2589b132a740a115a80113385 (diff)
downloadslackbuilds-f6819ce1afe3e08b17cb546ff462b7c492519c02.tar.gz
development/tstoolbox: Added (manipulate time series files).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'development/tstoolbox')
-rw-r--r--development/tstoolbox/README2
-rw-r--r--development/tstoolbox/slack-desc19
-rw-r--r--development/tstoolbox/tstoolbox.SlackBuild85
-rw-r--r--development/tstoolbox/tstoolbox.info10
4 files changed, 116 insertions, 0 deletions
diff --git a/development/tstoolbox/README b/development/tstoolbox/README
new file mode 100644
index 0000000000..d1d65afb57
--- /dev/null
+++ b/development/tstoolbox/README
@@ -0,0 +1,2 @@
+The tstoolbox is a Python script to manipulate time-series on
+the command line or by function calls within Python.
diff --git a/development/tstoolbox/slack-desc b/development/tstoolbox/slack-desc
new file mode 100644
index 0000000000..c470a44363
--- /dev/null
+++ b/development/tstoolbox/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+tstoolbox: tstoolbox (manipulate time series files)
+tstoolbox:
+tstoolbox: The tstoolbox is a Python script to manipulate time-series on the
+tstoolbox: command line or by function calls within Python.
+tstoolbox:
+tstoolbox: Homepage: http://pypi.python.org/pypi/tstoolbox
+tstoolbox:
+tstoolbox:
+tstoolbox:
+tstoolbox:
+tstoolbox:
diff --git a/development/tstoolbox/tstoolbox.SlackBuild b/development/tstoolbox/tstoolbox.SlackBuild
new file mode 100644
index 0000000000..51263011d5
--- /dev/null
+++ b/development/tstoolbox/tstoolbox.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+
+# Slackware build script for 0.8.2
+
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=tstoolbox
+VERSION=${VERSION:-0.8.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a *.rst LICENSE.txt PKG-INFO VERSION $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/tstoolbox/tstoolbox.info b/development/tstoolbox/tstoolbox.info
new file mode 100644
index 0000000000..66e58ab003
--- /dev/null
+++ b/development/tstoolbox/tstoolbox.info
@@ -0,0 +1,10 @@
+PRGNAM="tstoolbox"
+VERSION="0.8.2"
+HOMEPAGE="http://pypi.python.org/pypi/tstoolbox"
+DOWNLOAD="https://pypi.python.org/packages/source/t/tstoolbox/tstoolbox-0.8.2.tar.gz"
+MD5SUM="079956ace60d5ed97c7f2c67cf522d55"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pandas python-dateutil Baker"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"