summaryrefslogtreecommitdiffstats
path: root/development/pudb
diff options
context:
space:
mode:
author Rudson R. Alves2013-06-30 21:20:24 +0200
committer Erik Hanson2013-06-30 21:20:24 +0200
commit697a4c02f6763e98200e8f905e9cf65f85b09d04 (patch)
tree997c4c076285b81226ae36c5d9a800f97f1df0aa /development/pudb
parentc8549aa149d41b27ce5a50ea598968729d03544e (diff)
downloadslackbuilds-697a4c02f6763e98200e8f905e9cf65f85b09d04.tar.gz
development/pudb: Added (A full-screen, console-based Python debugger)
Signed-off-by: Erik Hanson <erik@slackbuilds.org>
Diffstat (limited to 'development/pudb')
-rw-r--r--development/pudb/README7
-rw-r--r--development/pudb/pudb.SlackBuild69
-rw-r--r--development/pudb/pudb.info11
-rw-r--r--development/pudb/slack-desc20
4 files changed, 107 insertions, 0 deletions
diff --git a/development/pudb/README b/development/pudb/README
new file mode 100644
index 0000000000..9cafb649d7
--- /dev/null
+++ b/development/pudb/README
@@ -0,0 +1,7 @@
+PuDB is a full-screen, console-based visual debugger for Python.
+
+Its goal is to provide all the niceties of modern GUI-based debuggers in a
+more lightweight and keyboard-friendly package. PuDB allows you to debug
+code right where you write and test it--in a terminal. If you've worked
+with the excellent (but nowadays ancient) DOS-based Turbo Pascal or C
+tools, PuDB's UI might look familiar.
diff --git a/development/pudb/pudb.SlackBuild b/development/pudb/pudb.SlackBuild
new file mode 100644
index 0000000000..a2a6987a1e
--- /dev/null
+++ b/development/pudb/pudb.SlackBuild
@@ -0,0 +1,69 @@
+#!/bin/sh
+#
+# Slackware build script for pudb
+#
+# Written by Rudson R. Alves rudsonalves@yahoo.com.br
+
+PRGNAM=pudb
+VERSION=${VERSION:-2013.3.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ MANIFEST.in PKG-INFO README.rst \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/pudb/pudb.info b/development/pudb/pudb.info
new file mode 100644
index 0000000000..47f0b01508
--- /dev/null
+++ b/development/pudb/pudb.info
@@ -0,0 +1,11 @@
+PRGNAM="pudb"
+VERSION="2013.3.2"
+HOMEPAGE="https://pypi.python.org/pypi/pudb"
+DOWNLOAD="https://pypi.python.org/packages/source/p/pudb/pudb-2013.3.2.tar.gz"
+MD5SUM="aacca6e45b664914a1f514e3580d1d65"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Rudson R. Alves"
+EMAIL="rudsonalves@yahoo.com.br"
+APPROVED=""
diff --git a/development/pudb/slack-desc b/development/pudb/slack-desc
new file mode 100644
index 0000000000..12c4aacf76
--- /dev/null
+++ b/development/pudb/slack-desc
@@ -0,0 +1,20 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler---------------------------------------------------------|
+pudb: pudb (A full-screen, console-based Python debugger)
+pudb:
+pudb: PuDB is a full-screen, console-based visual debugger for Python.
+pudb:
+pudb: Its goal is to provide all the niceties of modern GUI-based debuggers
+pudb: in a more lightweight and keyboard-friendly package. PuDB allows you to
+pudb: debug code right where you write and test it--in a terminal.
+pudb:
+pudb: If you've worked with the excellent (but nowadays ancient) DOS-based
+pudb: Turbo Pascal or C tools, PuDB's UI might look familiar.
+pudb:
+pudb: