summaryrefslogtreecommitdiffstats
path: root/development/lua52
diff options
context:
space:
mode:
author Matteo Bernardini2016-12-28 15:47:16 +0100
committer Willy Sudiarto Raharjo2016-12-31 02:22:27 +0100
commit9389d02c19e3d1641d81f8b2ffc272631b53d963 (patch)
tree7a5ee27163b5c93852d891e0c768505220ff76e5 /development/lua52
parentd417536442a961997eca62c2a1da4a403f2b151b (diff)
downloadslackbuilds-9389d02c19e3d1641d81f8b2ffc272631b53d963.tar.gz
development/lua52: Removed.
...until a working way to manage multiple lua versions in the system is provided Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'development/lua52')
-rw-r--r--development/lua52/README9
-rw-r--r--development/lua52/lua.pc31
-rw-r--r--development/lua52/lua52.SlackBuild106
-rw-r--r--development/lua52/lua52.info10
-rw-r--r--development/lua52/slack-desc19
5 files changed, 0 insertions, 175 deletions
diff --git a/development/lua52/README b/development/lua52/README
deleted file mode 100644
index ec843498c2..0000000000
--- a/development/lua52/README
+++ /dev/null
@@ -1,9 +0,0 @@
-Lua is a free software light-weight programming language designed
-for extending applications. Lua is also frequently used as a
-general-purpose, stand-alone scripting language.
-
-* WARNING *
-This package is just for the slackware users needing the 5.2.x
-version: it is not compatible with the 5.1.x one (install
-just one version of the two) and with most of the software
-that needs lua on slackbuilds.org.
diff --git a/development/lua52/lua.pc b/development/lua52/lua.pc
deleted file mode 100644
index 7d8a1abf40..0000000000
--- a/development/lua52/lua.pc
+++ /dev/null
@@ -1,31 +0,0 @@
-# lua.pc -- pkg-config data for Lua
-
-# vars from install Makefile
-
-# grep '^V=' ../Makefile
-V= 5.2
-# grep '^R=' ../Makefile
-R= 5.2.0
-
-# grep '^INSTALL_.*=' ../Makefile | sed 's/INSTALL_TOP/prefix/'
-prefix= /usr
-INSTALL_BIN= ${prefix}/bin
-INSTALL_INC= ${prefix}/include
-INSTALL_LIB= ${prefix}/lib
-INSTALL_MAN= ${prefix}/man/man1
-INSTALL_LMOD= ${prefix}/share/lua/${V}
-INSTALL_CMOD= ${prefix}/lib/lua/${V}
-
-# canonical vars
-exec_prefix=${prefix}
-libdir=${exec_prefix}/lib
-includedir=${prefix}/include
-
-Name: Lua
-Description: An Extensible Extension Language
-Version: ${R}
-Requires:
-Libs: -L${libdir} -llua -lm
-Cflags: -I${includedir}
-
-# (end of lua.pc)
diff --git a/development/lua52/lua52.SlackBuild b/development/lua52/lua52.SlackBuild
deleted file mode 100644
index 01d100186a..0000000000
--- a/development/lua52/lua52.SlackBuild
+++ /dev/null
@@ -1,106 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for Lua
-
-# Written by Menno Duursma
-# Modified by the SlackBuilds.org project
-# Modified by Aaron W. Hsu
-# Adapted by Matteo Bernardini for version 5.2.x
-
-# This program is free software. It comes without any warranty.
-# Granted WTFPL, Version 2, as published by Sam Hocevar. See
-# http://sam.zoy.org/wtfpl/COPYING for more details.
-
-PRGNAM=lua52
-VERSION=${VERSION:-5.2.3}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-SRCNAM=lua
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $SRCNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-
-# Fix up a to-be-installed header
-sed -i "s|/usr/local|/usr|" src/luaconf.h
-sed -i "s|lib/lua|lib$LIBDIRSUFFIX/lua|" src/luaconf.h
-
-make linux \
- MYLIBS="-lncurses" \
- CFLAGS="$SLKCFLAGS \$(MYCFLAGS) -DLUA_COMPAT_ALL -DLUA_USE_LINUX" \
- INSTALL_TOP=/usr \
- INSTALL_LIB=/usr/lib${LIBDIRSUFFIX} \
- INSTALL_CMOD=/usr/lib${LIBDIRSUFFIX}/lua/5.2
-
-make linux install \
- MYLIBS="-lncurses" \
- CFLAGS="$SLKCFLAGS \$(MYCFLAGS) -DLUA_COMPAT_ALL -DLUA_USE_LINUX" \
- INSTALL_TOP=$PKG/usr \
- INSTALL_LIB=$PKG/usr/lib${LIBDIRSUFFIX} \
- INSTALL_CMOD=$PKG/usr/lib${LIBDIRSUFFIX}/lua/5.2
-
-# Now let's build the shared library
-mkdir -p shared
-cd shared
- ar -x $PKG/usr/lib${LIBDIRSUFFIX}/liblua.a
- gcc -ldl -lreadline -lhistory -lncurses -lm -shared *.o -o liblua.so.5.2.0
- cp -a liblua.so.5.2.0 $PKG/usr/lib${LIBDIRSUFFIX}
- ( cd $PKG/usr/lib${LIBDIRSUFFIX}
- ln -s liblua.so.5.2.0 liblua.so.5.2
- ln -s liblua.so.5.2.0 liblua.so.5
- ln -s liblua.so.5.2.0 liblua.so
- )
-cd ..
-
-# and install the pkgconfig file
-mkdir -p $PKG/usr/lib${LIBDIRSUFFIX}/pkgconfig
-cat $CWD/lua.pc | sed "s|prefix}/lib|prefix}/lib${LIBDIRSUFFIX}|g" \
- > $PKG/usr/lib${LIBDIRSUFFIX}/pkgconfig/lua.pc
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/html
-cp -a README $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a doc/*.html doc/logo.gif doc/lua.css $PKG/usr/doc/$PRGNAM-$VERSION/html
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/lua52/lua52.info b/development/lua52/lua52.info
deleted file mode 100644
index 6ab7fc2c9f..0000000000
--- a/development/lua52/lua52.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="lua52"
-VERSION="5.2.3"
-HOMEPAGE="http://www.lua.org"
-DOWNLOAD="http://www.lua.org/ftp/lua-5.2.3.tar.gz"
-MD5SUM="dc7f94ec6ff15c985d2d6ad0f1b35654"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Matteo Bernardini"
-EMAIL="ponce@slackbuilds.org"
diff --git a/development/lua52/slack-desc b/development/lua52/slack-desc
deleted file mode 100644
index a69568c49d..0000000000
--- a/development/lua52/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-lua52: lua52 (a powerful, fast, light-weight, embeddable scripting language)
-lua52:
-lua52: Lua combines simple procedural syntax with powerful data description
-lua52: constructs based on associative arrays and extensible semantics.
-lua52: Lua is dynamically typed, runs by interpreting bytecode for a
-lua52: register-based virtual machine, and has automatic memory management
-lua52: with incremental garbage collection, making it ideal for
-lua52: configuration, scripting, and rapid prototyping.
-lua52:
-lua52: This package installs the 5.2.x version.
-lua52: