summaryrefslogtreecommitdiffstats
path: root/development/lazarus
diff options
context:
space:
mode:
author B. Watson2021-09-05 22:13:15 +0200
committer Willy Sudiarto Raharjo2021-10-12 19:52:00 +0200
commitb6fd3d69e278d64a8b4b0d4819d01a35bb12cf09 (patch)
tree69bef7bfc391f4a00575f03b07ff36c8609aaa57 /development/lazarus
parenta69b0c879250b4edc0126c31121f031a6b45bd1d (diff)
downloadslackbuilds-b6fd3d69e278d64a8b4b0d4819d01a35bb12cf09.tar.gz
development/lazarus: Updated for version 2.0.12, new maintainer.
Signed-off-by: B. Watson <yalhcru@gmail.com> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'development/lazarus')
-rw-r--r--development/lazarus/README2
-rw-r--r--development/lazarus/lazarus.SlackBuild45
-rw-r--r--development/lazarus/lazarus.info14
-rw-r--r--development/lazarus/slack-desc2
4 files changed, 43 insertions, 20 deletions
diff --git a/development/lazarus/README b/development/lazarus/README
index 962953e383..b4018e6b92 100644
--- a/development/lazarus/README
+++ b/development/lazarus/README
@@ -1,3 +1,5 @@
+lazarus (rapid application development tool for freepascal)
+
Lazarus is a Rapid Application Development Tool for FreePascal. It
comes with the LCL - Lazarus Component Library, which contains platform
independent visual components like buttons, windows, checkbox, treeview
diff --git a/development/lazarus/lazarus.SlackBuild b/development/lazarus/lazarus.SlackBuild
index 11b00e1d66..f0b5b59e27 100644
--- a/development/lazarus/lazarus.SlackBuild
+++ b/development/lazarus/lazarus.SlackBuild
@@ -2,7 +2,8 @@
# Slackware build script for Lazarus IDE
-# Written by Andre Barboza <bmg.andre@gmail.com>
+# Written by Andre Barboza <email removed>
+# Now maintained by B. Watson <yalhcru@gmail.com>
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
@@ -21,19 +22,22 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20210905 bkw:
+# - take over maintenance
+# - update for v2.0.12
+# - get rid of fpc-source dep; include the source in this package
+
cd $(dirname $0) ; CWD=$(pwd)
PRGNAM=lazarus
-VERSION=${VERSION:-2.0.6}
+VERSION=${VERSION:-2.0.12}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
PKGTYPE=${PKGTYPE:-tgz}
+FPCVER=${FPCVER:-3.2.2}
LCL=${LCL:-gtk2}
-# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
-# the name of the created package would be, and then exit. This information
-# could be useful to other scripts.
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
exit 0
@@ -57,18 +61,20 @@ fi
set -e
+fixperms() {
+ chown -R root:root .
+ find -L . -type l -o \
+ -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
+}
+
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+fixperms
sed -i -e 's:share/man:man:' install/man/Makefile
@@ -89,8 +95,21 @@ make install \
ln -sf ../share/lazarus/startlazarus
)
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+find $PKG -print0 -type f -a -perm /111 | \
+ xargs -0 file -m /etc/file/magic/elf | \
+ grep -e "executable" -e "shared object" | \
+ grep ELF | \
+ cut -f 1 -d : | \
+ xargs strip --strip-unneeded 2> /dev/null || true
+
+# 20210905 bkw: Nothing used fpc-source but lazarus, so just include
+# the source here.
+mkdir -p $PKG/usr/src
+( cd $PKG/usr/src
+ tar xvf $CWD/fpc-$FPCVER.source.tar.gz
+ fixperms
+ ln -s fpc-$FPCVER fpc
+)
# Install desktop file, icon, and mime entry
mkdir -p $PKG/usr/share/{applications,pixmaps,mime/packages}
diff --git a/development/lazarus/lazarus.info b/development/lazarus/lazarus.info
index 2f094c1ea1..d14cd7ecbd 100644
--- a/development/lazarus/lazarus.info
+++ b/development/lazarus/lazarus.info
@@ -1,10 +1,12 @@
PRGNAM="lazarus"
-VERSION="2.0.6"
+VERSION="2.0.12"
HOMEPAGE="http://www.lazarus.freepascal.org/"
-DOWNLOAD="http://downloads.sourceforge.net/lazarus/lazarus-2.0.6.tar.gz"
-MD5SUM="2e7006ae8af2c52f7e4db0039bf1c6af"
+DOWNLOAD="http://downloads.sourceforge.net/lazarus/lazarus-2.0.12.tar.gz \
+ https://downloads.sourceforge.net/freepascal/fpc-3.2.2.source.tar.gz"
+MD5SUM="208dfeb20c528649d2598cc0eb341309 \
+ e7649ad0fc9230fdd9493a7fcabbd426"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="fpc fpc-source"
-MAINTAINER="Capi X."
-EMAIL="capi_x@haibane.org"
+REQUIRES="fpc"
+MAINTAINER="B. Watson"
+EMAIL="yalhcru@gmail.com"
diff --git a/development/lazarus/slack-desc b/development/lazarus/slack-desc
index e6b8d70594..8872f667bc 100644
--- a/development/lazarus/slack-desc
+++ b/development/lazarus/slack-desc
@@ -6,7 +6,7 @@
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
-lazarus: lazarus (Rapid Application Development Tool for FreePascal)
+lazarus: lazarus (rapid application development tool for freepascal)
lazarus:
lazarus: Lazarus is a Rapid Application Development Tool for FreePascal.
lazarus: It comes with the LCL - Lazarus component library, which contains