summaryrefslogtreecommitdiffstats
path: root/development/jupyter-qtconsole
diff options
context:
space:
mode:
author Benjamin Trigona-Harany2017-01-24 01:15:21 +0100
committer David Spencer2017-01-24 01:21:57 +0100
commit4cae9ccdb20ebb5013beb0803e0b2a5d28c1be70 (patch)
tree9c2045fbb3517ad0c33945b3f81a92beef27f1d2 /development/jupyter-qtconsole
parent23d95a53cf0b655c54062dae0abbda058ce77e3e (diff)
downloadslackbuilds-4cae9ccdb20ebb5013beb0803e0b2a5d28c1be70.tar.gz
development/jupyter-qtconsole: Added (Jupyter Qt Console).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'development/jupyter-qtconsole')
-rw-r--r--development/jupyter-qtconsole/README7
-rw-r--r--development/jupyter-qtconsole/jupyter-qtconsole.SlackBuild88
-rw-r--r--development/jupyter-qtconsole/jupyter-qtconsole.info10
-rw-r--r--development/jupyter-qtconsole/slack-desc19
4 files changed, 124 insertions, 0 deletions
diff --git a/development/jupyter-qtconsole/README b/development/jupyter-qtconsole/README
new file mode 100644
index 0000000000..5daba3c8f0
--- /dev/null
+++ b/development/jupyter-qtconsole/README
@@ -0,0 +1,7 @@
+jupyter-qtconsole provides a rich Qt-based console for working with Jupyter
+kernels, supporting rich media output, session export, and more.
+
+The Qt console is a very lightweight application that largely feels like a
+terminal, but provides a number of enhancements only possible in a GUI, such as
+inline figures, proper multiline editing with syntax highlighting, graphical
+calltips, and more.
diff --git a/development/jupyter-qtconsole/jupyter-qtconsole.SlackBuild b/development/jupyter-qtconsole/jupyter-qtconsole.SlackBuild
new file mode 100644
index 0000000000..4717d6a37e
--- /dev/null
+++ b/development/jupyter-qtconsole/jupyter-qtconsole.SlackBuild
@@ -0,0 +1,88 @@
+#!/bin/sh
+
+# Slackware build script for jupyter-qtconsole
+
+# Copyright 2017 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+SRCNAM=qtconsole
+PRGNAM=jupyter-$SRCNAM
+VERSION=${VERSION:-4.2.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ COPYING.md README.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/jupyter-qtconsole/jupyter-qtconsole.info b/development/jupyter-qtconsole/jupyter-qtconsole.info
new file mode 100644
index 0000000000..5dd4c13d0d
--- /dev/null
+++ b/development/jupyter-qtconsole/jupyter-qtconsole.info
@@ -0,0 +1,10 @@
+PRGNAM="jupyter-qtconsole"
+VERSION="4.2.1"
+HOMEPAGE="https://jupyter.org/"
+DOWNLOAD="https://pypi.python.org/packages/2b/94/ed3d11ab0ceac135f22fe418a9d5f99c4a071f74b5bd46c4f2ede65eafb1/qtconsole-4.2.1.tar.gz"
+MD5SUM="c08ebebc7a60629ebadf685361ca0798"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="jupyter-ipykernel"
+MAINTAINER="Benjamin Trigona-Harany"
+EMAIL="slackbuilds@jaxartes.net"
diff --git a/development/jupyter-qtconsole/slack-desc b/development/jupyter-qtconsole/slack-desc
new file mode 100644
index 0000000000..04b30c5c93
--- /dev/null
+++ b/development/jupyter-qtconsole/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+jupyter-qtconsole: jupyter-qtconsole (Jupyter Qt Console)
+jupyter-qtconsole:
+jupyter-qtconsole: jupyter-qtconsole jupyter-qtconsole provides a rich Qt-based console
+jupyter-qtconsole: for working with Jupyter kernels, supporting rich media output,
+jupyter-qtconsole: session export, and more.
+jupyter-qtconsole:
+jupyter-qtconsole:
+jupyter-qtconsole:
+jupyter-qtconsole:
+jupyter-qtconsole:
+jupyter-qtconsole: