summaryrefslogtreecommitdiffstats
path: root/development/gnuradio
diff options
context:
space:
mode:
author Matteo Bernardini2020-01-26 12:12:46 +0100
committer Matteo Bernardini2020-01-26 12:12:46 +0100
commit5c6dca884b084906c44487685b3076b1af9535e5 (patch)
tree539e39579797fc68f887f55276d1d3a18b2e2107 /development/gnuradio
parent192ba2be163f6c90f8b56e4d4a59c6b7ef3b1b5c (diff)
downloadslackbuilds-5c6dca884b084906c44487685b3076b1af9535e5.tar.gz
20200126.1 global branch merge.current-20200126.1
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'development/gnuradio')
-rw-r--r--development/gnuradio/boost-1.70.0.patch36
-rw-r--r--development/gnuradio/gnuradio.SlackBuild2
2 files changed, 38 insertions, 0 deletions
diff --git a/development/gnuradio/boost-1.70.0.patch b/development/gnuradio/boost-1.70.0.patch
new file mode 100644
index 0000000000..6d46598525
--- /dev/null
+++ b/development/gnuradio/boost-1.70.0.patch
@@ -0,0 +1,36 @@
+From c01473bf00b73ba1dd72813fbc4c4c5d0f66d339 Mon Sep 17 00:00:00 2001
+From: Michael Dickens <michael.dickens@ettus.com>
+Date: Thu, 23 May 2019 10:26:00 -0400
+Subject: [PATCH] blocks: simple fix for Boost 1.70.0 in socket_pdu
+
+NOTE: There have been multiple fixes proposed, such as
+https://github.com/gnuradio/gnuradio/pull/2451 .
+This one is the simplest and most compatible.
+---
+ gr-blocks/lib/socket_pdu_impl.cc | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/gr-blocks/lib/socket_pdu_impl.cc b/gr-blocks/lib/socket_pdu_impl.cc
+index e20f1478f0..168d74ebb2 100644
+--- a/gr-blocks/lib/socket_pdu_impl.cc
++++ b/gr-blocks/lib/socket_pdu_impl.cc
+@@ -1,6 +1,6 @@
+ /* -*- c++ -*- */
+ /*
+- * Copyright 2013 Free Software Foundation, Inc.
++ * Copyright 2013,2019 Free Software Foundation, Inc.
+ *
+ * This file is part of GNU Radio
+ *
+@@ -165,7 +165,11 @@ namespace gr {
+ void
+ socket_pdu_impl::start_tcp_accept()
+ {
++#if (BOOST_VERSION >= 107000)
++ tcp_connection::sptr new_connection = tcp_connection::make(d_io_service, d_rxbuf.size(), d_tcp_no_delay);
++#else
+ tcp_connection::sptr new_connection = tcp_connection::make(d_acceptor_tcp->get_io_service(), d_rxbuf.size(), d_tcp_no_delay);
++#endif
+
+ d_acceptor_tcp->async_accept(new_connection->socket(),
+ boost::bind(&socket_pdu_impl::handle_tcp_accept, this,
diff --git a/development/gnuradio/gnuradio.SlackBuild b/development/gnuradio/gnuradio.SlackBuild
index 0c395d8a07..8b42897f6f 100644
--- a/development/gnuradio/gnuradio.SlackBuild
+++ b/development/gnuradio/gnuradio.SlackBuild
@@ -73,6 +73,8 @@ find -L . \
# install docs in the right place
sed -i "s|\${GR_DATA_DIR}/doc|doc|" CMakeLists.txt
+patch -p1 < $CWD/boost-1.70.0.patch
+
mkdir -p build
cd build
cmake \