summaryrefslogtreecommitdiffstats
path: root/development/git-cola
diff options
context:
space:
mode:
author Ricardo J. Barberis2018-03-20 12:08:17 +0100
committer David Spencer2018-03-20 12:08:51 +0100
commitf089409e20a59dd661ee55a30174f624f8df79d5 (patch)
tree60d170ac926c081061842bfe09dee147379ab5c4 /development/git-cola
parentab30d7abec76dbf2b7ea4f8a9b732ca9aeca41c8 (diff)
downloadslackbuilds-f089409e20a59dd661ee55a30174f624f8df79d5.tar.gz
development/git-cola: Updated for version 3.0 + new maintainer.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'development/git-cola')
-rw-r--r--development/git-cola/README20
-rw-r--r--development/git-cola/doinst.sh10
-rw-r--r--development/git-cola/git-cola.SlackBuild21
-rw-r--r--development/git-cola/git-cola.info14
4 files changed, 54 insertions, 11 deletions
diff --git a/development/git-cola/README b/development/git-cola/README
index 84bd80501c..b771bc1e12 100644
--- a/development/git-cola/README
+++ b/development/git-cola/README
@@ -1 +1,21 @@
git-cola is a Python-powered GPL licensed GUI for git.
+
+Qt4 warning, the website says:
+
+"NOTE: We do not yet recommend using PyQt5 because there are known
+exit-on-segfault bugs in Qt5 that have not yet been addressed. git-cola
+is sensitive to this bug and is known to crash on exit when using git dag
+or the interactive rebase feature on PyQt5.
+
+QTBUG-52988 (https://bugreports.qt.io/browse/QTBUG-52988)
+
+PyQt4 is stable and there are no known issues when using it so we
+recommend using PyQt4 until the Qt5 bugs have been resolved.
+
+Set QT_API=pyqt4 in your environment if you have both versions of PyQt
+installed and want to ensure that PyQt4 is used.
+
+NOTE: git-cola includes a vendored copy of its QtPy dependency."
+
+That said, if you set QT_API=pyqt4 git-cola segfaults, but it works fine
+with Qt5 and PyQt5 from AlienBOB's repository.
diff --git a/development/git-cola/doinst.sh b/development/git-cola/doinst.sh
index 5fb28930db..aea0f894eb 100644
--- a/development/git-cola/doinst.sh
+++ b/development/git-cola/doinst.sh
@@ -1,3 +1,13 @@
if [ -x /usr/bin/update-desktop-database ]; then
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
fi
+
+if [ -x /usr/bin/update-mime-database ]; then
+ /usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/development/git-cola/git-cola.SlackBuild b/development/git-cola/git-cola.SlackBuild
index da71d00c2d..78d159b01f 100644
--- a/development/git-cola/git-cola.SlackBuild
+++ b/development/git-cola/git-cola.SlackBuild
@@ -4,14 +4,16 @@
# Written by Andrew Rowland <darowland@ieee.org>
+# Copyright (c) 2017-2018, Modified by: Ricardo J. Barberis <ricardo.barberis@gmail.com>
+
PRGNAM=git-cola
-VERSION=${VERSION:-2.1.0}
+VERSION=${VERSION:-3.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -22,8 +24,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -53,12 +55,23 @@ find -L . \
python setup.py install --root=$PKG
+make DESTDIR=$PKG prefix=/usr install
+make DESTDIR=$PKG prefix=/usr install-doc
+make DESTDIR=$PKG prefix=/usr install-html
+
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+mv $PKG/usr/share/man $PKG/usr/
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a COPYING COPYRIGHT README.md $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+mv $PKG/usr/share/doc/$PRGNAM/* $PKG/usr/doc/$PRGNAM-$VERSION
+rmdir $PKG/usr/share/doc/$PRGNAM
+rmdir $PKG/usr/share/doc
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
diff --git a/development/git-cola/git-cola.info b/development/git-cola/git-cola.info
index 7d1d4f8a07..0b1be492bd 100644
--- a/development/git-cola/git-cola.info
+++ b/development/git-cola/git-cola.info
@@ -1,10 +1,10 @@
PRGNAM="git-cola"
-VERSION="2.1.0"
-HOMEPAGE="http://git-cola.github.com/index.html"
-DOWNLOAD="https://github.com/git-cola/git-cola/archive/v2.1.0.tar.gz"
-MD5SUM="558b13020ed12d7b491d9a7dc101e065"
+VERSION="3.0"
+HOMEPAGE="https://git-cola.github.io/"
+DOWNLOAD="https://github.com/git-cola/git-cola/archive/v3.0/git-cola-3.0.tar.gz"
+MD5SUM="879c5e6dcc47d73c18e0f3520516d66d"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Andrew Rowland"
-EMAIL="darowland@ieee.org"
+REQUIRES="Sphinx"
+MAINTAINER="Ricardo J. Barberis"
+EMAIL="ricardo.barberis@gmail.com"