summaryrefslogtreecommitdiffstats
path: root/development/fortls
diff options
context:
space:
mode:
author Erich Ritz2023-09-27 06:34:19 +0200
committer Willy Sudiarto Raharjo2023-09-27 06:34:19 +0200
commitfe12b013d98a4c51cc4312e1bb14cbafa6c8e995 (patch)
tree3e5cdd6a474e64f76c3f6550642579ac7c17abf9 /development/fortls
parent6285babb90cf78952aecd9dd03eb8e0d1338292d (diff)
downloadslackbuilds-fe12b013d98a4c51cc4312e1bb14cbafa6c8e995.tar.gz
development/fortls: Added (Modern Language Server).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'development/fortls')
-rw-r--r--development/fortls/README35
-rw-r--r--development/fortls/fortls.SlackBuild77
-rw-r--r--development/fortls/fortls.info10
-rw-r--r--development/fortls/slack-desc19
4 files changed, 141 insertions, 0 deletions
diff --git a/development/fortls/README b/development/fortls/README
new file mode 100644
index 0000000000..f1d769c1ef
--- /dev/null
+++ b/development/fortls/README
@@ -0,0 +1,35 @@
+fortls is an implementation of the Language Server Protocol for Fortran
+using Python (3.7+).
+
+All code editors that support LSP can integrate with fortls; see the
+section Editor Integration in the documentation. Some supported code
+editors include: Visual Studio Code, Atom, Sublime Text, (Neo)Vim, and
+Emacs.
+
+Features:
+ * Project-wide and Document symbol detection and Renaming
+ * Hover support, Signature help and Auto-completion
+ * GoTo/Peek implementation and Find/Peek references
+ * Preprocessor support
+ * Documentation parsing (Doxygen and FORD styles)
+ * Access to multiple intrinsic modules and functions
+ * ISO_FORTRAN_ENV GCC 11.2.0
+ * ISO_C_BINDING GCC 11.2.0
+ * IEEE_EXCEPTIONS, IEEE_ARITHMETIC, IEEE_FEATURES GCC 11.2.0
+ * OpenMP OMP_LIB, OMP_LIB_KINDS v5.0
+ * OpenACC OPENACC, OPENACC_KINDS v3.1
+ * Diagnostics
+ * Multiple definitions with the same variable name
+ * Variable definition masks definition from parent scope
+ * Missing subroutine/function arguments
+ * Unknown user-defined type used in TYPE/CLASS definition (only if
+ visible in project)
+ * Unclosed blocks/scopes
+ * Invalid scope nesting
+ * Unknown modules in USE statement
+ * Unimplemented deferred type-bound procedures
+ * Use of non-imported variables/objects in interface blocks
+ * Statement placement errors (CONTAINS, IMPLICIT, IMPORT)
+ * Code actions
+ * Generate type-bound procedures and implementation templates for
+ deferred procedures
diff --git a/development/fortls/fortls.SlackBuild b/development/fortls/fortls.SlackBuild
new file mode 100644
index 0000000000..443c1c1579
--- /dev/null
+++ b/development/fortls/fortls.SlackBuild
@@ -0,0 +1,77 @@
+#!/bin/bash
+
+# Slackware build script for fortls
+
+# Copyright 2023 Erich Ritz, Jenks, Oklahoma, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=fortls
+VERSION=${VERSION:-2.13.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ CHANGELOG.md LICENSE README.md SECURITY.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/development/fortls/fortls.info b/development/fortls/fortls.info
new file mode 100644
index 0000000000..23125357e3
--- /dev/null
+++ b/development/fortls/fortls.info
@@ -0,0 +1,10 @@
+PRGNAM="fortls"
+VERSION="2.13.0"
+HOMEPAGE="https://fortls.fortran-lang.org"
+DOWNLOAD="https://files.pythonhosted.org/packages/38/04/db988efbcaac142999af91888e9750dfa422108a318ec3038c2cd42ecf04/fortls-2.13.0.tar.gz"
+MD5SUM="b48ded0a49d364cc029591547a16703d"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3-json5"
+MAINTAINER="Erich Ritz"
+EMAIL="erich.public@protonmail.com"
diff --git a/development/fortls/slack-desc b/development/fortls/slack-desc
new file mode 100644
index 0000000000..6645096d68
--- /dev/null
+++ b/development/fortls/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+fortls: fortls (A modern Language Server for Fortran)
+fortls:
+fortls: fortls is an implementation of the Language Server Protocol for
+fortls: Fortran using Python (3.7+).
+fortls:
+fortls: All code editors that support LSP can integrate with fortls; see the
+fortls: section Editor Integration in the documentation. Some supported code
+fortls: editors include: Visual Studio Code, Atom, Sublime Text, (Neo)Vim, and
+fortls: Emacs.
+fortls:
+fortls: Homepage: https://fortls.fortran-lang.org