summaryrefslogtreecommitdiffstats
path: root/development/bsdiff
diff options
context:
space:
mode:
author B. Watson2018-12-11 10:37:30 +0100
committer Willy Sudiarto Raharjo2018-12-15 14:44:28 +0100
commit7e1284e7a9fc58e8bd40bf1016511258a8a9c15a (patch)
treef3bfdecbdaf5e829589fbadc01aae04ce6504822 /development/bsdiff
parente78d03870bfa8916f50c947e683f015141d1886b (diff)
downloadslackbuilds-7e1284e7a9fc58e8bd40bf1016511258a8a9c15a.tar.gz
development/bsdiff: New maintainer, tweaks.
Signed-off-by: B. Watson <yalhcru@gmail.com>
Diffstat (limited to 'development/bsdiff')
-rw-r--r--development/bsdiff/Makefile.diff26
-rw-r--r--development/bsdiff/README4
-rw-r--r--development/bsdiff/bsdiff.SlackBuild48
-rw-r--r--development/bsdiff/bsdiff.info4
-rw-r--r--development/bsdiff/slack-desc2
5 files changed, 31 insertions, 53 deletions
diff --git a/development/bsdiff/Makefile.diff b/development/bsdiff/Makefile.diff
deleted file mode 100644
index 393f0803b7..0000000000
--- a/development/bsdiff/Makefile.diff
+++ /dev/null
@@ -1,26 +0,0 @@
-diff -Naur bsdiff-4.3.orig/Makefile bsdiff-4.3/Makefile
---- bsdiff-4.3.orig/Makefile 2005-08-17 00:14:10.000000000 +0200
-+++ bsdiff-4.3/Makefile 2010-02-19 13:58:05.568018203 +0100
-@@ -1,15 +1,16 @@
- CFLAGS += -O3 -lbz2
-
- PREFIX ?= /usr/local
--INSTALL_PROGRAM ?= ${INSTALL} -c -s -m 555
--INSTALL_MAN ?= ${INSTALL} -c -m 444
-+INSTALL_PROGRAM ?= ${INSTALL} -m 0755
-+INSTALL_DIR ?= ${INSTALL} -d
-+INSTALL_MAN ?= ${INSTALL} -m 0644
-
- all: bsdiff bspatch
- bsdiff: bsdiff.c
- bspatch: bspatch.c
-
- install:
-- ${INSTALL_PROGRAM} bsdiff bspatch ${PREFIX}/bin
--.ifndef WITHOUT_MAN
-- ${INSTALL_MAN} bsdiff.1 bspatch.1 ${PREFIX}/man/man1
--.endif
-+ ${INSTALL_DIR} $(DESTDIR)/${PREFIX}/bin
-+ ${INSTALL_DIR} $(DESTDIR)/${PREFIX}/man/man1
-+ ${INSTALL_PROGRAM} bsdiff bspatch $(DESTDIR)/${PREFIX}/bin
-+ ${INSTALL_MAN} bsdiff.1 bspatch.1 $(DESTDIR)/${PREFIX}/man/man1
diff --git a/development/bsdiff/README b/development/bsdiff/README
index 8b4167b91e..482944aace 100644
--- a/development/bsdiff/README
+++ b/development/bsdiff/README
@@ -1,8 +1,10 @@
+bsdiff (binary diff/patch utility)
+
bsdiff and bspatch are tools for building and applying patches to binary
files. By using suffix sorting (specifically, Larsson and Sadakane's qsufsort)
and taking advantage of how executable files change, bsdiff routinely produces
binary patches 50-80% smaller than those produced by Xdelta, and 15% smaller
-than those produced by .RTPatch (a $2750/seat commercial patch tool).
+than those produced by .RTPatch (a $2750/seat commercial patch tool).
These programs were originally named bdiff and bpatch, but the large number of
other programs using those names lead to confusion; I'm not sure if the "bs"
diff --git a/development/bsdiff/bsdiff.SlackBuild b/development/bsdiff/bsdiff.SlackBuild
index 436d9f1747..b0e6486208 100644
--- a/development/bsdiff/bsdiff.SlackBuild
+++ b/development/bsdiff/bsdiff.SlackBuild
@@ -2,9 +2,10 @@
# Slackware build script for bsdiff.
#
-# Copyright 2010-2011 Marco Bonetti <sid77@slackware.it>
+# Copyright 2010-2011 Marco Bonetti <email removed>
# All rights reserved.
-# Maintenance adoption 2016 Glenn Becker <glenn.becker@gmail.com>
+# Maintenance adoption 2016 Glenn Becker <email removed>
+# Maintenance adoption 2018 B. Watson <yalhcru@gmail.com>
#
# Redistribution and use of this script, with or without modification, is
# permitted provided that the following conditions are met:
@@ -23,6 +24,12 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# 20181211 bkw:
+# - Take over maintenance.
+# - i486 => i586.
+# - Simplify script a bit.
+# - Get rid of Makefile.diff.
+
PRGNAM=bsdiff
VERSION=${VERSION:-4.3}
BUILD=${BUILD:-1}
@@ -30,7 +37,7 @@ TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -41,8 +48,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
@@ -64,28 +71,23 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
-# fix Makefile
-patch -p1 --verbose < $CWD/Makefile.diff
+# fix Makefile so it works with gmake
+sed -i '/^\./d' Makefile
+
+# 'make install' won't create these
+mkdir -p $PKG/usr/bin $PKG/usr/man/man1
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
# bsdiff needs to be linked against bzip2 libraries
-SLKCFLAGS="$SLKCFLAGS -lbz2"
-make CFLAGS="$SLKCFLAGS"
-make install INSTALL=install PREFIX=/usr DESTDIR=$PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
- for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-)
+make CFLAGS="$SLKCFLAGS -lbz2"
+make install \
+ INSTALL_PROGRAM="install -s -m0755" \
+ INSTALL_MAN="install -m0644" \
+ PREFIX=$PKG/usr
+gzip -9 $PKG/usr/man/man1/*.1
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/development/bsdiff/bsdiff.info b/development/bsdiff/bsdiff.info
index fad8525a3e..56206c8ab1 100644
--- a/development/bsdiff/bsdiff.info
+++ b/development/bsdiff/bsdiff.info
@@ -6,5 +6,5 @@ MD5SUM="e6d812394f0e0ecc8d5df255aa1db22a"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
-MAINTAINER="Glenn Becker"
-EMAIL="glenn.becker@gmail.com"
+MAINTAINER="B. Watson"
+EMAIL="yalhcru@gmail.com"
diff --git a/development/bsdiff/slack-desc b/development/bsdiff/slack-desc
index 127150a6ad..a04d406013 100644
--- a/development/bsdiff/slack-desc
+++ b/development/bsdiff/slack-desc
@@ -13,7 +13,7 @@ bsdiff: binary files. By using suffix sorting (specifically, Larsson and
bsdiff: Sadakane's qsufsort) and taking advantage of how executable files
bsdiff: change, bsdiff routinely produces binary patches 50-80% smaller than
bsdiff: those produced by Xdelta, and 15% smaller than those produced by
-bsdiff: .RTPatch (a $2750/seat commercial patch tool).
+bsdiff: .RTPatch (a $2750/seat commercial patch tool).
bsdiff:
bsdiff:
bsdiff: