summaryrefslogtreecommitdiffstats
path: root/desktop
diff options
context:
space:
mode:
author Jay Lanagan2024-02-02 02:16:47 +0100
committer Willy Sudiarto Raharjo2024-02-02 09:48:06 +0100
commit90916914c9c11643ea8486dcd17da8ab35895b03 (patch)
tree47de5be7b3354f55b04512dba45ed6a20ffb8ba5 /desktop
parente2943f362d7a59a3263195ba2723cf3d3e46e3a8 (diff)
downloadslackbuilds-90916914c9c11643ea8486dcd17da8ab35895b03.tar.gz
desktop/nwg-readme-browser: Added (NWG Browser).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'desktop')
-rw-r--r--desktop/nwg-readme-browser/README8
-rw-r--r--desktop/nwg-readme-browser/doinst.sh3
-rw-r--r--desktop/nwg-readme-browser/nwg-readme-browser.SlackBuild104
-rw-r--r--desktop/nwg-readme-browser/nwg-readme-browser.info10
-rw-r--r--desktop/nwg-readme-browser/slack-desc19
5 files changed, 144 insertions, 0 deletions
diff --git a/desktop/nwg-readme-browser/README b/desktop/nwg-readme-browser/README
new file mode 100644
index 0000000000..65135209c1
--- /dev/null
+++ b/desktop/nwg-readme-browser/README
@@ -0,0 +1,8 @@
+nwg-readme-browser (WebKitGTK-based README file browser)
+
+Nwg-readme-browser was conceived as rtfm with a graphical user
+interface. It searches the /usr/share/doc path for README.* files,
+and displays them in WebKit2.WebView. It supports .md, .rst, .html
+and plain text. It does not support .pdf format. Although the
+program was written with nwg-shell for sway and Hyprland in mind,
+it may also be used standalone.
diff --git a/desktop/nwg-readme-browser/doinst.sh b/desktop/nwg-readme-browser/doinst.sh
new file mode 100644
index 0000000000..5fb28930db
--- /dev/null
+++ b/desktop/nwg-readme-browser/doinst.sh
@@ -0,0 +1,3 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
diff --git a/desktop/nwg-readme-browser/nwg-readme-browser.SlackBuild b/desktop/nwg-readme-browser/nwg-readme-browser.SlackBuild
new file mode 100644
index 0000000000..5dbeeec7e9
--- /dev/null
+++ b/desktop/nwg-readme-browser/nwg-readme-browser.SlackBuild
@@ -0,0 +1,104 @@
+#!/bin/bash
+
+# Slackware build script for nwg-readme-browser
+
+# Copyright 2024 Jay Lanagan (j@lngn.net), Detroit, MI, USA.
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=nwg-readme-browser
+VERSION=${VERSION:-0.1.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.?z
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG --optimize=1
+install -Dm0644 -t $PKG/usr/share/pixmaps nwg-readme-browser.svg
+install -Dm0644 -t $PKG/usr/share/applications nwg-readme-browser.desktop
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+rm -rf $PKG/usr/lib${LIBDIRSUFFIX}/*.la
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/desktop/nwg-readme-browser/nwg-readme-browser.info b/desktop/nwg-readme-browser/nwg-readme-browser.info
new file mode 100644
index 0000000000..6a3996e593
--- /dev/null
+++ b/desktop/nwg-readme-browser/nwg-readme-browser.info
@@ -0,0 +1,10 @@
+PRGNAM="nwg-readme-browser"
+VERSION="0.1.3"
+HOMEPAGE="https://github.com/nwg-piotr/nwg-readme-browser/"
+DOWNLOAD="https://github.com/nwg-piotr/nwg-readme-browser/archive/v0.1.3/nwg-readme-browser-0.1.3.tar.gz"
+MD5SUM="28943c12f61ef8da546319e58aef1a59"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="gtk-layer-shell python3-markdown2 webkit2gtk"
+MAINTAINER="Jay Lanagan"
+EMAIL="j@lngn.net"
diff --git a/desktop/nwg-readme-browser/slack-desc b/desktop/nwg-readme-browser/slack-desc
new file mode 100644
index 0000000000..daab52bdba
--- /dev/null
+++ b/desktop/nwg-readme-browser/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+nwg-readme-browser: nwg-readme-browser (WebKitGTK-based README file browser)
+nwg-readme-browser:
+nwg-readme-browser: Nwg-readme-browser was conceived as rtfm with a graphical user
+nwg-readme-browser: interface. It searches the /usr/share/doc path for README.* files,
+nwg-readme-browser: and displays them in WebKit2.WebView. It supports .md, .rst, .html
+nwg-readme-browser: and plain text. It does not support .pdf format. Although the
+nwg-readme-browser: program was written with nwg-shell for sway and Hyprland in mind,
+nwg-readme-browser: it may also be used standalone.
+nwg-readme-browser:
+nwg-readme-browser: Homepage: https://github.com/nwg-piotr/nwg-readme-browser
+nwg-readme-browser: