summaryrefslogtreecommitdiffstats
path: root/desktop
diff options
context:
space:
mode:
author Johannes Schoepfer2024-03-09 00:52:58 +0100
committer Willy Sudiarto Raharjo2024-03-09 00:52:58 +0100
commit5d2ab03ba5744bfa9c57d28622f737599430175b (patch)
treee8b9295b25fc8542dff88b4613356465e6933115 /desktop
parentf82799a47599104e17b48a5364b100d9d73e070d (diff)
downloadslackbuilds-5d2ab03ba5744bfa9c57d28622f737599430175b.tar.gz
desktop/mate-terminal: Updated for version 1.28.1.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'desktop')
-rw-r--r--desktop/mate-terminal/README3
-rw-r--r--desktop/mate-terminal/mate-terminal.SlackBuild16
2 files changed, 10 insertions, 9 deletions
diff --git a/desktop/mate-terminal/README b/desktop/mate-terminal/README
index 78c7d40646..24e7470734 100644
--- a/desktop/mate-terminal/README
+++ b/desktop/mate-terminal/README
@@ -3,6 +3,3 @@ the MATE Desktop.
Optional dependency for help files:
yelp
-
-NOTE: This script will download submodules from Internet
-while building
diff --git a/desktop/mate-terminal/mate-terminal.SlackBuild b/desktop/mate-terminal/mate-terminal.SlackBuild
index a7541bdd9f..bc223bde92 100644
--- a/desktop/mate-terminal/mate-terminal.SlackBuild
+++ b/desktop/mate-terminal/mate-terminal.SlackBuild
@@ -4,7 +4,7 @@
# Copyright 2013 Chess Griffin Raleigh, NC
# Copyright 2013-2021 Willy Sudiarto Raharjo
-# Copyright 2023-2024 Johannes Schoepfer, Germany
+# Copyright 2023-2024 Johannes Schoepfer, Germany
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -84,12 +84,19 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} +
-# If yelp is not present don't build Help-files and remove HelpContens-menu
+# If yelp is not present don't build Help-files, remove HelpContens-menu and
+# move HelpAbout in first file-menu
if ! command -v yelp; then
- sed -i "/HelpContents/d" src/terminal.xml
sed -i "/subdir('help')/d" meson.build
+ sed -i src/terminal.xml \
+ -e "/HelpContents/d" \
+ -e "/HelpAbout/d" \
+ -e "/FileCloseWindow/a <separator \/>\n <menuitem action=\"HelpAbout\" \/>"
fi
+# Avoid dependency on mate-submoules at the cost for disabled session-manager-client
+sed -i -e "/submodules/d" -e "/HAVE_SMCLIENT/d" meson.build
+
mkdir build
cd build
CFLAGS="$SLKCFLAGS" \
@@ -114,9 +121,6 @@ cd ..
cp $CWD/org.mate.interface.gschema.xml \
$PKG/usr/share/glib-2.0/schemas/org.mate.interface.gschema.xml
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
find $PKG/usr/man -type f -exec gzip -9 {} +
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done