summaryrefslogtreecommitdiffstats
path: root/desktop
diff options
context:
space:
mode:
author Tonus2024-02-16 05:18:28 +0100
committer Willy Sudiarto Raharjo2024-02-16 12:51:33 +0100
commit051b47676c55929a2eabb383da4023c3b7ebb61d (patch)
tree834851c670ca2c15ae42ecdf09567e7a5ba8b372 /desktop
parentf9224eb7a0e7e78a3d8c6c4dff5a04a8798fe256 (diff)
downloadslackbuilds-051b47676c55929a2eabb383da4023c3b7ebb61d.tar.gz
desktop/ncpamixer: Added (sound mixer).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'desktop')
-rw-r--r--desktop/ncpamixer/README12
-rw-r--r--desktop/ncpamixer/ncpamixer.SlackBuild124
-rw-r--r--desktop/ncpamixer/ncpamixer.info10
-rw-r--r--desktop/ncpamixer/slack-desc19
4 files changed, 165 insertions, 0 deletions
diff --git a/desktop/ncpamixer/README b/desktop/ncpamixer/README
new file mode 100644
index 0000000000..3cc1b26944
--- /dev/null
+++ b/desktop/ncpamixer/README
@@ -0,0 +1,12 @@
+An ncurses mixer for PulseAudio inspired by pavucontrol.
+
+ncpamixer supports 256 colors.
+ncpamixer supports custom bindings.
+You can change both in ncpamixer.conf
+
+If $XDG_CONFIG_HOME is defined then it will be created at
+$XDG_CONFIG_HOME/ncpamixer.conf otherwise $HOME/.ncpamixer.conf
+File gets created on first run.
+
+Pandoc is an optional dependency to build man page. If installed do
+BUILD_MANPAGE=yes ./ncpamixer.SlackBuild
diff --git a/desktop/ncpamixer/ncpamixer.SlackBuild b/desktop/ncpamixer/ncpamixer.SlackBuild
new file mode 100644
index 0000000000..7c784bac9c
--- /dev/null
+++ b/desktop/ncpamixer/ncpamixer.SlackBuild
@@ -0,0 +1,124 @@
+#!/bin/bash
+
+# Slackware build script for ncpamixer
+
+# Copyright 2024 Tonus Paris
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=ncpamixer
+VERSION=${VERSION:-1.3.7}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+[ ${BUILD_MANPAGE:-no} == 'yes' ] && MANBUILD="-DBUILD_MANPAGE=ON" || MANBUILD="-UBUILD_MANPAGE"
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+sed -i 's|"Build Man pages using pandoc" ON|"Build Man pages using pandoc" OFF|' src/CMakeLists.txt
+[ ${BUILD_MANPAGE:-no} == 'yes' ] && sed -i 's|"Build Man pages using pandoc" OFF|"Build Man pages using pandoc" ON|' src/CMakeLists.txt
+
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_MANDIR=/usr/man \
+ -DUSE_WIDE=TRUE \
+ -DCMAKE_BUILD_TYPE=Release ../src
+ make
+ make install/strip DESTDIR=$PKG
+cd ..
+
+
+rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+[ ${BUILD_MANPAGE:-no} == 'yes' ] && find $PKG/usr/man -type f -exec gzip -9 {} \; && \
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+find $PKG -name perllocal.pod -o -name ".packlist" -o -name "*.bs" | xargs rm -f || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ LICENSE README.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/desktop/ncpamixer/ncpamixer.info b/desktop/ncpamixer/ncpamixer.info
new file mode 100644
index 0000000000..2e29ef7e0f
--- /dev/null
+++ b/desktop/ncpamixer/ncpamixer.info
@@ -0,0 +1,10 @@
+PRGNAM="ncpamixer"
+VERSION="1.3.7"
+HOMEPAGE="https://github.com/fulhax/ncpamixer"
+DOWNLOAD="https://github.com/fulhax/ncpamixer/archive/1.3.7/ncpamixer-1.3.7.tar.gz"
+MD5SUM="4679fe42ddaa4916a90cb8837d256cfc"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Tonus"
+EMAIL="tonus1@gmail.com"
diff --git a/desktop/ncpamixer/slack-desc b/desktop/ncpamixer/slack-desc
new file mode 100644
index 0000000000..103e0acc97
--- /dev/null
+++ b/desktop/ncpamixer/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+ncpamixer: ncpamixer (a ncurses mixer for PulseAudio inspired by pavucontrol)
+ncpamixer:
+ncpamixer:
+ncpamixer:
+ncpamixer:
+ncpamixer:
+ncpamixer:
+ncpamixer:
+ncpamixer:
+ncpamixer:
+ncpamixer: