summaryrefslogtreecommitdiffstats
path: root/desktop
diff options
context:
space:
mode:
author Damian Perticone2022-06-11 06:18:06 +0200
committer Willy Sudiarto Raharjo2022-06-18 04:09:56 +0200
commit6edf4ed9a6003d354aaca9563bbda7ddb8d67caa (patch)
tree9ab1c9379b24a7da787711bb5403025856b08b28 /desktop
parent2f021339d72f7445ee79691754ce5f34fbed6f7d (diff)
downloadslackbuilds-6edf4ed9a6003d354aaca9563bbda7ddb8d67caa.tar.gz
desktop/azote: Added (wallpaper manager)
Signed-off-by: Dave Woodfall <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'desktop')
-rw-r--r--desktop/azote/README68
-rw-r--r--desktop/azote/azote.SlackBuild103
-rw-r--r--desktop/azote/azote.desktop13
-rw-r--r--desktop/azote/azote.info10
-rw-r--r--desktop/azote/doinst.sh3
-rw-r--r--desktop/azote/slack-desc19
6 files changed, 216 insertions, 0 deletions
diff --git a/desktop/azote/README b/desktop/azote/README
new file mode 100644
index 0000000000..0b7070805c
--- /dev/null
+++ b/desktop/azote/README
@@ -0,0 +1,68 @@
+Azote is a GTK+3 - based picture browser and background setter, as the
+frontend to the swaybg (sway/Wayland) and feh (X windows) commands.
+The user interface is being developed with multi-headed setups in mind.
+Azote also includes several colour management tools.
+The program is confirmed to work on sway, Wayfire, i3, Openbox, Fluxbox
+and dwm window managers. Wayland support is limited to wlroots-based
+compositors. GNOME is not supported.
+
+Usage
+
+Select the folder your wallpapers are stored in. If it contains a lot
+of big pictures, it may take some time for Azote to create thumbnails.
+It's being performed once per folder, unless you clear the thumbnails
+folder.
+
+Most of the buttons seem to be self-explanatory, with a little help from
+their tooltip text. What may not be clear at first is the Apply selected
+picture to all screens button. It applies unchanged selected picture to
+all displays, regardless of whether they are currently
+connected/detected. It may be useful if you often connect and disconnect
+displays. A shortcut to this feature is just to double click a
+thumbnail. It'll always use the 'fill' mode, however.
+
+Azote, as well as feh, saves a batch file to your home directory. It
+needs to be executed in order to set the wallpaper on subsequent logins
+or reboot.
+
+sway
+
+Edit your ~/.config/sway/config file.
+
+Replace your current wallpaper settings, like:
+
+output * bg /usr/share/backgrounds/sway/Sway_Wallpaper.png fill
+
+with:
+
+exec ~/.azotebg
+
+Wayfire
+
+In ~/.config/wayfire.ini set autostart_wf_shell = false,
+and replace background = wf-background with background = ~/.azotebg.
+
+Important: optional wlr-randr / wlr-randr-git and swaybg packages are
+necessary.
+
+X window managers (i3, Openbox, dwm etc.)
+
+You need to execute ~/.fehbg from your window manager’s startup file.
+You'll also need optional feh and xorg-xrandr packages.
+
+Important: optional xorg-xrandr and feh packages are necessary.
+
+dwm note:
+
+If you start dwm from a script, it may look something like this:
+
+# Statusbar loop
+while true; do
+ xsetroot -name "$( date +"%F %R" )"
+ sleep 1m # Update time every minute
+done &
+
+# Autostart section
+~/.fehbg &
+
+exec dwm
diff --git a/desktop/azote/azote.SlackBuild b/desktop/azote/azote.SlackBuild
new file mode 100644
index 0000000000..f9965397be
--- /dev/null
+++ b/desktop/azote/azote.SlackBuild
@@ -0,0 +1,103 @@
+#!/bin/bash
+
+# Slackware build script for azote
+
+# Copyright 2022 Damian Perticone, Berisso, Argentina
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=azote
+VERSION=${VERSION:-1.9.5}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+mkdir -p $PKG/usr/bin
+mkdir -p $PKG/usr/share/applications
+mkdir -p $PKG/usr/share/pixmaps
+mkdir -p $PKG/usr/share/azote
+cp -a dist/azote $PKG/usr/bin/
+cp -a dist/azote.svg $PKG/usr/share/pixmaps/
+cp -a dist/indicator_active.png $PKG/usr/share/azote/
+cp -a dist/indicator_attention.png $PKG/usr/share/azote/
+cat $CWD/azote.desktop > $PKG/usr/share/applications/azote.desktop
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE LICENSE-COLORTHIEF README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/desktop/azote/azote.desktop b/desktop/azote/azote.desktop
new file mode 100644
index 0000000000..0ac0b353f5
--- /dev/null
+++ b/desktop/azote/azote.desktop
@@ -0,0 +1,13 @@
+[Desktop Entry]
+Type=Application
+Exec=azote
+Name=Azote
+Icon=azote
+Terminal=false
+GenericName=Azote wallpaper manager
+GenericName[pl]=Menedżer tapet Azote
+GenericName[de]=Azote Bildschirmhintergrund-Manager
+Categories=Settings;
+Comment=Browse, flip and set desktop wallpapers
+Comment[pl]=Przeglądaj, odwracaj i ustawiaj tapety pulpitu
+Keywords=background;desktop;
diff --git a/desktop/azote/azote.info b/desktop/azote/azote.info
new file mode 100644
index 0000000000..bbbbb3f7c7
--- /dev/null
+++ b/desktop/azote/azote.info
@@ -0,0 +1,10 @@
+PRGNAM="azote"
+VERSION="1.9.5"
+HOMEPAGE="https://github.com/nwg-piotr/azote"
+DOWNLOAD="https://github.com/nwg-piotr/azote/archive/v1.9.5/azote-1.9.5.tar.gz"
+MD5SUM="fad1f2528cbf2734c1f7bb8b158aef8d"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="feh maim slop send2trash swaybg wlr-randr"
+MAINTAINER="Damian Perticone"
+EMAIL="mjolnirdam@gmail.com"
diff --git a/desktop/azote/doinst.sh b/desktop/azote/doinst.sh
new file mode 100644
index 0000000000..5fb28930db
--- /dev/null
+++ b/desktop/azote/doinst.sh
@@ -0,0 +1,3 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
diff --git a/desktop/azote/slack-desc b/desktop/azote/slack-desc
new file mode 100644
index 0000000000..b9c330685a
--- /dev/null
+++ b/desktop/azote/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+azote: azote (wallpaper manager)
+azote:
+azote: Azote is a Wallpaper and colour manager for Sway, i3 and some
+azote: other WMs
+azote:
+azote:
+azote:
+azote:
+azote:
+azote: Home: https://github.com/nwg-piotr/azote
+azote: