summaryrefslogtreecommitdiffstats
path: root/desktop
diff options
context:
space:
mode:
author orbea2020-01-07 23:15:53 +0100
committer Willy Sudiarto Raharjo2020-01-12 02:47:55 +0100
commiteb787db2ca0f9d5d9dc2910863708a5b357bb482 (patch)
treefb4c0bfc919f39fbbf69cc85b0d6d11f08bd242d /desktop
parent34a0123dda7bb6fddde345e1933aa4feb829f032 (diff)
downloadslackbuilds-eb787db2ca0f9d5d9dc2910863708a5b357bb482.tar.gz
desktop/PyPanel: Update script.
Signed-off-by: orbea <orbea@riseup.net>
Diffstat (limited to 'desktop')
-rw-r--r--desktop/PyPanel/PyPanel.SlackBuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/desktop/PyPanel/PyPanel.SlackBuild b/desktop/PyPanel/PyPanel.SlackBuild
index 21d8759b75..11b1d4f05e 100644
--- a/desktop/PyPanel/PyPanel.SlackBuild
+++ b/desktop/PyPanel/PyPanel.SlackBuild
@@ -6,7 +6,7 @@
PRGNAM=PyPanel
VERSION=${VERSION:-2.4}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -51,6 +51,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+# Fix the imlib2 library path on 64-bit systems.
+sed -i "s|/usr/lib/libImlib2|/usr/lib${LIBDIRSUFFIX}/libImlib2|" setup.py
+
python setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \