summaryrefslogtreecommitdiffstats
path: root/desktop
diff options
context:
space:
mode:
author B. Watson2019-12-12 09:18:06 +0100
committer Willy Sudiarto Raharjo2019-12-15 11:06:28 +0100
commite9b011fb5c34eb671159ae1d8398e9657353f7bc (patch)
tree302e8ca092d8280e1edbb274a2a2340a34a68708 /desktop
parentd94c672c17631f201aabd1671fa1b510e0b23541 (diff)
downloadslackbuilds-e9b011fb5c34eb671159ae1d8398e9657353f7bc.tar.gz
desktop/wmmon: Updated for version 1.4.
Signed-off-by: B. Watson <yalhcru@gmail.com>
Diffstat (limited to 'desktop')
-rw-r--r--desktop/wmmon/doinst.sh4
-rw-r--r--desktop/wmmon/patches/gcc5.diff18
-rw-r--r--desktop/wmmon/patches/manpage_window_not_clock.diff21
-rw-r--r--desktop/wmmon/patches/rc_file_parser.diff12
-rw-r--r--desktop/wmmon/wmmon.1214
-rw-r--r--desktop/wmmon/wmmon.SlackBuild95
-rw-r--r--desktop/wmmon/wmmon.info8
-rw-r--r--desktop/wmmon/wmmon.pngbin0 -> 2272 bytes
8 files changed, 260 insertions, 112 deletions
diff --git a/desktop/wmmon/doinst.sh b/desktop/wmmon/doinst.sh
index 3bfcee2d02..a0e6bc86f0 100644
--- a/desktop/wmmon/doinst.sh
+++ b/desktop/wmmon/doinst.sh
@@ -12,3 +12,7 @@ config() {
}
config etc/wmmonrc.new
+
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
diff --git a/desktop/wmmon/patches/gcc5.diff b/desktop/wmmon/patches/gcc5.diff
deleted file mode 100644
index 1d02bddb48..0000000000
--- a/desktop/wmmon/patches/gcc5.diff
+++ /dev/null
@@ -1,18 +0,0 @@
-Description: fix build failure with gcc5:
- build with "-std=gnu89"
-Origin: vendor
-Bug-Debian: https://bugs.debian.org/778171
-Author: gregor herrmann <gregoa@debian.org>
-Last-Update: 2015-07-19
-
---- a/wmmon/Makefile
-+++ b/wmmon/Makefile
-@@ -5,7 +5,7 @@
- ../wmgeneral/misc.o \
- ../wmgeneral/list.o
-
--CFLAGS = -O2
-+CFLAGS = -O2 -std=gnu89
- CC = cc
-
-
diff --git a/desktop/wmmon/patches/manpage_window_not_clock.diff b/desktop/wmmon/patches/manpage_window_not_clock.diff
deleted file mode 100644
index d32d08ee2d..0000000000
--- a/desktop/wmmon/patches/manpage_window_not_clock.diff
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -Naur wmmon.app/wmmon/wmmon.1 wmmon.app.patched/wmmon/wmmon.1
---- wmmon.app/wmmon/wmmon.1 2009-04-20 17:55:39.000000000 -0400
-+++ wmmon.app.patched/wmmon/wmmon.1 2009-04-20 17:56:52.000000000 -0400
-@@ -64,7 +64,7 @@
-
- .TP
- .BI \-geometry \ geometry
--This option specifies the preferred position of clock; see
-+This option specifies the preferred position of the window; see
- .IR X(7x) .
-
- .TP
-@@ -159,7 +159,7 @@
- .B WMMon
- detects a
- .I $HOME/.wmmonrc
--file, it will launch the appropriate command when you click on the clock.
-+file, it will launch the appropriate command when you click on the window.
-
- The system administrator can define default commands in
- .IR /etc/wmmonrc .
diff --git a/desktop/wmmon/patches/rc_file_parser.diff b/desktop/wmmon/patches/rc_file_parser.diff
deleted file mode 100644
index 376fcc72d1..0000000000
--- a/desktop/wmmon/patches/rc_file_parser.diff
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -Naur wmmon.app/wmgeneral/wmgeneral.c wmmon.app.patched/wmgeneral/wmgeneral.c
---- wmmon.app/wmgeneral/wmgeneral.c 2009-04-20 17:03:25.000000000 -0400
-+++ wmmon.app.patched/wmgeneral/wmgeneral.c 2009-04-20 17:02:58.000000000 -0400
-@@ -95,6 +95,8 @@
- fp = fopen(filename, "r");
- if (fp) {
- while (getline(&line, &line_size, fp) >= 0) {
-+ if(*line == '#')
-+ continue;
- key = 0;
- while (key >= 0 && keys[key].label) {
- if ((p = strstr(line, keys[key].label))) {
diff --git a/desktop/wmmon/wmmon.1 b/desktop/wmmon/wmmon.1
new file mode 100644
index 0000000000..49da7cf055
--- /dev/null
+++ b/desktop/wmmon/wmmon.1
@@ -0,0 +1,214 @@
+'\" t
+.\" Man page for wmmon
+.\" Copyright (c) 2003 Software in the Public Interest, Inc.
+.\"
+.\" This program is free software; you can redistribute it and/or modify
+.\" it under the terms of the GNU General Public License as published by
+.\" the Free Software Foundation; either version 2 of the License, or (at
+.\" your option) any later version.
+.\"
+.\" This program is distributed in the hope that it will be useful, but
+.\" WITHOUT ANY WARRANTY; without even the implied warranty of
+.\" MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+.\" General Public License for more details.
+.\"
+.\" You should have received a copy of the GNU General Public License
+.\" along with this program; if not, write to the Free Software
+.\" Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+.\"
+.TH wmmon 1 "Dec 2019" "WMMON 1.4"
+
+.SH NAME
+wmmon \- Window Maker dockapp for monitoring system information
+
+.SH SYNOPSIS
+
+.B wmmon
+[
+.I OPTION
+]
+
+.SH DESCRIPTION
+
+.B WMMon
+monitors the realtime CPU load as well as the average system load,
+and gives you some nice additional features too. It is intended for
+docking in Window Maker.
+
+It currently provides:
+
+.IP \(bu 4
+a realtime CPU stress meter;
+.IP \(bu
+an auto-scaled average system load meter, like
+.B xload
+and
+.BR wmavgload ;
+.IP \(bu
+hint lines change color as the system load increases.
+.RS
+.IP \(bu
+green for multiples of 1
+.IP \(bu
+yellow for multiples of 10
+.IP \(bu
+red for multiples of 100
+.RE
+.IP \(bu
+a realtime disk I/O stress meter;
+.IP \(bu
+auto-scaled disk I/O load meter;
+.IP \(bu
+realtime memory and swap usage meters;
+.IP \(bu
+a display for system uptime;
+.IP \(bu
+three user-defined commands to launch.
+
+.SH OPTIONS
+
+.TP
+.BI \-display \ display
+This option specifies the X server to contact; see
+.IR X(7x) .
+
+.TP
+.BI \-geometry \ geometry
+This option specifies the preferred position of window; see
+.IR X(7x) .
+
+.TP
+.BR \-l
+Lock the mode, so that it cannot be cycled by clicking on the upper-left
+widget. You can use this to open multiple copies of
+.BR WMMon ,
+each set to a different mode.
+
+.TP
+.BR \-c
+Show average and max CPU usage for SMP machines. This is the default
+if there are more than 10 processors.
+
+.TP
+.BR \-i
+Start in disk I/O mode, which displays instantaneous disk usage and
+average disk load.
+
+.TP
+.BR \-b
+Include buffers and cache in memory usage calculations. The trend in
+recent years has been to not include this in memory load monitors, but it
+can be useful information.
+
+.TP
+.BR \-s
+Start in system information mode, which displays memory usage, swap usage,
+and uptime.
+
+.TP
+.B \-h
+Show help information.
+
+.TP
+.B \-v
+Print the version number.
+
+.SH USAGE
+The
+.B WMMon
+display can be cycled between CPU, disk I/O, and system
+information displays by clicking on the upper-left widget. This
+displays CPU information by default.
+
+WMMon can also be used to launch programs. You may click either left,
+middle, or right mouse buttons in the average-load section of the
+window. The pre-configured program will be launched according to the
+mouse button clicked. (see
+.B CONFIGURATION FILE
+below.)
+
+In order to move
+.BR WMMon ,
+drag on the outer edges. These are not sensitive to mouse clicks.
+
+.SH "DOCKING IN WINDOW MANAGERS"
+
+.TP
+Window Maker
+
+Window Maker users should drag and drop the
+.B WMMon
+window on the Dock. Then, right-click on the border of the window and
+select \*(lqSettings...\*(rq. Check \*(lqStart when Window Maker
+is started\*(rq.
+
+.TP
+AfterStep
+
+AfterStep users should put the following in their
+.I $HOME/.steprc
+
+.RS 16
+Wharf wmmon \- MaxSwallow "wmmon" wmmon &
+.RE
+
+.TP
+Other window managers
+
+.B WMMon
+runs nicely as a 64x64 shaped icon on your desktop.
+
+.SH "CONFIGURATION FILE"
+
+.B WMMon
+can launch three user-defined commands, triggered by left, middle and
+right mouse button clicks. You can define the commands to launch in
+.I $HOME/.wmmonrc
+
+.RS
+.PD 0
+left: xterm
+.PP
+middle: xload
+.PP
+right: xcalc
+.PP
+.PD
+.RE
+
+If
+.B WMMon
+detects a
+.I $HOME/.wmmonrc
+file, it will launch the appropriate command when you click on the window.
+
+The system administrator can define default commands in
+.IR /etc/wmmonrc .
+The administrator may also choose to \*(lqfix\*(rq particular commands,
+making it impossible for users to change. These commands can be defined in
+.IR /etc/wmmonrc.fixed ,
+although this isn't a nice thing to do.
+
+.SH FILES
+
+.I /etc/wmmonrc
+.br
+.I $HOME/.wmmonrc
+.br
+.I /etc/wmmonrc.fixed
+
+.SH AUTHORS
+
+.B WMMon
+was written by Martijn Pieterse and Antoine Nulle.
+
+This manual page was written by Simon Law <sfllaw@debian.org> for the
+.B Debian
+system (but may be used by others), and was modified for WMMon 1.4 by
+B. Watson <yalhcru@gmail.com>. It is based on the documentation provided
+by the original program.
+
+This manual is free software; you can redistribute it and/or modify
+it under the terms of the GNU General Public License as published by
+the Free Software Foundation; either version 2 of the License, or (at
+your option) any later version.
diff --git a/desktop/wmmon/wmmon.SlackBuild b/desktop/wmmon/wmmon.SlackBuild
index 3de7dccf81..fa162e867c 100644
--- a/desktop/wmmon/wmmon.SlackBuild
+++ b/desktop/wmmon/wmmon.SlackBuild
@@ -6,6 +6,12 @@
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20191211 bkw: Update for v1.4. Script can no longer build the old version.
+# - add libdockapp dep
+# - get rid of patches (no longer needed)
+# - add icon (to go with upstream's new .desktop file)
+# - s/clock/window in man page, also document -c option
+
# 20170224 bkw:
# - BUILD=2
# - install /etc/wmmonrc as a proper .new config
@@ -15,31 +21,9 @@
# from trying to "upgrade" to 1.2b1.
# - actually mention windowmaker in the README (derp!)
-# Notes about versions:
-
-# The version number is from Debian. I don't know why they called it 1.1,
-# because:
-# $ wmmon -v
-# WMMon version 1.2.b2
-# Since I'm using their tarball, I'll stick with their version numbering.
-
-# http://www.dockapps.net/wmmon has a wmmon-1.2b1 release, which looks
-# like a higher version number than we use for VERSION here. However
-# it's really older (missing some options/bugfixes) and this is obvious
-# if you look at the output of wmmon -v (1.2.b1 < 1.2.b2).
-
-# I could package up a newer git commit (there are commits from 2015),
-# but they add complexity (a new libdockapp.so library, as a separate
-# source tree, which wmmon would require as a dependency) and don't fix
-# any bugs or add any features beyond what we've got here. Plus, we've
-# got the same version Debian uses, and Fedora uses effectively the
-# same version too (they include a commit "Remove trailing whitespace"
-# that doesn't change the actual code). Gentoo uses 1.2b1, but I'm not
-# using them for a role model :)
-
PRGNAM=wmmon
-VERSION=${VERSION:-1.1+20131205}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-1.4}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -57,13 +41,10 @@ OUTPUT=${OUTPUT:-/tmp}
if [ "$ARCH" = "i586" ]; then
SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIR="-L/usr/lib"
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIR="-L/usr/lib"
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
- LIBDIR="-L/usr/lib64"
fi
set -e
@@ -71,43 +52,43 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM.app
+rm -rf $PRGNAM-$VERSION
tar xvf $CWD/${PRGNAM}_${VERSION}.orig.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-# need this for -current, it doesn't hurt anything on 14.1.
-# patch snarfed from Debian:
-patch -p1 < $CWD/patches/gcc5.diff
-
-# This patch is necessary because the $#!%^#$^ wmmonrc file parser doesn't
-# fully support comments: they are allowed, but a commented-out (but
-# otherwise valid) config directive is still processed as though it
-# weren't commented out! Ack!
-patch -p1 < $CWD/patches/rc_file_parser.diff
-
-# The man page refers to "the clock" (probably copied from wmclock docs),
-# change to "the window".
-patch -p1 < $CWD/patches/manpage_window_not_clock.diff
-
-cd $PRGNAM
- sed -i -e "s/-O2/$SLKCFLAGS/" Makefile
- make LIBDIR="$LIBDIR"
- strip $PRGNAM
- mkdir -p $PKG/usr/bin
- install -m0755 -o root -g root $PRGNAM $PKG/usr/bin
- mkdir -p $PKG/usr/man/man1
- gzip -9c $PRGNAM.1 > $PKG/usr/man/man1/$PRGNAM.1.gz
-cd -
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
+
+# Man page taken from Debian, slightly corrected, and -c option added.
+cat $CWD/$PRGNAM.1 > $PRGNAM.1
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --build=$ARCH-slackware-linux
+make
+make install-strip DESTDIR=$PKG
+gzip $PKG/usr/man/man1/*.1
mkdir -p $PKG/etc
cat $CWD/wmmonrc > $PKG/etc/wmmonrc.new
+# Icon created from wmmon-master.xpm + some overlaid text. If you
+# think it's ugly, you're right: PLEASE send me a nicer looking one.
+# I never claimed to be a graphic designer.
+mkdir -p $PKG/usr/share/pixmaps
+cat $CWD/$PRGNAM.png > $PKG/usr/share/pixmaps/$PRGNAM.png
+
+# Make .desktop reference the icon.
+echo 'Icon=/usr/share/pixmaps/wmmon.png' >> \
+ $PKG/usr/share/applications/$PRGNAM.desktop
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a BUGS CHANGES COPYING HINTS README TODO $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/desktop/wmmon/wmmon.info b/desktop/wmmon/wmmon.info
index 09646450fa..16346111d1 100644
--- a/desktop/wmmon/wmmon.info
+++ b/desktop/wmmon/wmmon.info
@@ -1,10 +1,10 @@
PRGNAM="wmmon"
-VERSION="1.1+20131205"
+VERSION="1.4"
HOMEPAGE="http://repo.or.cz/w/dockapps.git"
-DOWNLOAD="http://http.debian.net/debian/pool/main/w/wmmon/wmmon_1.1+20131205.orig.tar.gz"
-MD5SUM="c2faf71b0d2bf92d65d308eee321104f"
+DOWNLOAD="http://http.debian.net/debian/pool/main/w/wmmon/wmmon_1.4.orig.tar.gz"
+MD5SUM="3d6c918355880e4d313dd7402b5b6b3d"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="libdockapp"
MAINTAINER="B. Watson"
EMAIL="yalhcru@gmail.com"
diff --git a/desktop/wmmon/wmmon.png b/desktop/wmmon/wmmon.png
new file mode 100644
index 0000000000..dfb5b53f08
--- /dev/null
+++ b/desktop/wmmon/wmmon.png
Binary files differ