summaryrefslogtreecommitdiffstats
path: root/desktop
diff options
context:
space:
mode:
author Leo C2019-06-29 01:19:35 +0200
committer Willy Sudiarto Raharjo2019-06-29 01:19:35 +0200
commitb8855682ce0336a53bab05491830ec5b09303a39 (patch)
treec9a24ee1cc09117c77ff733a59be0700a4a26b49 /desktop
parentbac887ac20252f5f0a7c9e20f8e38100752526a4 (diff)
downloadslackbuilds-b8855682ce0336a53bab05491830ec5b09303a39.tar.gz
desktop/kolorcontrol: Added (Simple GUI front-end to xcalib).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'desktop')
-rw-r--r--desktop/kolorcontrol/README5
-rw-r--r--desktop/kolorcontrol/doinst.sh4
-rw-r--r--desktop/kolorcontrol/kolorcontrol.SlackBuild107
-rw-r--r--desktop/kolorcontrol/kolorcontrol.info10
-rw-r--r--desktop/kolorcontrol/slack-desc19
5 files changed, 145 insertions, 0 deletions
diff --git a/desktop/kolorcontrol/README b/desktop/kolorcontrol/README
new file mode 100644
index 0000000000..0c751b7796
--- /dev/null
+++ b/desktop/kolorcontrol/README
@@ -0,0 +1,5 @@
+This little GUI tool is intended to set your screen brightness,
+contrast and gamma levels for each color channel. It is implemented as
+a front-end to xcalib, a command line utility. It will also display
+the actual xcalib command line, suitable for copy-pasting to a script
+to run and activate automatically on login your desired settings.
diff --git a/desktop/kolorcontrol/doinst.sh b/desktop/kolorcontrol/doinst.sh
new file mode 100644
index 0000000000..4e8ba7071d
--- /dev/null
+++ b/desktop/kolorcontrol/doinst.sh
@@ -0,0 +1,4 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
diff --git a/desktop/kolorcontrol/kolorcontrol.SlackBuild b/desktop/kolorcontrol/kolorcontrol.SlackBuild
new file mode 100644
index 0000000000..9516a1d8c5
--- /dev/null
+++ b/desktop/kolorcontrol/kolorcontrol.SlackBuild
@@ -0,0 +1,107 @@
+#!/bin/sh
+
+# Slackware build script for kolorcontrol
+
+# Copyright 2019 Leonardo Citrolo, Italy
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=kolorcontrol
+VERSION=${VERSION:-20181211git}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+COMMIT=${COMMIT:-6b7ab04deea96b688feb20896577501b2f8fd10e}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$COMMIT
+tar xvf $CWD/$PRGNAM-$COMMIT.tar.gz
+cd $PRGNAM-$COMMIT
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Prevent setup.py from trying to download and install pyqt5 at all costs
+sed -e '/setup_requires/d' \
+ -e '/install_requires/d' \
+ -i setup.py
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+# Create desktop entry
+mkdir -p $PKG/usr/share/applications
+cat > $PKG/usr/share/applications/$PRGNAM.desktop <<EOF
+[Desktop Entry]
+Type=Application
+Name=KolorControl
+GenericName=KolorControl Color Correction Tool
+Comment=KolorControl Color Correction Tool
+Icon=preferences-desktop
+Exec=$PRGNAM
+Categories=Settings;
+EOF
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/desktop/kolorcontrol/kolorcontrol.info b/desktop/kolorcontrol/kolorcontrol.info
new file mode 100644
index 0000000000..819dc8a7bb
--- /dev/null
+++ b/desktop/kolorcontrol/kolorcontrol.info
@@ -0,0 +1,10 @@
+PRGNAM="kolorcontrol"
+VERSION="20181211git"
+HOMEPAGE="https://github.com/Ablinne/kolorcontrol"
+DOWNLOAD="https://github.com/Ablinne/kolorcontrol/archive/6b7ab04deea96b688feb20896577501b2f8fd10e/kolorcontrol-6b7ab04deea96b688feb20896577501b2f8fd10e.tar.gz"
+MD5SUM="96a193eae2f8c56c0dfa4173a425dcbc"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pyqt-distutils python3-PyQt5 python3-matplotlib xcalib"
+MAINTAINER="Leo C."
+EMAIL="leoc@gmx.com"
diff --git a/desktop/kolorcontrol/slack-desc b/desktop/kolorcontrol/slack-desc
new file mode 100644
index 0000000000..3bb017f5cd
--- /dev/null
+++ b/desktop/kolorcontrol/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+kolorcontrol: kolorcontrol (Simple GUI front-end to xcalib)
+kolorcontrol:
+kolorcontrol: This little GUI tool is intended to set your screen brightness,
+kolorcontrol: contrast and gamma levels for each color channel. It is implemented as
+kolorcontrol: a front-end to xcalib, a command line utility. It will also display
+kolorcontrol: the actual xcalib command line, suitable for copy-pasting to a script
+kolorcontrol: to run and activate automatically on login your desired settings.
+kolorcontrol:
+kolorcontrol:
+kolorcontrol: Homepage: https://github.com/Ablinne/kolorcontrol
+kolorcontrol: