summaryrefslogtreecommitdiffstats
path: root/desktop
diff options
context:
space:
mode:
author Edinaldo P. Silva2016-07-26 02:59:53 +0200
committer Willy Sudiarto Raharjo2016-07-30 01:03:36 +0200
commitda33ac50b833eeef66683e8271a3f4dd3e0e2991 (patch)
treec1683d5ed8cecc87e3e08b20a1a51965f9fd3f30 /desktop
parent1a2acc95def0f281f42e4796bd8b0720ef5aa2a4 (diff)
downloadslackbuilds-da33ac50b833eeef66683e8271a3f4dd3e0e2991.tar.gz
desktop/pytyle: Added (extensible tiling manager).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'desktop')
-rw-r--r--desktop/pytyle/README29
-rw-r--r--desktop/pytyle/doinst.sh13
-rw-r--r--desktop/pytyle/pytyle.SlackBuild88
-rw-r--r--desktop/pytyle/pytyle.info10
-rw-r--r--desktop/pytyle/slack-desc19
5 files changed, 159 insertions, 0 deletions
diff --git a/desktop/pytyle/README b/desktop/pytyle/README
new file mode 100644
index 0000000000..2631fee323
--- /dev/null
+++ b/desktop/pytyle/README
@@ -0,0 +1,29 @@
+pytyle (extensible tiling manager).
+
+An extensible tiling manager that can fit into any EWMH compatible
+window manager. Uses Python and the Python X Library.
+
+PyTyle is meant to run in the background, so run it like so:
+
+ pytyle &
+
+You may want to add the above command to your ~/.xinitrc or
+another startup script like ~/.config/openbox/autostart.
+
+If you're having trouble running it on start up, try this in
+your ~/.xinitrc:
+
+ (sleep 5 && pytyle) &
+
+It will give the window manager time to startup before PyTyle starts
+asking it for information. Increase/decrease the sleep timeout
+appropriately.
+
+After PyTyle has been executed for the first time, it will create a
+configuration file in your XDG_CONFIG_HOME/pytyle/ directory (usually
+~/.config/pytyle) called pytylerc. The comments in the configuration
+file will explain everything.
+
+It has been tested relatively well on OpenBox and partially on Fluxbox.
+It should, in theory, work with any window manager complying with the
+EWMH standards.
diff --git a/desktop/pytyle/doinst.sh b/desktop/pytyle/doinst.sh
new file mode 100644
index 0000000000..9424ce43ff
--- /dev/null
+++ b/desktop/pytyle/doinst.sh
@@ -0,0 +1,13 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -x /usr/bin/update-mime-database ]; then
+ /usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/desktop/pytyle/pytyle.SlackBuild b/desktop/pytyle/pytyle.SlackBuild
new file mode 100644
index 0000000000..1be91f3561
--- /dev/null
+++ b/desktop/pytyle/pytyle.SlackBuild
@@ -0,0 +1,88 @@
+#!/bin/sh
+#
+# Slackware build script for pytyle.
+#
+# Copyright 2015 Edinaldo P. Silva, Rio de Janeiro, Brazil.
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=pytyle
+VERSION=${VERSION:-0.7.5}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+DOCS="CHANGELOG INSTALL LICENSE README PKG-INFO TODO"
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/desktop/pytyle/pytyle.info b/desktop/pytyle/pytyle.info
new file mode 100644
index 0000000000..44be8a93e2
--- /dev/null
+++ b/desktop/pytyle/pytyle.info
@@ -0,0 +1,10 @@
+PRGNAM="pytyle"
+VERSION="0.7.5"
+HOMEPAGE="http://sourceforge.net/projects/pytyle/"
+DOWNLOAD="http://downloads.sourceforge.net/project/pytyle/pytyle-0.7.5.tar.gz"
+MD5SUM="0475a2f98732ef724423f3c19ecfa52e"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python-xlib"
+MAINTAINER="Edinaldo P. Silva"
+EMAIL="edps.mundognu@gmail.com"
diff --git a/desktop/pytyle/slack-desc b/desktop/pytyle/slack-desc
new file mode 100644
index 0000000000..beae8b1d27
--- /dev/null
+++ b/desktop/pytyle/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+pytyle: pytyle (extensible tiling manager).
+pytyle:
+pytyle: An extensible tiling manager that can fit into any EWMH compatible
+pytyle: window manager. Uses Python and the Python X Library.
+pytyle:
+pytyle: Home page: http://sourceforge.net/projects/pytyle/
+pytyle:
+pytyle:
+pytyle:
+pytyle:
+pytyle: