summaryrefslogtreecommitdiffstats
path: root/desktop
diff options
context:
space:
mode:
author Piotr Janaszek2015-06-05 01:57:10 +0200
committer Willy Sudiarto Raharjo2015-06-05 01:57:10 +0200
commit15f45b17a76f7baff5119e431a0f06a4652f8f3d (patch)
treef0b58ce2e49a339a84f796296e244a1d85f8ebb6 /desktop
parentd118519990bd9b3f8da760cc23bf01e18a154446 (diff)
downloadslackbuilds-15f45b17a76f7baff5119e431a0f06a4652f8f3d.tar.gz
desktop/rodent: Added (Rodent Filemanager).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'desktop')
-rw-r--r--desktop/rodent/README3
-rw-r--r--desktop/rodent/doinst.sh10
-rw-r--r--desktop/rodent/rodent.SlackBuild114
-rw-r--r--desktop/rodent/rodent.info10
-rw-r--r--desktop/rodent/slack-desc19
5 files changed, 156 insertions, 0 deletions
diff --git a/desktop/rodent/README b/desktop/rodent/README
new file mode 100644
index 0000000000..4b54a9d35c
--- /dev/null
+++ b/desktop/rodent/README
@@ -0,0 +1,3 @@
+Rodent is fast, small and powerful file manager for the GNU operating system.
+That's one way to look at it. Another way is to call it a graphic shell
+(that's probably more accurate).
diff --git a/desktop/rodent/doinst.sh b/desktop/rodent/doinst.sh
new file mode 100644
index 0000000000..1f8ff67ded
--- /dev/null
+++ b/desktop/rodent/doinst.sh
@@ -0,0 +1,10 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
+
diff --git a/desktop/rodent/rodent.SlackBuild b/desktop/rodent/rodent.SlackBuild
new file mode 100644
index 0000000000..a6d5acbda6
--- /dev/null
+++ b/desktop/rodent/rodent.SlackBuild
@@ -0,0 +1,114 @@
+#!/bin/sh
+
+# Slackware build script for rodent
+
+# Copyright 2015 Piotr Janaszek <pjanas01@gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=rodent
+VERSION=${VERSION:-5.3.12}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Disable pkg plugin since it is useless on Slackware
+sed -i 's/"apps\/rodent-pkg",//g' configure
+sed -i 's/rodent-pkg//g' apps/Makefile.*
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --enable-static=no \
+ --with-centos=no \
+ --build=$ARCH-slackware-linux
+
+make
+make install DESTDIR=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+
+# Install manual (RTFM.pdf) in the standard Slackware location
+mv $PKG/usr/share/doc/$PRGNAM/RTFM.pdf $PKG/usr/doc/$PRGNAM-$VERSION
+rm -rf $PKG/usr/share/doc
+# And create a symlink so Help function works
+( cd $PKG/usr/doc; ln -sf $PRGNAM-$VERSION rfm )
+
+cp -a AUTHORS ChangeLog COPYING README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/desktop/rodent/rodent.info b/desktop/rodent/rodent.info
new file mode 100644
index 0000000000..b14ba8f0fa
--- /dev/null
+++ b/desktop/rodent/rodent.info
@@ -0,0 +1,10 @@
+PRGNAM="rodent"
+VERSION="5.3.12"
+HOMEPAGE="http://xffm.org/"
+DOWNLOAD="http://sourceforge.net/projects/xffm/files/5.3.12/rodent-5.3.12.tar.bz2"
+MD5SUM="ee4cd7b1298bd4d20a4b25b820ba1636"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="librfm5"
+MAINTAINER="Piotr Janaszek"
+EMAIL="pjanas01@gmail.com"
diff --git a/desktop/rodent/slack-desc b/desktop/rodent/slack-desc
new file mode 100644
index 0000000000..94a7431990
--- /dev/null
+++ b/desktop/rodent/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+rodent: rodent (Rodent Filemanager)
+rodent:
+rodent: Rodent is fast, small and powerful file manager for the GNU operating
+rodent: system.
+rodent:
+rodent:
+rodent: Homepage: http://xffm.org/
+rodent:
+rodent:
+rodent:
+rodent: