summaryrefslogtreecommitdiffstats
path: root/desktop
diff options
context:
space:
mode:
author Heinz Wiesinger2013-11-25 12:23:31 +0100
committer Heinz Wiesinger2013-11-25 13:11:59 +0100
commit926b93d445e92be03e62efcd742b2ac88f0d96ed (patch)
treea9e1e616e37f2f7187d0b0ab2d8e83b3ad8eed63 /desktop
parent7bc7feac90a3966ebaea1b1ad87431764a560344 (diff)
downloadslackbuilds-926b93d445e92be03e62efcd742b2ac88f0d96ed.tar.gz
various: Replace chmod command with find command from template.
Signed-off-by: Heinz Wiesinger <pprkut@slackbuilds.org>
Diffstat (limited to 'desktop')
-rw-r--r--desktop/CurseTheWeather/CurseTheWeather.SlackBuild6
-rw-r--r--desktop/cairo-dock-plugins/cairo-dock-plugins.SlackBuild6
-rw-r--r--desktop/cairo-dock/cairo-dock.SlackBuild6
-rw-r--r--desktop/cmatrix/cmatrix.SlackBuild6
-rw-r--r--desktop/crystalcursors/crystalcursors.SlackBuild6
-rw-r--r--desktop/gtk-chtheme/gtk-chtheme.SlackBuild6
-rw-r--r--desktop/ion/ion.SlackBuild6
-rw-r--r--desktop/jwm/jwm.SlackBuild6
-rw-r--r--desktop/kbdd/kbdd.SlackBuild6
-rw-r--r--desktop/kcometen4/kcometen4.SlackBuild6
-rw-r--r--desktop/maitreya/maitreya.SlackBuild6
-rw-r--r--desktop/pidgin-guifications/pidgin-guifications.SlackBuild6
-rw-r--r--desktop/plasma-applet-daisy/plasma-applet-daisy.SlackBuild6
-rw-r--r--desktop/rootactions_servicemenu/rootactions_servicemenu.SlackBuild6
-rw-r--r--desktop/rss-glx/rss-glx.SlackBuild6
-rw-r--r--desktop/simon/simon.SlackBuild6
-rw-r--r--desktop/vbox-runner/vbox-runner.SlackBuild6
-rw-r--r--desktop/whaw/whaw.SlackBuild6
-rw-r--r--desktop/wmcliphist/wmcliphist.SlackBuild6
-rw-r--r--desktop/wmclock/wmclock.SlackBuild6
-rw-r--r--desktop/wmctrl/wmctrl.SlackBuild6
-rw-r--r--desktop/wmmon/wmmon.SlackBuild6
-rw-r--r--desktop/xfce4-xmms-plugin/xfce4-xmms-plugin.SlackBuild6
-rw-r--r--desktop/xtrascreenhacks/xtrascreenhacks.SlackBuild6
-rw-r--r--desktop/xvkbd/xvkbd.SlackBuild6
-rw-r--r--desktop/yawp/yawp.SlackBuild6
26 files changed, 130 insertions, 26 deletions
diff --git a/desktop/CurseTheWeather/CurseTheWeather.SlackBuild b/desktop/CurseTheWeather/CurseTheWeather.SlackBuild
index 8acd6ad8bc..dabaa2f468 100644
--- a/desktop/CurseTheWeather/CurseTheWeather.SlackBuild
+++ b/desktop/CurseTheWeather/CurseTheWeather.SlackBuild
@@ -51,7 +51,11 @@ rm -rf $PRGNAM-$VERSION
tar -xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Patch ctw to work with latest weather feed changes
# and display 10 day forecast
diff --git a/desktop/cairo-dock-plugins/cairo-dock-plugins.SlackBuild b/desktop/cairo-dock-plugins/cairo-dock-plugins.SlackBuild
index b176f99d14..1d9c9005d6 100644
--- a/desktop/cairo-dock-plugins/cairo-dock-plugins.SlackBuild
+++ b/desktop/cairo-dock-plugins/cairo-dock-plugins.SlackBuild
@@ -63,7 +63,11 @@ rm -rf $PRGNAM-$VERSION
tar -xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
cmake \
-DCMAKE_C_FLAGS_RELEASE:STRING="$SLKCFLAGS" \
diff --git a/desktop/cairo-dock/cairo-dock.SlackBuild b/desktop/cairo-dock/cairo-dock.SlackBuild
index 57f6fb48a7..07d5fa9e75 100644
--- a/desktop/cairo-dock/cairo-dock.SlackBuild
+++ b/desktop/cairo-dock/cairo-dock.SlackBuild
@@ -63,7 +63,11 @@ rm -rf $PRGNAM-$VERSION
tar -xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
cmake \
-DCMAKE_C_FLAGS_RELEASE:STRING="$SLKCFLAGS" \
diff --git a/desktop/cmatrix/cmatrix.SlackBuild b/desktop/cmatrix/cmatrix.SlackBuild
index 22331e01bf..ea56c70366 100644
--- a/desktop/cmatrix/cmatrix.SlackBuild
+++ b/desktop/cmatrix/cmatrix.SlackBuild
@@ -44,7 +44,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R a-s,u+rw,go-w .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Patch configure to find the fonts correctly
patch -p1 < $CWD/cmatrix-1.2a-find_fonts.diff
diff --git a/desktop/crystalcursors/crystalcursors.SlackBuild b/desktop/crystalcursors/crystalcursors.SlackBuild
index 9190d12212..aa9dc3df0e 100644
--- a/desktop/crystalcursors/crystalcursors.SlackBuild
+++ b/desktop/crystalcursors/crystalcursors.SlackBuild
@@ -39,7 +39,11 @@ tar xvf $CWD/${PRGNAM}_${VERSION}.orig.tar.gz || exit 1
mv Crystalcursors tmp-$PRGNAM
cd tmp-${PRGNAM}
chown -R root.root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
make || exit 1
make install PREFIX=$PKG/usr/share/icons || exit 1
diff --git a/desktop/gtk-chtheme/gtk-chtheme.SlackBuild b/desktop/gtk-chtheme/gtk-chtheme.SlackBuild
index 39c1aa0765..1ada16156f 100644
--- a/desktop/gtk-chtheme/gtk-chtheme.SlackBuild
+++ b/desktop/gtk-chtheme/gtk-chtheme.SlackBuild
@@ -67,7 +67,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
patch -p1 < $CWD/gtk-chtheme-0.3.1-new-api.patch
diff --git a/desktop/ion/ion.SlackBuild b/desktop/ion/ion.SlackBuild
index dd4deb525b..a9b87316f9 100644
--- a/desktop/ion/ion.SlackBuild
+++ b/desktop/ion/ion.SlackBuild
@@ -49,7 +49,11 @@ rm -rf $PRGNAM-$SRC_VERSION
tar xvf $CWD/$PRGNAM-$SRC_VERSION.tar.gz
cd $PRGNAM-$SRC_VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Patch system.mk after filtering it through sed to replace a few path issues,
# x86_64-specific things, and add optimization flags
diff --git a/desktop/jwm/jwm.SlackBuild b/desktop/jwm/jwm.SlackBuild
index 45159b214c..fe10b21cb7 100644
--- a/desktop/jwm/jwm.SlackBuild
+++ b/desktop/jwm/jwm.SlackBuild
@@ -45,7 +45,11 @@ rm -rf $PRGNAM-$VERSION
tar xjf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
diff --git a/desktop/kbdd/kbdd.SlackBuild b/desktop/kbdd/kbdd.SlackBuild
index 773227c121..e1bab925d2 100644
--- a/desktop/kbdd/kbdd.SlackBuild
+++ b/desktop/kbdd/kbdd.SlackBuild
@@ -49,7 +49,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
FLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
diff --git a/desktop/kcometen4/kcometen4.SlackBuild b/desktop/kcometen4/kcometen4.SlackBuild
index e831806ea1..263304d4c4 100644
--- a/desktop/kcometen4/kcometen4.SlackBuild
+++ b/desktop/kcometen4/kcometen4.SlackBuild
@@ -63,7 +63,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R a-s,u+w,go+r-w .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
cmake \
-DCMAKE_C_FLAGS="$SLKCFLAGS" \
diff --git a/desktop/maitreya/maitreya.SlackBuild b/desktop/maitreya/maitreya.SlackBuild
index 1582b6c1a1..3f6c5a6583 100644
--- a/desktop/maitreya/maitreya.SlackBuild
+++ b/desktop/maitreya/maitreya.SlackBuild
@@ -46,7 +46,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
./configure \
--prefix=/usr \
diff --git a/desktop/pidgin-guifications/pidgin-guifications.SlackBuild b/desktop/pidgin-guifications/pidgin-guifications.SlackBuild
index 47228b6386..faee0c98a6 100644
--- a/desktop/pidgin-guifications/pidgin-guifications.SlackBuild
+++ b/desktop/pidgin-guifications/pidgin-guifications.SlackBuild
@@ -44,7 +44,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
diff --git a/desktop/plasma-applet-daisy/plasma-applet-daisy.SlackBuild b/desktop/plasma-applet-daisy/plasma-applet-daisy.SlackBuild
index 5c9869fce3..0b52211b1e 100644
--- a/desktop/plasma-applet-daisy/plasma-applet-daisy.SlackBuild
+++ b/desktop/plasma-applet-daisy/plasma-applet-daisy.SlackBuild
@@ -44,7 +44,11 @@ cd $TMP
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
mkdir -p build
cd build
diff --git a/desktop/rootactions_servicemenu/rootactions_servicemenu.SlackBuild b/desktop/rootactions_servicemenu/rootactions_servicemenu.SlackBuild
index 10ef10f244..a3d7a4755b 100644
--- a/desktop/rootactions_servicemenu/rootactions_servicemenu.SlackBuild
+++ b/desktop/rootactions_servicemenu/rootactions_servicemenu.SlackBuild
@@ -45,7 +45,11 @@ cd $TMP
tar xvf $CWD/48411-${PRGNAM}_${VERSION}.tar.gz
cd ${PRGNAM}_${VERSION}
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
mkdir -p $PKG/usr/bin
cp -a \
diff --git a/desktop/rss-glx/rss-glx.SlackBuild b/desktop/rss-glx/rss-glx.SlackBuild
index e011c645e4..43bbe48ce5 100644
--- a/desktop/rss-glx/rss-glx.SlackBuild
+++ b/desktop/rss-glx/rss-glx.SlackBuild
@@ -63,7 +63,11 @@ rm -rf ${PRGNAM}_${VERSION}
tar xvf $CWD/${PRGNAM}_${VERSION}.tar.bz2
cd ${PRGNAM}_${VERSION}
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Magick Wand detection is broken.
./autogen.sh
diff --git a/desktop/simon/simon.SlackBuild b/desktop/simon/simon.SlackBuild
index 366b89d97f..2b048df093 100644
--- a/desktop/simon/simon.SlackBuild
+++ b/desktop/simon/simon.SlackBuild
@@ -65,7 +65,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
mkdir build
cd build/
diff --git a/desktop/vbox-runner/vbox-runner.SlackBuild b/desktop/vbox-runner/vbox-runner.SlackBuild
index 879fdd4252..f30a3d3e17 100644
--- a/desktop/vbox-runner/vbox-runner.SlackBuild
+++ b/desktop/vbox-runner/vbox-runner.SlackBuild
@@ -63,7 +63,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/107926-$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
KDEPREF=$(kde4-config --prefix)
diff --git a/desktop/whaw/whaw.SlackBuild b/desktop/whaw/whaw.SlackBuild
index 16ba172290..dc1c24890a 100644
--- a/desktop/whaw/whaw.SlackBuild
+++ b/desktop/whaw/whaw.SlackBuild
@@ -38,7 +38,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R a-s,u+rw,go-w .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
CFLAGS="$SLKCFLAGS" \
CPPFLAGS="$SLKCFLAGS" \
diff --git a/desktop/wmcliphist/wmcliphist.SlackBuild b/desktop/wmcliphist/wmcliphist.SlackBuild
index 8b1dabbc50..5a31f32e21 100644
--- a/desktop/wmcliphist/wmcliphist.SlackBuild
+++ b/desktop/wmcliphist/wmcliphist.SlackBuild
@@ -46,8 +46,12 @@ mkdir -p $PRGNAM-$VERSION
cd $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-latest.tar.gz
cd $PRGNAM
-chmod -R u+w,go+r-w,a-s .
chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
make CFLAGS="$SLKCFLAGS \$(INCLUDES)" LDFLAGS="-lX11"
mkdir -p $PKG/usr/bin
diff --git a/desktop/wmclock/wmclock.SlackBuild b/desktop/wmclock/wmclock.SlackBuild
index eba3962717..95a8274d51 100644
--- a/desktop/wmclock/wmclock.SlackBuild
+++ b/desktop/wmclock/wmclock.SlackBuild
@@ -47,7 +47,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R a-s,u+w,go+r-w .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Set the default language with LANGUAGE=<language> in the environment
# Default is english. It's still possible to display in other
diff --git a/desktop/wmctrl/wmctrl.SlackBuild b/desktop/wmctrl/wmctrl.SlackBuild
index 3997553940..3e628d93cb 100644
--- a/desktop/wmctrl/wmctrl.SlackBuild
+++ b/desktop/wmctrl/wmctrl.SlackBuild
@@ -48,7 +48,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
CFLAGS="$SLKCFLAGS" \
./configure \
diff --git a/desktop/wmmon/wmmon.SlackBuild b/desktop/wmmon/wmmon.SlackBuild
index 4976ac29f6..3005147038 100644
--- a/desktop/wmmon/wmmon.SlackBuild
+++ b/desktop/wmmon/wmmon.SlackBuild
@@ -47,7 +47,11 @@ rm -rf $PRGNAM.app
tar xvf $CWD/$PRGNAM-$SRCVER.tar.gz
cd $PRGNAM.app
chown -R root:root .
-chmod -R a-s,u+w,go+r-w .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# wmmon was pretty much abandoned by the original developer 10+ years ago.
# The Debian maintainer has added some security-related fixes, a man page,
diff --git a/desktop/xfce4-xmms-plugin/xfce4-xmms-plugin.SlackBuild b/desktop/xfce4-xmms-plugin/xfce4-xmms-plugin.SlackBuild
index 19c3e4071d..9a3ea3bdb8 100644
--- a/desktop/xfce4-xmms-plugin/xfce4-xmms-plugin.SlackBuild
+++ b/desktop/xfce4-xmms-plugin/xfce4-xmms-plugin.SlackBuild
@@ -63,7 +63,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
CFLAGS="$SLKCFLAGS" \
./configure \
diff --git a/desktop/xtrascreenhacks/xtrascreenhacks.SlackBuild b/desktop/xtrascreenhacks/xtrascreenhacks.SlackBuild
index e22a8321e2..52cab90c44 100644
--- a/desktop/xtrascreenhacks/xtrascreenhacks.SlackBuild
+++ b/desktop/xtrascreenhacks/xtrascreenhacks.SlackBuild
@@ -57,7 +57,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
diff --git a/desktop/xvkbd/xvkbd.SlackBuild b/desktop/xvkbd/xvkbd.SlackBuild
index 4a32558cc1..299e76ce42 100644
--- a/desktop/xvkbd/xvkbd.SlackBuild
+++ b/desktop/xvkbd/xvkbd.SlackBuild
@@ -49,7 +49,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
xmkmf
make
diff --git a/desktop/yawp/yawp.SlackBuild b/desktop/yawp/yawp.SlackBuild
index 541acc8efd..a9f77c42c1 100644
--- a/desktop/yawp/yawp.SlackBuild
+++ b/desktop/yawp/yawp.SlackBuild
@@ -62,7 +62,11 @@ cd $TMP
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \