summaryrefslogtreecommitdiffstats
path: root/desktop/x-tile
diff options
context:
space:
mode:
author Marcel Saegebarth2016-04-12 09:35:23 +0200
committer Marcel Saegebarth2016-04-12 09:35:23 +0200
commita17aec6a688dbffb773aba4d424351b7679610fe (patch)
tree0eb3dd89ed9edb8fb2ef2d87bf4b8fd74f1b6c01 /desktop/x-tile
parentb474cac0e2daab5d63b42958df61772be4eda9b1 (diff)
downloadslackbuilds-a17aec6a688dbffb773aba4d424351b7679610fe.tar.gz
desktop/x-tile: Migrated to GitHub + new maintainer.
Signed-off-by: Marcel Saegebarth <marc@mos6581.de>
Diffstat (limited to 'desktop/x-tile')
-rw-r--r--desktop/x-tile/doinst.sh1
-rw-r--r--desktop/x-tile/x-tile.SlackBuild46
-rw-r--r--desktop/x-tile/x-tile.info8
3 files changed, 25 insertions, 30 deletions
diff --git a/desktop/x-tile/doinst.sh b/desktop/x-tile/doinst.sh
index 1f8ff67ded..3e5691a052 100644
--- a/desktop/x-tile/doinst.sh
+++ b/desktop/x-tile/doinst.sh
@@ -7,4 +7,3 @@ if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
/usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
fi
fi
-
diff --git a/desktop/x-tile/x-tile.SlackBuild b/desktop/x-tile/x-tile.SlackBuild
index 58c112933a..116b08ad06 100644
--- a/desktop/x-tile/x-tile.SlackBuild
+++ b/desktop/x-tile/x-tile.SlackBuild
@@ -1,31 +1,34 @@
#!/bin/sh
-# Slackware build script for x-tile
+# Slackware build script for "x-tile".
# Copyright 2012 Chris Abela, Malta
-# Copyright 2014 Ryan P.C. McQuen, ryan.q@linux.com, WA
+# Copyright 2014-2016 Ryan P.C. McQuen, ryan.q@linux.com, WA
+# Copyright 2016 Marcel Saegebarth <marc@mos6581.de>
# All rights reserved.
#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions are
+# met:
#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
+# * Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=x-tile
VERSION=${VERSION:-2.5.1}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
ARCH=noarch
@@ -41,7 +44,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
+tar xvf $CWD/$VERSION.tar.gz || tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
@@ -52,16 +55,9 @@ find -L . \
python setup.py install --root=$PKG
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
mv $PKG/usr/share/man $PKG/usr/
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-mv $PKG//usr/lib*/python*/site-packages/*.egg-info \
- $PKG/usr/doc/$PRGNAM-$VERSION ; rm -rf $PKG/usr/lib*/
cp -a license $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/desktop/x-tile/x-tile.info b/desktop/x-tile/x-tile.info
index 1caa188ab8..fdf73605b7 100644
--- a/desktop/x-tile/x-tile.info
+++ b/desktop/x-tile/x-tile.info
@@ -1,10 +1,10 @@
PRGNAM="x-tile"
VERSION="2.5.1"
HOMEPAGE="http://www.giuspen.com/x-tile/"
-DOWNLOAD="http://www.giuspen.com/software/x-tile-2.5.1.tar.xz"
-MD5SUM="62b2f8b3fe26674963dacf9367bc695e"
+DOWNLOAD="https://github.com/giuspen/x-tile/archive/2.5.1.tar.gz"
+MD5SUM="2107d793b9488c91bfc4c5b1941f0ca9"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="gnome-python"
-MAINTAINER="Ryan P.C. McQuen"
-EMAIL="ryan.q@linux.com"
+MAINTAINER="Marcel Saegebarth"
+EMAIL="marc@mos6581.de"