summaryrefslogtreecommitdiffstats
path: root/desktop/oomox/oomox.SlackBuild
diff options
context:
space:
mode:
author Leo C2018-03-09 22:38:10 +0100
committer Willy Sudiarto Raharjo2018-03-10 01:11:04 +0100
commitd09268239880d46548d086856d87dbd575bb8a49 (patch)
tree9ca0010580081c7d217c0d9c2ab28981efa754bb /desktop/oomox/oomox.SlackBuild
parent3be4812f8257742b962a01d98c0c856043a4693a (diff)
downloadslackbuilds-d09268239880d46548d086856d87dbd575bb8a49.tar.gz
desktop/oomox: Updated for version 1.5.0.5.
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'desktop/oomox/oomox.SlackBuild')
-rw-r--r--desktop/oomox/oomox.SlackBuild102
1 files changed, 55 insertions, 47 deletions
diff --git a/desktop/oomox/oomox.SlackBuild b/desktop/oomox/oomox.SlackBuild
index 1c299bde20..53bc493fc7 100644
--- a/desktop/oomox/oomox.SlackBuild
+++ b/desktop/oomox/oomox.SlackBuild
@@ -23,14 +23,17 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=oomox
-VERSION=${VERSION:-1.4.3}
+VERSION=${VERSION:-1.5.0.5}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
ARCH=noarch
-OOMOXVER=${OOMOXVER:-1.2.9}
-MATERIAVER=${MATERIAVER:-20171112}
+ARCHDROIDVER=${ARCHDROIDVER:-1.0.2}
+GNOMECOLORSVER=${GNOMECOLORSVER:-5.5.3}
+OOMOXIFY_COMMIT=${OOMOXIFY_COMMIT:-675fedce9a47745212b062e13a7e51b01f2bb581}
+MATERIAVER=${MATERIAVER:-20180110}
+OOMOXVER=${OOMOXVER:-1.6.1}
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
@@ -55,15 +58,13 @@ find -L . \
make -f po.mk install
mkdir -p $PKG/opt/oomox
-cp -a archdroid-icon-theme archdroid.sh colors gnome-colors gnome_colors.sh \
- gui.sh locale oomox_gui oomoxify.sh po scripts \
+cp -a colors locale oomox_gui plugins po terminal_templates \
+ gui.sh \
$PKG/opt/oomox
-mkdir $PKG/opt/oomox/gtk-theme
-tar xvf $CWD/$PRGNAM-gtk-theme-$OOMOXVER.tar.gz --strip-components=1 -C $PKG/opt/oomox/gtk-theme
-( cd $PKG/opt/oomox/gtk-theme
- rm -fr .editorconfig .github .gitignore .hound.yml .scss-lint.yml .travis.yml \
- Dockerfile screenshot.png screenshots test
+tar xvf $CWD/oomox-archdroid-icon-theme-$ARCHDROIDVER.tar.gz --strip-components=1 -C $PKG/opt/oomox/plugins/icons_archdroid/archdroid-icon-theme
+( cd $PKG/opt/oomox/plugins/icons_archdroid/archdroid-icon-theme
+ rm -fr .git*
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -71,10 +72,9 @@ tar xvf $CWD/$PRGNAM-gtk-theme-$OOMOXVER.tar.gz --strip-components=1 -C $PKG/opt
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \; )
-mkdir $PKG/opt/oomox/materia-theme
-tar xvf $CWD/materia-theme-$MATERIAVER.tar.gz --strip-components=1 -C $PKG/opt/oomox/materia-theme
-( cd $PKG/opt/oomox/materia-theme
- rm -fr .github .gitignore test.sh
+tar xvf $CWD/oomox-gnome-colors-icon-theme-$GNOMECOLORSVER.tar.gz --strip-components=1 -C $PKG/opt/oomox/plugins/icons_gnomecolors/gnome-colors-icon-theme
+( cd $PKG/opt/oomox/plugins/icons_gnomecolors/gnome-colors-icon-theme
+ rm -fr .git*
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -82,45 +82,53 @@ tar xvf $CWD/materia-theme-$MATERIAVER.tar.gz --strip-components=1 -C $PKG/opt/o
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \; )
-mkdir -p $PKG/usr/bin
-
-cat > $PKG/usr/bin/oomox-gui <<EOF
-#!/bin/sh
-cd /opt/oomox
-exec ./gui.sh "\$@"
-EOF
-chmod +x $PKG/usr/bin/oomox-gui
+tar xvf $CWD/oomoxify-$OOMOXIFY_COMMIT.tar.gz --strip-components=1 -C $PKG/opt/oomox/plugins/oomoxify
+( cd $PKG/opt/oomox/plugins/oomoxify
+ rm -fr .git*
+ chown -R root:root .
+ find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \; )
-cat > $PKG/usr/bin/oomox-cli <<EOF
-#!/bin/sh
-cd /opt/oomox/gtk-theme
-exec ./change_color.sh "\$@"
-EOF
-chmod +x $PKG/usr/bin/oomox-cli
+tar xvf $CWD/materia-theme-$MATERIAVER.tar.gz --strip-components=1 -C $PKG/opt/oomox/plugins/theme_materia/materia-theme
+( cd $PKG/opt/oomox/plugins/theme_materia/materia-theme
+ rm -fr .git*
+ chown -R root:root .
+ find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \; )
-cat > $PKG/usr/bin/oomox-gnome-colors-icons-cli <<EOF
-#!/bin/sh
-cd /opt/oomox
-exec ./gnome-colors.sh "\$@"
-EOF
-chmod +x $PKG/usr/bin/oomox-gnome-colors-icons-cli
+tar xvf $CWD/$PRGNAM-gtk-theme-$OOMOXVER.tar.gz --strip-components=1 -C $PKG/opt/oomox/plugins/theme_oomox/gtk-theme
+( cd $PKG/opt/oomox/plugins/theme_oomox/gtk-theme
+ rm -fr .git* .editorconfig .*.yml {D,d}ocker* maintenance* screenshot* test*
+ chown -R root:root .
+ find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \; )
-cat > $PKG/usr/bin/oomox-archdroid-icons-cli <<EOF
-#!/bin/sh
-cd /opt/oomox
-exec ./archdroid.sh "\$@"
-EOF
-chmod +x $PKG/usr/bin/oomox-archdroid-icons-cli
+mkdir -p $PKG/usr/bin
+cp -a packaging/bin/* $PKG/usr/bin
-cat > $PKG/usr/bin/oomoxify-cli <<EOF
-#!/bin/sh
-cd /opt/oomox
-exec ./oomoxify.sh "\$@"
-EOF
-chmod +x $PKG/usr/bin/oomoxify-cli
+mkdir -p $PKG/usr/share/appdata
+cp -a packaging/com.github.actionless.oomox.appdata.xml $PKG/usr/share/appdata
mkdir -p $PKG/usr/share/applications
-cat $CWD/oomox.desktop > $PKG/usr/share/applications/oomox.desktop
+cp -a packaging/com.github.actionless.oomox.desktop $PKG/usr/share/applications
+
+mkdir -p $PKG/usr/share/icons/hicolor/64x64/apps
+cp -a packaging/com.github.actionless.oomox-64.png $PKG/usr/share/icons/hicolor/64x64/apps/com.github.actionless.oomox.png
+
+mkdir -p $PKG/usr/share/icons/hicolor/128x128/apps
+cp -a packaging/com.github.actionless.oomox-128.png $PKG/usr/share/icons/hicolor/128x128/apps/com.github.actionless.oomox.png
+
+mkdir -p $PKG/usr/share/icons/hicolor/666x666/apps
+cp -a packaging/com.github.actionless.oomox-666.png $PKG/usr/share/icons/hicolor/666x666/apps/com.github.actionless.oomox.png
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a CREDITS LICENSE README.md \