summaryrefslogtreecommitdiffstats
path: root/desktop/nwg-shell-config
diff options
context:
space:
mode:
author Jay Lanagan2023-03-04 00:13:52 +0100
committer Willy Sudiarto Raharjo2023-03-04 02:06:29 +0100
commit75ea21a87f2c3cf85b117e63336e8758d63fd3b8 (patch)
tree134bd7448f2ab86b2a6d2b30f0f78bb1f9eae1cd /desktop/nwg-shell-config
parenta93d22ac2537f135c8cad5669de4954d13020d31 (diff)
downloadslackbuilds-75ea21a87f2c3cf85b117e63336e8758d63fd3b8.tar.gz
desktop/nwg-shell-config: Added (configurator for nwg-shell)
Signed-off-by: bedlam <dave@slackbuilds.org> Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'desktop/nwg-shell-config')
-rw-r--r--desktop/nwg-shell-config/README5
-rw-r--r--desktop/nwg-shell-config/doinst.sh3
-rw-r--r--desktop/nwg-shell-config/nwg-shell-config.SlackBuild110
-rw-r--r--desktop/nwg-shell-config/nwg-shell-config.info10
-rw-r--r--desktop/nwg-shell-config/slack-desc19
5 files changed, 147 insertions, 0 deletions
diff --git a/desktop/nwg-shell-config/README b/desktop/nwg-shell-config/README
new file mode 100644
index 0000000000..331085418f
--- /dev/null
+++ b/desktop/nwg-shell-config/README
@@ -0,0 +1,5 @@
+nwg-shell-config (configurator for nwg-shell)
+
+This program is a GUI to configure all the components in one place.
+It also integrates several third party components, which we
+arbitrarily found the best to build a coherent user experience.
diff --git a/desktop/nwg-shell-config/doinst.sh b/desktop/nwg-shell-config/doinst.sh
new file mode 100644
index 0000000000..5fb28930db
--- /dev/null
+++ b/desktop/nwg-shell-config/doinst.sh
@@ -0,0 +1,3 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
diff --git a/desktop/nwg-shell-config/nwg-shell-config.SlackBuild b/desktop/nwg-shell-config/nwg-shell-config.SlackBuild
new file mode 100644
index 0000000000..1c28e2a6eb
--- /dev/null
+++ b/desktop/nwg-shell-config/nwg-shell-config.SlackBuild
@@ -0,0 +1,110 @@
+#!/bin/bash
+
+# Slackware build script for nwg-shell-config
+
+# Copyright 2023 Jay Lanagan (j@lngn.net), Detroit, MI, USA.
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=nwg-shell-config
+VERSION=${VERSION:-0.4.16}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+elif [ "$ARCH" = "aarch64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.?z
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --optimize=1 --root=$PKG
+mkdir -p $PKG/usr/share/applications $PKG/usr/share/pixmaps
+chmod 644 *.desktop *.svg
+cp nwg-shell-config.desktop $PKG/usr/share/applications
+cp *.svg $PKG/usr/share/pixmaps
+
+# manually remove installed Arch specific updater bins
+# if these aren't removed, a non-working applet will appear in WM
+rm $PKG/usr/bin/{nwg-shell-updater,nwg-update-indicator}
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+rm -rf $PKG/usr/lib${LIBDIRSUFFIX}/*.la
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE README.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/desktop/nwg-shell-config/nwg-shell-config.info b/desktop/nwg-shell-config/nwg-shell-config.info
new file mode 100644
index 0000000000..3542f03ab9
--- /dev/null
+++ b/desktop/nwg-shell-config/nwg-shell-config.info
@@ -0,0 +1,10 @@
+PRGNAM="nwg-shell-config"
+VERSION="0.4.16"
+HOMEPAGE="https://github.com/nwg-piotr/nwg-shell-config/"
+DOWNLOAD="https://github.com/nwg-piotr/nwg-shell-config/archive/v0.4.16/nwg-shell-config-0.4.16.tar.gz"
+MD5SUM="0fdf98655c6848813e49f4ed74f5fc08"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="wheel"
+MAINTAINER="Jay Lanagan"
+EMAIL="j@lngn.net"
diff --git a/desktop/nwg-shell-config/slack-desc b/desktop/nwg-shell-config/slack-desc
new file mode 100644
index 0000000000..cd8d598bc5
--- /dev/null
+++ b/desktop/nwg-shell-config/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+nwg-shell-config: nwg-shell-config (configurator for nwg-shell)
+nwg-shell-config:
+nwg-shell-config: This program is a GUI to configure all the components in one place.
+nwg-shell-config: It also integrates several third party components, which we
+nwg-shell-config: arbitrarily found the best to build a coherent user experience.
+nwg-shell-config:
+nwg-shell-config: Homepage: https://github.com/nwg-piotr/nwg-shell-config
+nwg-shell-config:
+nwg-shell-config:
+nwg-shell-config:
+nwg-shell-config: