summaryrefslogtreecommitdiffstats
path: root/desktop/dwm
diff options
context:
space:
mode:
author Tom Canich2010-05-13 00:22:35 +0200
committer Robby Workman2010-05-13 00:22:35 +0200
commit80a27183e4669ce50675c449add173538c025237 (patch)
tree5ca1854743e8974c44434478e3bb95b60c3e3a67 /desktop/dwm
parent2cc3ee9cd42c3038302ea26e12b958ea6891b60e (diff)
downloadslackbuilds-80a27183e4669ce50675c449add173538c025237.tar.gz
desktop/dwm: Updated for version 5.7.2
Diffstat (limited to 'desktop/dwm')
-rw-r--r--desktop/dwm/README1
-rw-r--r--desktop/dwm/README.SBo8
-rw-r--r--desktop/dwm/add_OPTS_to_config.mk.diff12
-rw-r--r--desktop/dwm/dwm.SlackBuild60
-rw-r--r--desktop/dwm/dwm.info10
-rw-r--r--desktop/dwm/patches/config_mk.patch13
-rw-r--r--desktop/dwm/slack-desc18
7 files changed, 61 insertions, 61 deletions
diff --git a/desktop/dwm/README b/desktop/dwm/README
index 12de13eca0..4d177eb75e 100644
--- a/desktop/dwm/README
+++ b/desktop/dwm/README
@@ -21,4 +21,3 @@ different color, while the tags of the focused window are highlighted
with a small point.
dwm draws a small border around windows to indicate their focus state.
-
diff --git a/desktop/dwm/README.SBo b/desktop/dwm/README.SBo
index b21499496b..02b71b4bea 100644
--- a/desktop/dwm/README.SBo
+++ b/desktop/dwm/README.SBo
@@ -11,14 +11,12 @@ SlackBuild script.
Example:
-$ cd dwm-5.5
+$ tar xvf dwm-5.7.2.tar.gz
+$ cd dwm-5.7.2
$ cp config.def.h config.h
$ vi config.h
[make customizations]
-$ diff -u config.h config.def.h >> ../patches/config.patch
+$ diff -u config.def.h config.h > ../patches/config.patch
$ cd ..
$ sh dwm.SlackBuild
-
-
-
diff --git a/desktop/dwm/add_OPTS_to_config.mk.diff b/desktop/dwm/add_OPTS_to_config.mk.diff
new file mode 100644
index 0000000000..414b7bb99f
--- /dev/null
+++ b/desktop/dwm/add_OPTS_to_config.mk.diff
@@ -0,0 +1,12 @@
+diff -Nur dwm-5.7.2.orig/config.mk dwm-5.7.2/config.mk
+--- dwm-5.7.2.orig/config.mk 2009-09-27 14:20:23.000000000 -0500
++++ dwm-5.7.2/config.mk 2009-10-14 22:09:46.313425339 -0500
+@@ -21,7 +21,7 @@
+ # flags
+ CPPFLAGS = -DVERSION=\"${VERSION}\" ${XINERAMAFLAGS}
+ #CFLAGS = -g -std=c99 -pedantic -Wall -O0 ${INCS} ${CPPFLAGS}
+-CFLAGS = -std=c99 -pedantic -Wall -Os ${INCS} ${CPPFLAGS}
++CFLAGS = -std=c99 -pedantic -Wall ${OPTS} ${INCS} ${CPPFLAGS}
+ #LDFLAGS = -g ${LIBS}
+ LDFLAGS = -s ${LIBS}
+
diff --git a/desktop/dwm/dwm.SlackBuild b/desktop/dwm/dwm.SlackBuild
index 1f384cc3c0..8a8f3323ec 100644
--- a/desktop/dwm/dwm.SlackBuild
+++ b/desktop/dwm/dwm.SlackBuild
@@ -2,47 +2,39 @@
# Slackware build script for dwm
-# Written by Tom Canich <tcanich@canich.net>
-# Released under the BSD
# Copyright (c) 2009, Tom Canich, State College, Pennsylvania, USA
# All rights reserved.
#
# Redistribution and use in source and binary forms, with or without
# modification, are permitted provided that the following conditions
# are met:
-# * Redistributions of source code must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-# * Redistributions in binary form must reproduce the above
-# copyright notice, this list of conditions and the following
-# disclaimer in the documentation and/or other materials
-# provided with the distribution.
-# * Neither the name of Tom Canich nor the names of other
-# contributors may be used to endorse or promote
-# products
-# derived from this software without specific prior
-# written
-# permission.
+# * Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+# * Redistributions in binary form must reproduce the above
+# copyright notice, this list of conditions and the following
+# disclaimer in the documentation and/or other materials
+# provided with the distribution.
+# * Neither the name of Tom Canich nor the names of other contributors
+# may be used to endorse or promote products derived from this
+# software without specific prior written prior written permission.
#
# THIS SOFTWARE IS PROVIDED BY Tom Canich ''AS IS'' AND ANY
# EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
# IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
# PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL Tom Canich BE LIABLE FOR
-# ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
-# CONSEQUENTIAL
+# ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
# DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE
# GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
# INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER
# IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN
# IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-#
-# Modified by the SlackBuilds.org project
PRGNAM=dwm
-VERSION=${VERSION:-5.5}
+VERSION=${VERSION:-5.7.2}
ARCH=${ARCH:-i486}
-BUILD=${BUILD:-2}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
CWD=$(pwd)
@@ -54,10 +46,13 @@ INSTALL="/bin/ginstall -o root -g root"
if [ "$ARCH" = "i486" ]; then
SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
fi
set -e
@@ -69,21 +64,28 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
-for i in `ls $CWD/patches`; do
+# Apply our patch add custom CFLAGS first:
+patch -p1 < $CWD/add_OPTS_to_config.mk.diff
+
+# Now apply any other patches that users might have added
+for i in $(ls $CWD/patches); do
echo "Applying patch $i"
patch -p0 < $CWD/patches/$i
done
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-make PREFIX=/usr
-make install DESTDIR=$PKG
+make install \
+ OPTS="$SLKCFLAGS" \
+ PREFIX=/usr \
+ MANPREFIX=/usr/man \
+ X11INC=/usr/include/X11 \
+ X11LIB=/usr/lib${LIBDIRSUFFIX}/X11 \
+ DESTDIR=$PKG
( cd $PKG
find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | \
xargs strip --strip-unneeded 2> /dev/null || true
find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | \
- xargs strip --strip-unneeded 2> /dev/null
+ xargs strip --strip-unneeded 2> /dev/null || true
)
( cd $PKG/usr/man
@@ -92,12 +94,12 @@ make install DESTDIR=$PKG
)
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp $CWD/README* $PKG/usr/doc/$PRGNAM-$VERSION
-cp -r $CWD/patches $PKG/usr/doc/$PRGNAM-$VERSION/patches
+cp $CWD/README $CWD/README.SBo $PKG/usr/doc/$PRGNAM-$VERSION
+cp -r $CWD/patches $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/desktop/dwm/dwm.info b/desktop/dwm/dwm.info
index 0182811bb9..3f423f2bca 100644
--- a/desktop/dwm/dwm.info
+++ b/desktop/dwm/dwm.info
@@ -1,8 +1,10 @@
PRGNAM="dwm"
-VERSION="5.5"
+VERSION="5.7.2"
HOMEPAGE="http://dwm.suckless.org"
-DOWNLOAD="http://code.suckless.org/dl/dwm/dwm-5.5.tar.gz"
-MD5SUM="352d952e839ab0e2df0b0959a250b098"
+DOWNLOAD="http://dl.suckless.org/dwm/dwm-5.7.2.tar.gz"
+MD5SUM="a0b8a799ddc5034dd8a818c9bd76f3a3"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
MAINTAINER="Tom Canich"
EMAIL="tcanich@canich.net"
-APPROVED="chess"
+APPROVED="rworkman"
diff --git a/desktop/dwm/patches/config_mk.patch b/desktop/dwm/patches/config_mk.patch
deleted file mode 100644
index bc5cea3094..0000000000
--- a/desktop/dwm/patches/config_mk.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- config.mk.orig 2009-04-20 20:25:24.000000000 -0400
-+++ config.mk 2009-04-20 20:25:38.000000000 -0400
-@@ -4,8 +4,8 @@
- # Customize below to fit your system
-
- # paths
--PREFIX = /usr/local
--MANPREFIX = ${PREFIX}/share/man
-+PREFIX = /usr
-+MANPREFIX = ${PREFIX}/man
-
- X11INC = /usr/X11R6/include
- X11LIB = /usr/X11R6/lib
diff --git a/desktop/dwm/slack-desc b/desktop/dwm/slack-desc
index f13980db6d..0d865cf88f 100644
--- a/desktop/dwm/slack-desc
+++ b/desktop/dwm/slack-desc
@@ -5,15 +5,15 @@
# make exactly 11 lines for the formatting to be correct. It's also
# customary to leave one space after the ':'.
- |-----handy-ruler------------------------------------------------------|
+ |-----handy-ruler--------------------------------------------------------|
dwm: dwm (suckless dynamic window manager)
dwm:
-dwm: dwm is a dynamic window manager for X. It manages windows in tiled
-dwm: and floating layouts. Either layout can be applied dynamically,
-dwm: optimizing the environment for the application in use and the task
-dwm: performed. It is the little brother of wmii.
-dwm: In tiled layout, windows are managed in a master and stacking area.
-dwm: The master area contains the windows which currently need most
-dwm: attention, whereas the stacking area contains all other windows.
-dwm:
+dwm: dwm is a dynamic window manager for X. It manages windows in tiled and
+dwm: floating layouts. Either layout can be applied dynamically, optimizing
+dwm: the environment for the application in use and the task performed. It
+dwm: is the little brother of wmii.
+dwm: In tiled layout, windows are managed in a master and stacking area. The
+dwm: master area contains the windows which currently need most attention,
+dwm: whereas the stacking area contains all other windows.
+dwm:
dwm: Homepage: http://dwm.suckless.org