summaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
author Johannes Schoepfer2023-07-15 04:46:42 +0200
committer Willy Sudiarto Raharjo2023-07-15 04:46:42 +0200
commit2cf2420aa6b64730f1db1f43e4301df13f61ff9b (patch)
tree0dafa31fda2ecac9e68ab5a13aba9b05efc3c56e /audio
parentededbf698a5f0f09742bfd3d354144aa81874ce1 (diff)
downloadslackbuilds-2cf2420aa6b64730f1db1f43e4301df13f61ff9b.tar.gz
audio/tuner: Script update.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'audio')
-rw-r--r--audio/tuner/tuner.SlackBuild22
1 files changed, 17 insertions, 5 deletions
diff --git a/audio/tuner/tuner.SlackBuild b/audio/tuner/tuner.SlackBuild
index b4f160e81a..235bfc1252 100644
--- a/audio/tuner/tuner.SlackBuild
+++ b/audio/tuner/tuner.SlackBuild
@@ -70,9 +70,24 @@ cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
+ -o -perm 511 \) -exec chmod 755 {} + -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} +
+
+# Remove com.github.louis77 from filenames
+GITHUB_NAME=com.github.louis77
+mv $GITHUB_NAME.$PRGNAM.yml $PRGNAM.yml
+for src_nam in meson.build data/$GITHUB_NAME.$PRGNAM.desktop.in; do
+ sed "s/$GITHUB_NAME.//g" -i $src_nam
+done
+for icon_size in 16 24 32 48 64 128; do
+ for icon in tuner.png tuner-symbolic.png tuner.svg; do
+ mv data/icons/$icon_size/$GITHUB_NAME.$icon data/icons/$icon_size/$icon
+ done
+done
+for src_nam in appdata.xml.in desktop.in gresource.xml gschema.xml; do
+ mv data/$GITHUB_NAME.$PRGNAM.$src_nam data/$PRGNAM.$src_nam
+done
mkdir build
cd build
@@ -88,9 +103,6 @@ cd build
DESTDIR=$PKG $NINJA install
cd ..
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a LICENSE NOTES.md PACKAGING.md README.md $PKG/usr/doc/$PRGNAM-$VERSION