summaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
author Robby Workman2021-04-22 03:09:17 +0200
committer Robby Workman2021-04-22 03:09:17 +0200
commit2cc1cff83f8232f62d6c22dbb2d870ee7f00f05c (patch)
tree92b5385e6d8e1b1bdbecd1026441a1a4af0a50a1 /audio
parente0130b7820c1e0c1653ed01bc84b8ab3e1dce8cb (diff)
downloadslackbuilds-2cc1cff83f8232f62d6c22dbb2d870ee7f00f05c.tar.gz
audio/aacplusenc: Removed (no maintainer)
Diffstat (limited to 'audio')
-rw-r--r--audio/aacplusenc/README7
-rw-r--r--audio/aacplusenc/aacplusenc.SlackBuild101
-rw-r--r--audio/aacplusenc/aacplusenc.info10
-rw-r--r--audio/aacplusenc/slack-desc19
4 files changed, 0 insertions, 137 deletions
diff --git a/audio/aacplusenc/README b/audio/aacplusenc/README
deleted file mode 100644
index 0407f4ea02..0000000000
--- a/audio/aacplusenc/README
+++ /dev/null
@@ -1,7 +0,0 @@
-aacplusenc (High-Efficency AAC (AAC+))
-
-Command-line encoder that outputs aacPlus v2 files (ie. Advanced Audio
-Coding + Spectral Band Resonation + Parametric Stereo, or AAC + SBR +
-PS), also known as HE-AAC+ (High Efficiency AAC+). Developed by Coding
-Technologies, based on the reference code obtained from 3GPP,
-repackaged to compile on contemporary Linux by Matteo Croce.
diff --git a/audio/aacplusenc/aacplusenc.SlackBuild b/audio/aacplusenc/aacplusenc.SlackBuild
deleted file mode 100644
index 274b649738..0000000000
--- a/audio/aacplusenc/aacplusenc.SlackBuild
+++ /dev/null
@@ -1,101 +0,0 @@
-#!/bin/sh
-#
-# Slackware build script for aacplusenc.
-#
-# Copyright 2015-2020 Edinaldo P. Silva, Rio de Janeiro, Brazil.
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=aacplusenc
-VERSION=${VERSION:-0.17.5}
-BUILD=${BUILD:-2}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/${PRGNAM}_${VERSION}.tar.gz
-mv $PRGNAM $PRGNAM-$VERSION
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --mandir=/usr/man \
- --docdir=/usr/doc/$PRGNAM-$VERSION \
- --build=$ARCH-slackware-linux
-
-make
-
-mkdir -p $PKG/usr/bin
-cp -a aacplusenc $PKG/usr/bin
-strip -s -R.comment $PKG/usr/bin/aacplusenc
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a COPYRIGHT debian/changelog $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM-SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/audio/aacplusenc/aacplusenc.info b/audio/aacplusenc/aacplusenc.info
deleted file mode 100644
index d62a7955f9..0000000000
--- a/audio/aacplusenc/aacplusenc.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="aacplusenc"
-VERSION="0.17.5"
-HOMEPAGE="http://teknoraver.net/software/mp4tools/"
-DOWNLOAD="http://ppa.launchpad.net/teknoraver/ppa/ubuntu/pool/main/a/aacplusenc/aacplusenc_0.17.5.tar.gz"
-MD5SUM="f9df37068517ff8598f2b0ed31b67921"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="orphaned - no maintainer"
-EMAIL="nobody@nowhere"
diff --git a/audio/aacplusenc/slack-desc b/audio/aacplusenc/slack-desc
deleted file mode 100644
index 91c8b41691..0000000000
--- a/audio/aacplusenc/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-aacplusenc: aacplusenc (High-Efficency AAC (AAC+))
-aacplusenc:
-aacplusenc: Command-line encoder that outputs aacPlus v2 files (ie. Advanced Audio
-aacplusenc: Coding + Spectral Band Resonation + Parametric Stereo, or AAC + SBR +
-aacplusenc: PS), also known as HE-AAC+ (High Efficiency AAC+). Developed by Coding
-aacplusenc: Technologies, based on the reference code obtained from 3GPP,
-aacplusenc: repackaged to compile on contemporary Linux by Matteo Croce.
-aacplusenc:
-aacplusenc: Home Page: http://teknoraver.net/software/mp4tools/
-aacplusenc:
-aacplusenc: