summaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
author Heinz Wiesinger2010-05-11 20:30:49 +0200
committer Heinz Wiesinger2010-05-11 20:30:49 +0200
commit96d9d5a9a46136d88f191f6b498716afc3d956fd (patch)
tree9c3791331e89f1deec2338af939550ed33f43c81 /audio
parent999c1ed65abee216d96a9ad9b753f55afe5e9dd0 (diff)
downloadslackbuilds-96d9d5a9a46136d88f191f6b498716afc3d956fd.tar.gz
audio/moc: Moved from multimedia
Diffstat (limited to 'audio')
-rw-r--r--audio/moc/README4
-rw-r--r--audio/moc/configure.in.diff10
-rw-r--r--audio/moc/ffmpeg.c.diff14
-rw-r--r--audio/moc/moc.SlackBuild93
-rw-r--r--audio/moc/moc.info8
-rw-r--r--audio/moc/slack-desc19
6 files changed, 148 insertions, 0 deletions
diff --git a/audio/moc/README b/audio/moc/README
new file mode 100644
index 0000000000..2763be1415
--- /dev/null
+++ b/audio/moc/README
@@ -0,0 +1,4 @@
+MOC (music on console)
+
+MOC is a console audio player for LINUX/UNIX designed to be powerful
+and easy to use.
diff --git a/audio/moc/configure.in.diff b/audio/moc/configure.in.diff
new file mode 100644
index 0000000000..3d2a7d103e
--- /dev/null
+++ b/audio/moc/configure.in.diff
@@ -0,0 +1,10 @@
+--- configure.in~ 2008-06-25 18:41:07.000000000 +0200
++++ configure.in 2008-06-25 18:41:15.000000000 +0200
+@@ -383,6 +383,7 @@
+ DECODER_PLUGINS="$DECODER_PLUGINS ffmpeg"],
+ [true])
+ fi
++ AC_CHECK_HEADERS(ffmpeg/avformat.h libavformat/avformat.h)
+ fi
+
+ dnl speex
diff --git a/audio/moc/ffmpeg.c.diff b/audio/moc/ffmpeg.c.diff
new file mode 100644
index 0000000000..6a5d4d1651
--- /dev/null
+++ b/audio/moc/ffmpeg.c.diff
@@ -0,0 +1,14 @@
+--- decoder_plugins/ffmpeg/ffmpeg.c~ 2008-06-25 18:43:02.000000000 +0200
++++ decoder_plugins/ffmpeg/ffmpeg.c 2008-06-25 18:43:15.000000000 +0200
+@@ -22,7 +22,11 @@
+ #ifdef HAVE_INTTYPES_H
+ # include <inttypes.h>
+ #endif
++#if HAVE_LIBAVFORMAT_AVFORMAT_H
++#include <libavformat/avformat.h>
++#else
+ #include <ffmpeg/avformat.h>
++#endif
+
+ /* FFmpeg also likes common names, without that, our common.h and log.h would
+ * not be included. */
diff --git a/audio/moc/moc.SlackBuild b/audio/moc/moc.SlackBuild
new file mode 100644
index 0000000000..2268b92370
--- /dev/null
+++ b/audio/moc/moc.SlackBuild
@@ -0,0 +1,93 @@
+#!/bin/sh
+
+# Slackware build script for moc
+
+# (C) 2007 Michael Wagner <lapinours@web.de>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=moc
+VERSION=2.4.3
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-2}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCS="AUTHORS COPYING ChangeLog INSTALL NEWS README THANKS TODO \
+ config.example keymap.example"
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+# Patch configure.in and ffmpeg.c for use with newer
+# ffmpeg versions
+patch -p0 < $CWD/configure.in.diff
+patch -p0 < $CWD/ffmpeg.c.diff
+
+aclocal -I m4 && automake && autoconf
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --mandir=/usr/man \
+ --disable-debug
+
+make
+make install-strip DESTDIR=$PKG
+
+gzip -9 $PKG/usr/man/man1/*.?
+
+# Remove $PKG/usr/share/doc (the Makefile doesn't seem to understand docdir)
+rm -rf $PKG/usr/share/doc
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+chmod 644 $PKG/usr/doc/$PRGNAM-$VERSION/*
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/audio/moc/moc.info b/audio/moc/moc.info
new file mode 100644
index 0000000000..7013c44ad9
--- /dev/null
+++ b/audio/moc/moc.info
@@ -0,0 +1,8 @@
+PRGNAM="moc"
+VERSION="2.4.3"
+HOMEPAGE="http://moc.daper.net"
+DOWNLOAD="ftp://ftp.daper.net/pub/soft/moc/stable/moc-2.4.3.tar.bz2"
+MD5SUM="8808082848e90eeec5415baaec7e98ad"
+MAINTAINER="Michael Wagner"
+EMAIL="lapinours@web.de"
+APPROVED="David Somero"
diff --git a/audio/moc/slack-desc b/audio/moc/slack-desc
new file mode 100644
index 0000000000..c9932116bc
--- /dev/null
+++ b/audio/moc/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+moc: MOC (music on console)
+moc:
+moc: MOC is a console audio player for LINUX/UNIX
+moc: designed to be powerful and easy to use.
+moc:
+moc: Homepage: http://moc.daper.net
+moc:
+moc:
+moc:
+moc:
+moc: