summaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
author Dugan Chen2013-02-14 00:40:52 +0100
committer dsomero2013-02-14 01:33:51 +0100
commitadee97d9f9513d8f78dcd2824463dd36892654c2 (patch)
tree68101e069ee171ee94c35c66cee069790cefee84 /audio
parent20d12a41e8f426e7639c59d3dbcdd9ddce53390b (diff)
downloadslackbuilds-adee97d9f9513d8f78dcd2824463dd36892654c2.tar.gz
development/mutagen: Updated for version 1.21.
Moved from audio. Signed-off-by: dsomero <xgizzmo@slackbuilds.org>
Diffstat (limited to 'audio')
-rw-r--r--audio/mutagen/README3
-rw-r--r--audio/mutagen/mutagen.SlackBuild95
-rw-r--r--audio/mutagen/mutagen.info10
-rw-r--r--audio/mutagen/slack-desc19
4 files changed, 0 insertions, 127 deletions
diff --git a/audio/mutagen/README b/audio/mutagen/README
deleted file mode 100644
index fdc9e95862..0000000000
--- a/audio/mutagen/README
+++ /dev/null
@@ -1,3 +0,0 @@
-Mutagen is a Python module to handle audio metadata. It supports ASF,
-FLAC, M4A, Monkey's Audio, MP3, Musepack, Ogg FLAC, Ogg Speex, Ogg
-Theora, Ogg Vorbis, True Audio, WavPack and OptimFROG audio files.
diff --git a/audio/mutagen/mutagen.SlackBuild b/audio/mutagen/mutagen.SlackBuild
deleted file mode 100644
index 9c1d9e87a5..0000000000
--- a/audio/mutagen/mutagen.SlackBuild
+++ /dev/null
@@ -1,95 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for Mutagen
-
-# Currently maintained by Dugan Chen (thedoogster [at] gmail [dot] [com])
-
-# Copyright 2008 Frank Caraballo <fecaraballo{at}gmail{dot}com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=mutagen
-VERSION=${VERSION:-1.20}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP || exit 1
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.?z* || exit 1
-cd $PRGNAM-$VERSION || exit 1
-chown -R root:root .
-find . \
- \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-python setup.py build || exit 1
-python setup.py install --root $PKG || exit 1
-
-# Move man page(s) to correct location:
-mv $PKG/usr/share/man $PKG/usr/man
-rm -rf $PKG/usr/share
-
-( cd $PKG/usr/man
- find . -type f -exec gzip -9 {} \;
- for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-)
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a API-NOTES COPYING NEWS PKG-INFO README TODO TUTORIAL \
- $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/audio/mutagen/mutagen.info b/audio/mutagen/mutagen.info
deleted file mode 100644
index afc6126df0..0000000000
--- a/audio/mutagen/mutagen.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="mutagen"
-VERSION="1.20"
-HOMEPAGE="http://code.google.com/p/mutagen/"
-DOWNLOAD="http://mutagen.googlecode.com/files/mutagen-1.20.tar.gz"
-MD5SUM="adb16d9f6056bc864a5c86c6f885af79"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Dugan Chen"
-EMAIL="thedoogster [at] gmail [dot] com"
diff --git a/audio/mutagen/slack-desc b/audio/mutagen/slack-desc
deleted file mode 100644
index edf2d2e3f5..0000000000
--- a/audio/mutagen/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description. Line
-# up the first '|' above the ':' following the base package name, and the '|' on
-# the right side marks the last column you can put a character in. You must make
-# exactly 11 lines for the formatting to be correct. It's also customary to
-# leave one space after the ':'.
-
- |-----handy-ruler------------------------------------------------------|
-mutagen: Mutagen (Python Module)
-mutagen:
-mutagen: Mutagen is a Python module to handle audio metadata. It supports ASF,
-mutagen: FLAC, M4A, Monkey's Audio, MP3, Musepack, Ogg FLAC, Ogg Speex, Ogg
-mutagen: Theora, Ogg Vorbis, True Audio, WavPack and OptimFROG audio files.
-mutagen:
-mutagen: Homepage: http://code.google.com/p/quodlibet/
-mutagen:
-mutagen:
-mutagen:
-mutagen: