summaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
author Glenn Becker2012-12-20 23:02:45 +0100
committer Matteo Bernardini2012-12-21 21:27:22 +0100
commit52b9782d49b4f7995cb4d8f333110e4c232bb609 (patch)
tree3412e4cf6bd719df191decc700d2b0b59a10d1d2 /audio
parent77efda2c98a7d233423948bc64180e5621f9aaea (diff)
downloadslackbuilds-52b9782d49b4f7995cb4d8f333110e4c232bb609.tar.gz
audio/abcde: Updated for version 2.5.4.
Noted missing perl modules for musicbrainz-tool Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'audio')
-rw-r--r--audio/abcde/Makefile.diff25
-rw-r--r--audio/abcde/README10
-rw-r--r--audio/abcde/aac_speex_tagging.diff35
-rw-r--r--audio/abcde/abcde.SlackBuild26
-rw-r--r--audio/abcde/abcde.info12
-rw-r--r--audio/abcde/cddb-tool.diff11
-rw-r--r--audio/abcde/slack-desc2
7 files changed, 43 insertions, 78 deletions
diff --git a/audio/abcde/Makefile.diff b/audio/abcde/Makefile.diff
index 1f27b35588..1867f96bad 100644
--- a/audio/abcde/Makefile.diff
+++ b/audio/abcde/Makefile.diff
@@ -1,6 +1,6 @@
---- abcde-2.3.99.6.orig/Makefile 2006-08-05 10:10:52.000000000 +1000
-+++ abcde-2.3.99.6/Makefile 2008-12-18 21:26:21.000000000 +1100
-@@ -4,7 +4,7 @@
+--- abcde-2.5.4.orig/Makefile 2012-10-07 13:35:53.429882065 -0400
++++ abcde-2.5.4/Makefile 2012-10-07 13:39:37.271325434 -0400
+@@ -3,7 +3,7 @@
# Installation directories
prefix = ${DESTDIR}/usr
exec_prefix = ${prefix}
@@ -9,22 +9,3 @@
bindir = ${exec_prefix}/bin
etcdir = ${DESTDIR}/etc
-@@ -14,13 +14,13 @@
-
- install:
- $(INSTALL) -d -m 755 $(bindir)
-- $(INSTALL) -m 755 -o 0 abcde $(bindir)
-- $(INSTALL) -m 755 -o 0 cddb-tool $(bindir)
-+ $(INSTALL) -m 755 abcde $(bindir)
-+ $(INSTALL) -m 755 cddb-tool $(bindir)
- $(INSTALL) -d -m 755 $(mandir)
-- $(INSTALL) -m 644 -o 0 abcde.1 $(mandir)
-- $(INSTALL) -m 644 -o 0 cddb-tool.1 $(mandir)
-+ $(INSTALL) -m 644 abcde.1 $(mandir)
-+ $(INSTALL) -m 644 cddb-tool.1 $(mandir)
- $(INSTALL) -d -m 755 $(etcdir)
-- $(INSTALL) -m 644 -o 0 abcde.conf $(etcdir)
-+ $(INSTALL) -m 644 abcde.conf $(etcdir)
-
- tarball:
- @cd .. && tar czvf abcde_$(VERSION).orig.tar.gz \
diff --git a/audio/abcde/README b/audio/abcde/README
index 028fc726d7..3b6c074d74 100644
--- a/audio/abcde/README
+++ b/audio/abcde/README
@@ -14,6 +14,16 @@ with one or more of these optional dependencies:
* speex : for creating Speex files
* vorbisgain : for adjusting the volume of ogg vorbis files
+PLEASE NOTE: the included abcde-musicbrainz-tool script requires the
+following Perl modules (which are not available through SlackBuilds.org
+yet):
+
+MusicBrainz::DiscID
+WebService::MusicBrainz::Release
+WebService::MusicBrainz::Artist
+WebService::MusicBrainz::Response::Track
+WebService::MusicBrainz::Response::TrackList
+
Try running abcde as root (sudo or whatever) if abcde/cd-discid thinks
your favorite audio cd is a data cd. Please note also that faac needs
to have mp4 support enabled to work correctly with abcde.
diff --git a/audio/abcde/aac_speex_tagging.diff b/audio/abcde/aac_speex_tagging.diff
deleted file mode 100644
index 20b5c23a27..0000000000
--- a/audio/abcde/aac_speex_tagging.diff
+++ /dev/null
@@ -1,35 +0,0 @@
-# ------------------------------------------------------------------------------------------------ #
-# This patch fixes automatic aac and speex tagging in abcde-2.3.99.6
-# and is an amalgamation of 2 separate patches from Ubuntu and Fedora:
-# http://patches.ubuntu.com/a/abcde/abcde_2.3.99.6-1ubuntu2.patch
-# http://cvs.fedoraproject.org/viewvc/rpms/abcde/F-10/abcde-2.3.99.6-speex-comment.patch?view=co
-# ------------------------------------------------------------------------------------------------ #
-diff -Naur abcde-2.3.99.6.orig/abcde abcde-2.3.99.6/abcde
---- abcde-2.3.99.6.orig/abcde 2006-08-06 05:14:00.000000000 +1000
-+++ abcde-2.3.99.6/abcde 2009-03-17 21:07:11.000000000 +1100
-@@ -1068,11 +1068,10 @@
- *=*) ;;
- *) COMMENT="COMMENT=$COMMENT" ;;
- esac
-- COMMENT="--comment \"$COMMENT\""
- fi
-- # Quick hack to avoid tagging Ogg/Speex, since there is no other way to tag than inline tagging
-- if [ ! "$DOTAG" = "y" ]; then
-- $RUN_COMMAND nice $EFFECTIVE_NICE $SPEEXENCODER $SPEEXENCODEROPTS --author "$TRACKARTIST" --title "$TRACKNAME" "$COMMENT" "$IN" "$OUT"
-+ # Tag the file at encode time, as it can't be done after encoding.
-+ if [ "$DOTAG" = "y" ]; then
-+ $RUN_COMMAND nice $EFFECTIVE_NICE $SPEEXENCODER $SPEEXENCODEROPTS --author "$TRACKARTIST" --title "$TRACKNAME" ${COMMENT:+--comment "$COMMENT"} "$IN" "$OUT"
- else
- $RUN_COMMAND nice $EFFECTIVE_NICE $SPEEXENCODER $SPEEXENCODEROPTS "$IN" "$OUT"
- fi
-@@ -1087,8 +1086,8 @@
- $RUN_COMMAND nice $EFFECTIVE_NICE $MPPENCODER $MPPENCODEROPTS --artist "$TRACKARTIST" --album "$DALBUM" --title "$TRACKNAME" --track "$1" --genre "$CDGENRE" --year "$CDYEAR" --comment "$COMMENT" "$IN" "$OUT"
- ;;
- m4a)
-- # Quick hack to avoid tagging Ogg/Speex, since there is no other way to tag than inline tagging
-- if [ ! "$DOTAG" = "y" ]; then
-+ # Tag the file at encode time, as it can't be done after encoding.
-+ if [ "$DOTAG" = "y" ]; then
- $RUN_COMMAND nice $EFFECTIVE_NICE $AACENCODER $AACENCODEROPTS --artist "$TRACKARTIST" --album "$DALBUM" --title "$TRACKNAME" --track "$1" --genre "$CDGENRE" --year "$CDYEAR" --comment "$COMMENT" -o "$OUT" "$IN"
-
- else
diff --git a/audio/abcde/abcde.SlackBuild b/audio/abcde/abcde.SlackBuild
index 495e3a8613..e287d81c6b 100644
--- a/audio/abcde/abcde.SlackBuild
+++ b/audio/abcde/abcde.SlackBuild
@@ -24,10 +24,11 @@
# Modified by the SlackBuilds.org project
# Modified by Andrew Strong
+# Modified by Glenn Becker
PRGNAM=abcde
-VERSION=2.3.99.6
-BUILD=${BUILD:-2}
+VERSION=2.5.4
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
# Automatically determine the architecture we're building on:
@@ -66,15 +67,14 @@ chmod -R u+w,go+r-w,a-s .
# --rworkman
patch -p1 < $CWD/Makefile.diff
-# An amalgamated patch from Ubuntu and Fedora which allows automatic tagging
-# of both m4a/aac and speex files, broken in this version of abcde. Normally
-# this should be submitted upstream rather than placed in a SlackBuild script
-# but unfortunately there is no upstream at the moment :-).
-# For what its worth I have also submitted to the final resting place of abcde:
-# http://code.google.com/p/abcde/issues/detail?id=7
-patch -p1 < $CWD/aac_speex_tagging.diff
+# fix to mailx call: the command was using the -a option which, in Slackware's
+# mailx, means something different than what was intended here (intent here is
+# to set content type to UTF-8. In Slackware the -a is unnecessary. Thanks to
+# Andreas Vogele for this patch. --gbecker
+patch -p1 < $CWD/cddb-tool.diff
+
+# Removed aac/speex patch as this was fixed upstream - G Becker 10.7.12
-make
make install DESTDIR=$PKG
# Let's not overwrite the config file if it already exists
@@ -85,10 +85,8 @@ cp -a COPYING FAQ README TODO changelog examples $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
find $PKG/usr/doc/$PRGNAM-$VERSION -type f -exec chmod 644 {} \;
-( cd $PKG/usr/man || exit
- find . -type f -exec gzip -9 {} \;
- for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
-)
+find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/install
cat $CWD/slack-desc > $PKG/install/slack-desc
diff --git a/audio/abcde/abcde.info b/audio/abcde/abcde.info
index 4f4e329b4f..da26c029a3 100644
--- a/audio/abcde/abcde.info
+++ b/audio/abcde/abcde.info
@@ -1,10 +1,10 @@
PRGNAM="abcde"
-VERSION="2.3.99.6"
-HOMEPAGE="http://freshmeat.net/projects/abcde/"
-DOWNLOAD="http://ftp.de.debian.org/debian/pool/main/a/abcde/abcde_2.3.99.6.orig.tar.gz"
-MD5SUM="ac9be20f3098b0943212168171d33ffa"
+VERSION="2.5.4"
+HOMEPAGE="http://freecode.com/projects/abcde"
+DOWNLOAD="http://ftp.de.debian.org/debian/pool/main/a/abcde/abcde_2.5.4.orig.tar.gz"
+MD5SUM="d761c5a07854ce24748be9aa10100e74"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="cd-discid"
-MAINTAINER="nobody"
-EMAIL="nobody"
+MAINTAINER="Glenn Becker"
+EMAIL="burningc@sdf.org"
diff --git a/audio/abcde/cddb-tool.diff b/audio/abcde/cddb-tool.diff
new file mode 100644
index 0000000000..e3eeacce48
--- /dev/null
+++ b/audio/abcde/cddb-tool.diff
@@ -0,0 +1,11 @@
+--- abcde-2.5.4.orig/cddb-tool 2012-06-20 09:44:13.000000000 -0400
++++ abcde-2.5.4/cddb-tool 2012-12-08 14:59:08.865171479 -0500
+@@ -196,7 +196,7 @@
+ ADDRESS="$2"
+ DISCID=$(grep ^DISCID= "$FILE" | cut -f2 -d= | tr -d \[:cntrl:\])
+ CDDBGENRE=$(grep '^#CATEGORY=' "$FILE" | cut -f2- -d= | tr -d \[:cntrl:\])
+- grep -v "^#CATEGORY=" "$FILE" | iconv -t utf-8 | mail -a "Content-Type: text/plain; charset=utf-8" -s "cddb $CDDBGENRE $DISCID" "$ADDRESS"
++ grep -v "^#CATEGORY=" "$FILE" | iconv -t utf-8 | mailx -s "cddb $CDDBGENRE $DISCID" "$ADDRESS"
+ ;;
+
+ query) # cddb-tool query serverurl proto user host discid...
diff --git a/audio/abcde/slack-desc b/audio/abcde/slack-desc
index f7938558cd..6bf9571fc1 100644
--- a/audio/abcde/slack-desc
+++ b/audio/abcde/slack-desc
@@ -13,7 +13,7 @@ abcde: that grabs tracks from a CD, encodes them to Ogg/Vorbis, MP3, FLAC,
abcde: OGG/Speex, MPP/MP+(Musepack) and/or M4A/AAC format, and tags them,
abcde: all in one go.
abcde:
-abcde: Homepage: http://freshmeat.net/projects/abcde/
+abcde: Homepage: http://freecode.com/projects/abcde
abcde:
abcde:
abcde: