summaryrefslogtreecommitdiffstats
path: root/audio/wmusic-xmms/wmusic-xmms.SlackBuild
diff options
context:
space:
mode:
author B. Watson2018-09-16 20:37:29 +0200
committer David Spencer2018-09-18 00:11:57 +0200
commitb391444293305ce5e6746f8830a69605b12ce6ab (patch)
treeccbbe1af456d2a06d4a064a32e3681c49ea29c4d /audio/wmusic-xmms/wmusic-xmms.SlackBuild
parent28528be906556fdeab87fedee7f3478fbb1250e9 (diff)
downloadslackbuilds-b391444293305ce5e6746f8830a69605b12ce6ab.tar.gz
audio/wmusic-xmms: Added (xmms remote control dockapp).
Signed-off-by: David Spencer <idlemoor@slackbuilds.org>
Diffstat (limited to 'audio/wmusic-xmms/wmusic-xmms.SlackBuild')
-rw-r--r--audio/wmusic-xmms/wmusic-xmms.SlackBuild77
1 files changed, 77 insertions, 0 deletions
diff --git a/audio/wmusic-xmms/wmusic-xmms.SlackBuild b/audio/wmusic-xmms/wmusic-xmms.SlackBuild
new file mode 100644
index 0000000000..6d9093c676
--- /dev/null
+++ b/audio/wmusic-xmms/wmusic-xmms.SlackBuild
@@ -0,0 +1,77 @@
+#!/bin/sh
+
+# Slackware build script for wmusic-xmms
+
+# Written by B. Watson (yalhcru@gmail.com)
+
+# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+
+PRGNAM=wmusic-xmms
+SRCNAM=wmusic
+VERSION=${VERSION:-1.5.0}
+BUILD=${BUILD:-2}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
+
+# ./configure ignores CFLAGS, hence the sed stuff. -include string.h
+# kills a couple of warnings.
+./configure
+sed -i "s,-g -O2,$SLKCFLAGS -include string.h," src/Makefile
+make
+
+# 'make install' ignores DESTDIR, it's only 1 file anyway.
+mkdir -p $PKG/usr/bin
+install -s -m0755 src/wmusic $PKG/usr/bin/$PRGNAM
+
+mkdir -p $PKG/usr/man/man1
+sed -e '/see the Info files/d' -e "s,$SRCNAM,$PRGNAM,g" -e "s,${SRCNAM^^},${PRGNAM^^},g" \
+ debian/$SRCNAM.1 | \
+ gzip -9c > $PKG/usr/man/man1/$PRGNAM.1.gz
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README COPYING $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}