summaryrefslogtreecommitdiffstats
path: root/audio/abcde/abcde.SlackBuild
diff options
context:
space:
mode:
author Jim Capozzoli2010-05-12 17:36:47 +0200
committer David Somero2010-05-12 17:36:47 +0200
commit9200a8fd01a6b398f604f0fc58b8341372e631c3 (patch)
tree15bafde91dd950fe6a938d5c762227177a232b97 /audio/abcde/abcde.SlackBuild
parent1dcdc943a6b4eee2facaf70ae9500159f0dcdc00 (diff)
downloadslackbuilds-9200a8fd01a6b398f604f0fc58b8341372e631c3.tar.gz
audio/abcde: Updated for version 2.3.99.6
Diffstat (limited to 'audio/abcde/abcde.SlackBuild')
-rw-r--r--audio/abcde/abcde.SlackBuild25
1 files changed, 17 insertions, 8 deletions
diff --git a/audio/abcde/abcde.SlackBuild b/audio/abcde/abcde.SlackBuild
index dee9c05230..4d3122b853 100644
--- a/audio/abcde/abcde.SlackBuild
+++ b/audio/abcde/abcde.SlackBuild
@@ -23,25 +23,26 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
# Modified by the SlackBuilds.org project
-
-set -e
+# Modified by Andrew Strong
PRGNAM=abcde
-VERSION=2.3.3
+VERSION=2.3.99.6
ARCH=${ARCH:-i486}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
+
CWD=$(pwd)
TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
+set -e
+
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
rm -rf $TMP/$PRGNAM-$VERSION
-
cd $TMP
-tar -xzvf $CWD/$PRGNAM\_$VERSION.orig.tar.gz
+tar xvf $CWD/$PRGNAM\_$VERSION.orig.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
chmod -R u+w,go+r-w,a-s .
@@ -56,16 +57,24 @@ chmod -R u+w,go+r-w,a-s .
# --rworkman
patch -p1 < $CWD/Makefile.diff
+# An amalgamated patch from Ubuntu and Fedora which allows automatic tagging
+# of both m4a/aac and speex files, broken in this version of abcde. Normally
+# this should be submitted upstream rather than placed in a SlackBuild script
+# but unfortunately there is no upstream at the moment :-).
+# For what its worth I have also submitted to the final resting place of abcde:
+# http://code.google.com/p/abcde/issues/detail?id=7
+patch -p1 < $CWD/aac_speex_tagging.diff
+
make
-make install DESTDIR=$PKG || exit
+make install DESTDIR=$PKG
# Let's not overwrite the config file if it already exists
mv $PKG/etc/$PRGNAM.conf $PKG/etc/$PRGNAM.conf.new
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a COPYING FAQ README TODO changelog examples $PKG/usr/doc/$PRGNAM-$VERSION
-find $PKG/usr/doc/$PRGNAM-$VERSION -type f -exec chmod 644 {} \;
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+find $PKG/usr/doc/$PRGNAM-$VERSION -type f -exec chmod 644 {} \;
( cd $PKG/usr/man || exit
find . -type f -exec gzip -9 {} \;