summaryrefslogtreecommitdiffstats
path: root/accessibility
diff options
context:
space:
mode:
author B. Watson2018-11-14 07:03:33 +0100
committer Willy Sudiarto Raharjo2018-11-17 12:43:01 +0100
commitb8ec23a38406794115934935b65aca59298efa26 (patch)
tree710cd19f3166291317426b8da065d4470bd0c59e /accessibility
parent93cc852f284e6390c7046374fd41a8e5aecc5552 (diff)
downloadslackbuilds-b8ec23a38406794115934935b65aca59298efa26.tar.gz
accessibility/flite: Better texlive support.
Signed-off-by: B. Watson <yalhcru@gmail.com>
Diffstat (limited to 'accessibility')
-rw-r--r--accessibility/flite/README16
-rw-r--r--accessibility/flite/flite.117
-rw-r--r--accessibility/flite/flite.SlackBuild52
-rw-r--r--accessibility/flite/flite.rst15
-rw-r--r--accessibility/flite/slack-desc2
5 files changed, 71 insertions, 31 deletions
diff --git a/accessibility/flite/README b/accessibility/flite/README
index 8e44fa95c9..9115b3111a 100644
--- a/accessibility/flite/README
+++ b/accessibility/flite/README
@@ -1,7 +1,7 @@
flite (speech synthesis engine)
Flite is a small, fast run-time synthesis engine, designed for
-embedded systems and servers. Flite was developed by Alan W Black and
+embedded systems and servers. Flite was developed by Alan W. Black and
Kevin Lenzo at Carnegie Mellon University, in Pittsburgh.
Starting with version 2.0.0, flite is able to load extra voice files
@@ -11,7 +11,13 @@ http://festvox.org/flite/packed/flite-2.0/voices/ and place them
in the same directory as the SlackBuild. They will be installed in
/usr/share/flite/, and can be used with the flite's -voice option.
-To skip building the HTML and GNU Info API documentation, set DOCS=no
-in the environment. The man page will still be included. This option is
-mainly provided in case a future version of texi2html has issues with
-the texi2html options used by flite's doc/Makefile.
+The flite API documentation is available as a GNU info document,
+via "info flite". The same docs are available as HTML in
+/usr/doc/flite-$VERSION/html if:
+
+- You have Slackware's tetex package installed, or...
+- You have texlive and texi2html installed from SBo.
+
+The API docs are only needed for developers who intend to write code that
+uses flite as a library. If you have build errors that mention texi2html,
+try 'export HTML=no' in the script's environment.
diff --git a/accessibility/flite/flite.1 b/accessibility/flite/flite.1
index add46b6b72..b6c628f4e1 100644
--- a/accessibility/flite/flite.1
+++ b/accessibility/flite/flite.1
@@ -1,6 +1,6 @@
.\" Man page generated from reStructuredText.
.
-.TH FLITE 1 "2015-05-09" "2.0.0" "SlackBuilds.org"
+.TH FLITE 1 "2018-11-14" "2.1.0" "SlackBuilds.org"
.SH NAME
flite \- a small simple speech synthesizer
.
@@ -48,14 +48,19 @@ text string and spoken, and not as a file name. If \fItext/file\fP
is omitted or \fB\-\fP, text will be read from standard input.
.sp
If \fIwavefile\fP is unspecified or \fBplay\fP, the result is
-played on the current systems audio device. If \fIwavefile\fP
+played on the default ALSA audio device. If \fIwavefile\fP
is \fBnone\fP, the waveform is discarded (good for benchmarking).
.sp
Any other options must appear before \fItext/file\fP and/or \fIwavefile\fP\&.
.sp
-The full documentation for \fBflite\fP can be read as a GNU
-info file with the command \fBinfo flite\fP, or as HTML in
-\fI/usr/doc/flite\-|version|/html/index.html\fP\&.
+The full documentation for \fBflite\fP can be read as a GNU info
+file with the command \fBinfo flite\fP, or (possibly) as HTML in:
+.sp
+/usr/doc/flite\-2.1.0/html/index.html
+.sp
+If the HTML documentation isn\(aqt installed locally, it can also be found at:
+.sp
+\fI\%http://festvox.org/flite/doc/index.html\fP
.SH OPTIONS
.\" notice the **-opt** *param* stuff? rst's option recognition
.
@@ -156,7 +161,7 @@ The flite homepage: \fI\%http://www.festvox.org/flite/\fP
.SH AUTHOR
Alan W. Black, Kevin Lorenzo
.SH COPYRIGHT
-See /usr/doc/flite-2.0.0/COPYING for full copyright information on flite.
+See /usr/doc/flite-2.1.0/COPYING for full copyright information on flite.
This man page written for the SlackBuilds.org project
by B. Watson, and is licensed under the WTFPL.
.\" Generated by docutils manpage writer.
diff --git a/accessibility/flite/flite.SlackBuild b/accessibility/flite/flite.SlackBuild
index 64c3556e58..481a8da53f 100644
--- a/accessibility/flite/flite.SlackBuild
+++ b/accessibility/flite/flite.SlackBuild
@@ -3,6 +3,17 @@
# Slackware build script for flite
# Originally written by Martin Lefebvre (email removed)
# Now maintained by B. Watson (yalhcru@gmail.com), original author is MIA.
+# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+
+# 20181114 bkw:
+# - BUILD=2
+# - add WTFPL to script
+# - always build the .info API docs
+# - get rid of DOCS env variable
+# - only build HTML docs if texi2html is available
+# - update README to document the above
+# - minor updates to man page and slack-desc
+# - add HTML=no to skip building HTML docs
# 20180612 bkw: update for 2.1 (or is it 2.1.0?)
@@ -33,7 +44,7 @@
PRGNAM=flite
VERSION=${VERSION:-2.1}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -72,11 +83,8 @@ rm -rf $PRGNAM-$VERSION-release
tar xvf $CWD/$PRGNAM-$VERSION-release.tar.bz2
cd $PRGNAM-$VERSION-release
chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
+ \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
# fix LDLAGS to allow external programs to find libflite.so
patch -p1 < $CWD/flite-ldflags-fix.patch
@@ -90,7 +98,6 @@ CXXFLAGS="$SLKCFLAGS" \
--localstatedir=/var \
--with-audio=alsa \
--enable-shared \
- --disable-static \
--build=$ARCH-slackware-linux
# Fix builds with SBo standalone texi2html. The -number option works
@@ -116,10 +123,25 @@ for file in $CWD/*.flitevox; do
EXTRA=yes
done
+# -current's tex is texlive, which lacks texi2html. Also lots of
+# users prefer to run texlive on 14.2, which has the same problem.
+# So only try to build the HTML docs if (a) the user forces with
+# HTML=yes, or (b) if HTML=auto (the default) and texi2html is
+# actually found on the $PATH.
+HTML="${HTML:-auto}"
+
+if [ "$HTML" = "auto" ]; then
+ if which texi2html 2>/dev/null; then
+ HTML="yes"
+ else
+ HTML="no"
+ fi
+fi
+
# build the docs. NB don't replace subshells with "cd dir" and
# "cd -", as they don't nest.
HTMLDOC=""
-if [ "${DOCS:-yes}" = "yes" ]; then
+if [ "$HTML" = "yes" ]; then
HTMLDOC="doc/html"
( cd doc
# build the HTML docs.
@@ -137,14 +159,16 @@ if [ "${DOCS:-yes}" = "yes" ]; then
-e 's,\.tar\.gz,.tar.bz2,g' \
${PRGNAM}_toc.html
)
-
- # build the GNU info docs
- makeinfo $PRGNAM.texi
- mkdir -p $PKG/usr/info
- gzip -9c < $PRGNAM.info > $PKG/usr/info/$PRGNAM.info.gz
)
fi
+# 20181114 bkw: always build the GNU info docs.
+( cd doc
+ makeinfo $PRGNAM.texi
+ mkdir -p $PKG/usr/info
+ gzip -9c < $PRGNAM.info > $PKG/usr/info/$PRGNAM.info.gz
+)
+
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a ACKNOWLEDGEMENTS COPYING README* $HTMLDOC doc/*.txt doc/alice \
$PKG/usr/doc/$PRGNAM-$VERSION
@@ -165,7 +189,7 @@ else
fi
# doinst.sh needed because we append to /usr/info/dir.
-[ "${DOCS:-yes}" = "yes" ] && cat $CWD/doinst.sh > $PKG/install/doinst.sh
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/accessibility/flite/flite.rst b/accessibility/flite/flite.rst
index d546382956..1141f65a24 100644
--- a/accessibility/flite/flite.rst
+++ b/accessibility/flite/flite.rst
@@ -2,7 +2,7 @@
.. rst2man.py flite.rst > flite.1
.. rst2man.py comes from the SBo development/docutils package.
-.. |version| replace:: 2.0.0
+.. |version| replace:: 2.1.0
.. |date| date::
======
@@ -37,14 +37,19 @@ text string and spoken, and not as a file name. If *text/file*
is omitted or **-**, text will be read from standard input.
If *wavefile* is unspecified or **play**, the result is
-played on the current systems audio device. If *wavefile*
+played on the default ALSA audio device. If *wavefile*
is **none**, the waveform is discarded (good for benchmarking).
Any other options must appear before *text/file* and/or *wavefile*.
-The full documentation for **flite** can be read as a GNU
-info file with the command **info flite**, or as HTML in
-*/usr/doc/flite-|version|/html/index.html*.
+The full documentation for **flite** can be read as a GNU info
+file with the command **info flite**, or (possibly) as HTML in:
+
+/usr/doc/flite-|version|/html/index.html
+
+If the HTML documentation isn't installed locally, it can also be found at:
+
+http://festvox.org/flite/doc/index.html
OPTIONS
=======
diff --git a/accessibility/flite/slack-desc b/accessibility/flite/slack-desc
index 45469def60..ece17be00d 100644
--- a/accessibility/flite/slack-desc
+++ b/accessibility/flite/slack-desc
@@ -9,7 +9,7 @@
flite: flite (speech synthesis engine)
flite:
flite: Flite is a small and fast run-time synthesis engine designed for
-flite: embedded systems and servers. Flite was developed by Alan W Black
+flite: embedded systems and servers. Flite was developed by Alan W. Black
flite: and Kevin Lenzo at Carnegie Mellon University, in Pittsburgh.
flite:
flite: