summaryrefslogtreecommitdiffstats
path: root/academic
diff options
context:
space:
mode:
author Petar Petrov2013-12-14 15:36:42 +0100
committer Erik Hanson2013-12-14 17:53:07 +0100
commitaf993d7297b601a7d1faa6e731d3e07aa2bd5726 (patch)
tree14eea3066ddf63f23f7c65eb4a569dded3c74bb6 /academic
parentc732454ecf95097afba466a66d2cef0e14730d36 (diff)
downloadslackbuilds-af993d7297b601a7d1faa6e731d3e07aa2bd5726.tar.gz
academic/cistrome-MACS: Added (Model-based Analysis of ChIP-Seq).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'academic')
-rw-r--r--academic/cistrome-MACS/README16
-rw-r--r--academic/cistrome-MACS/References2
-rw-r--r--academic/cistrome-MACS/cistrome-MACS.SlackBuild95
-rw-r--r--academic/cistrome-MACS/cistrome-MACS.info10
-rw-r--r--academic/cistrome-MACS/slack-desc19
5 files changed, 142 insertions, 0 deletions
diff --git a/academic/cistrome-MACS/README b/academic/cistrome-MACS/README
new file mode 100644
index 0000000000..d039cfacfd
--- /dev/null
+++ b/academic/cistrome-MACS/README
@@ -0,0 +1,16 @@
+MACS: Model-based Analysis of ChIP-Seq
+
+Next generation parallel sequencing technologies made chromatin
+immunoprecipitation followed by sequencing (ChIP-Seq) a popular
+strategy to study genome-wide protein-DNA interactions, while creating
+challenges for analysis algorithms. We present Model-based Analysis of
+ChIP-Seq (MACS) on short reads sequencers such as Genome Analyzer
+(Illumina / Solexa). MACS empirically models the length of the
+sequenced ChIP fragments, which tends to be shorter than sonication or
+library construction size estimates, and uses it to improve the
+spatial resolution of predicted binding sites. MACS also uses a
+dynamic Poisson distribution to effectively capture local biases in
+the genome sequence, allowing for more sensitive and robust
+prediction. MACS compares favorably to existing ChIP-Seq peak-finding
+algorithms, is publicly available open source, and can be used for
+ChIP-Seq with or without control samples.
diff --git a/academic/cistrome-MACS/References b/academic/cistrome-MACS/References
new file mode 100644
index 0000000000..4cbc4be778
--- /dev/null
+++ b/academic/cistrome-MACS/References
@@ -0,0 +1,2 @@
+Zhang et al. Model-based Analysis of ChIP-Seq (MACS).
+Genome Biol (2008) vol. 9 (9) pp. R137
diff --git a/academic/cistrome-MACS/cistrome-MACS.SlackBuild b/academic/cistrome-MACS/cistrome-MACS.SlackBuild
new file mode 100644
index 0000000000..f22c48b227
--- /dev/null
+++ b/academic/cistrome-MACS/cistrome-MACS.SlackBuild
@@ -0,0 +1,95 @@
+#!/bin/sh
+
+# Slackware build script for cistrome-MACS
+
+# Copyright 2013 Petar Petrov, petar.petrov@student.oulu.fi
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=cistrome-MACS
+VERSION=${VERSION:-1.4.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRCNAM=MACS
+SRCVER=1.4.2-1
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$SRCVER.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ ChangeLog COPYING INSTALL NEW_IN_MACS14 README PKG-INFO\
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+cat $CWD/References > $PKG/usr/doc/$PRGNAM-$VERSION/References
+
+# Ugene expects this to have the py suffix
+cd $PKG/usr/bin
+ln -s macs14 macs14.py
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/academic/cistrome-MACS/cistrome-MACS.info b/academic/cistrome-MACS/cistrome-MACS.info
new file mode 100644
index 0000000000..6b12d67dd3
--- /dev/null
+++ b/academic/cistrome-MACS/cistrome-MACS.info
@@ -0,0 +1,10 @@
+PRGNAM="cistrome-MACS"
+VERSION="1.4.2"
+HOMEPAGE="http://liulab.dfci.harvard.edu/MACS/"
+DOWNLOAD="https://github.com/downloads/taoliu/MACS/MACS-1.4.2-1.tar.gz"
+MD5SUM="950dab09fe1335c8bbb34a896c21e3e2"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Petar Petrov"
+EMAIL="petar.petrov@student.oulu.fi"
diff --git a/academic/cistrome-MACS/slack-desc b/academic/cistrome-MACS/slack-desc
new file mode 100644
index 0000000000..82b067d296
--- /dev/null
+++ b/academic/cistrome-MACS/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+cistrome-MACS: cistrome-MACS (MACS: Model-based Analysis of ChIP-Seq)
+cistrome-MACS:
+cistrome-MACS: Next generation parallel sequencing technologies made chromatin
+cistrome-MACS: immunoprecipitation followed by sequencing (ChIP-Seq) a popular
+cistrome-MACS: strategy to study genome-wide protein-DNA interactions, while
+cistrome-MACS: creating challenges for analysis algorithms. We present Model-
+cistrome-MACS: based Analysis of ChIP-Seq (MACS) on short reads sequencers such
+cistrome-MACS: as Genome Analyzer (Illumina / Solexa).
+cistrome-MACS:
+cistrome-MACS: Home: http://liulab.dfci.harvard.edu/MACS/
+cistrome-MACS: References: /usr/doc/cistrome-MACS-1.4.2/references