summaryrefslogtreecommitdiffstats
path: root/academic
diff options
context:
space:
mode:
author Benjamin Trigona-Harany2014-02-02 00:33:23 +0100
committer Robby Workman2014-02-02 09:09:46 +0100
commit9c85432c040572ce76b0b1a51771058b38331da0 (patch)
tree7aa4a1627d758c453295420abd31f31ce24d367b /academic
parent26d06b1544168e3d8f7a3d4b97c9e7045aefe07f (diff)
downloadslackbuilds-9c85432c040572ce76b0b1a51771058b38331da0.tar.gz
gis/OWSLib: Moved from Academic category.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'academic')
-rw-r--r--academic/OWSLib/OWSLib.SlackBuild85
-rw-r--r--academic/OWSLib/OWSLib.info10
-rw-r--r--academic/OWSLib/README3
-rw-r--r--academic/OWSLib/slack-desc19
4 files changed, 0 insertions, 117 deletions
diff --git a/academic/OWSLib/OWSLib.SlackBuild b/academic/OWSLib/OWSLib.SlackBuild
deleted file mode 100644
index d194771f11..0000000000
--- a/academic/OWSLib/OWSLib.SlackBuild
+++ /dev/null
@@ -1,85 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for OWSLib
-
-# Copyright 2013-2014 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=OWSLib
-VERSION=${VERSION:-0.8.3}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a PKG-INFO CHANGES.txt CREDITS.txt HISTORY.txt LICENSE.txt README.txt $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/academic/OWSLib/OWSLib.info b/academic/OWSLib/OWSLib.info
deleted file mode 100644
index 4445e322b5..0000000000
--- a/academic/OWSLib/OWSLib.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="OWSLib"
-VERSION="0.8.3"
-HOMEPAGE="http://pypi.python.org/pypi/OWSLib/"
-DOWNLOAD="https://pypi.python.org/packages/source/O/OWSLib/OWSLib-0.8.3.tar.gz"
-MD5SUM="7e0924b8030d8039f41ae30982268296"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="python-dateutil pysetuptools pytz lxml six"
-MAINTAINER="Benjamin Trigona-Harany"
-EMAIL="slackbuilds@jaxartes.net"
diff --git a/academic/OWSLib/README b/academic/OWSLib/README
deleted file mode 100644
index 605b430f3a..0000000000
--- a/academic/OWSLib/README
+++ /dev/null
@@ -1,3 +0,0 @@
-OWSLib is a Python package for client programming with Open Geospatial
-Consortium (OGC) web service (hence OWS) interface standards, and their
-related content models.
diff --git a/academic/OWSLib/slack-desc b/academic/OWSLib/slack-desc
deleted file mode 100644
index 6dd7f7e8c6..0000000000
--- a/academic/OWSLib/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-OWSLib: OWSLib (OGC Web Service utility library)
-OWSLib:
-OWSLib: OWSLib is a Python package for client programming with Open Geospatial
-OWSLib: Consortium (OGC) web service (hence OWS) interface standards, and
-OWSLib: their related content models.
-OWSLib:
-OWSLib: Homepage: https://pypi.python.org/pypi/OWSLib/
-OWSLib:
-OWSLib:
-OWSLib:
-OWSLib: