summaryrefslogtreecommitdiffstats
path: root/academic
diff options
context:
space:
mode:
author William PC2022-12-03 05:26:39 +0100
committer Willy Sudiarto Raharjo2022-12-03 05:26:39 +0100
commitb54b49bfd0490042f1d0aa56228d7475e9a5a1b9 (patch)
treec2620a724b12b3789363cbb19763b5ee12a5b903 /academic
parentf8bce62175e68d57f96f9d2f7940182de7629728 (diff)
downloadslackbuilds-b54b49bfd0490042f1d0aa56228d7475e9a5a1b9.tar.gz
academic/DRAMSys: Added (DRAM subsystem).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'academic')
-rw-r--r--academic/DRAMSys/DRAMSys.SlackBuild143
-rw-r--r--academic/DRAMSys/DRAMSys.info10
-rw-r--r--academic/DRAMSys/README13
-rw-r--r--academic/DRAMSys/slack-desc19
4 files changed, 185 insertions, 0 deletions
diff --git a/academic/DRAMSys/DRAMSys.SlackBuild b/academic/DRAMSys/DRAMSys.SlackBuild
new file mode 100644
index 0000000000..abc780aa8d
--- /dev/null
+++ b/academic/DRAMSys/DRAMSys.SlackBuild
@@ -0,0 +1,143 @@
+#!/bin/bash
+
+# Slackware build script for DRAMSys
+
+# Copyright 2022 William PC - Seattle, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+cd $(dirname $0) ; CWD=$(pwd)
+
+PRGNAM=DRAMSys
+VERSION=${VERSION:-20220830}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+PKGTYPE=${PKGTYPE:-tgz}
+
+COMMIT=09f6dcbb91351e6ee7cadfc7bc8b29d97625db8f
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i586 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
+# the name of the created package would be, and then exit. This information
+# could be useful to other scripts.
+if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
+ echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
+ exit 0
+fi
+
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$COMMIT
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$COMMIT
+
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+
+# unpack requirements
+tar xvf $CWD/nlohmann-json-efcc826.tar.gz --strip-component 1 -C DRAMSys/library/src/common/third_party/nlohmann
+tar xvf $CWD/sqlite-amalgamation-9be05e1.tar.gz --strip-component 1 -C DRAMSys/library/src/common/third_party/sqlite-amalgamation
+
+if [ "${POWER:-no}" == "yes" ]; then
+ # fix for using system installed DRAMPower
+ sed -i '48,50s/^/#/' DRAMSys/library/CMakeLists.txt
+ sed -i '247s#PRIVATE.*#PRIVATE /usr/include/libdrampower#' DRAMSys/library/CMakeLists.txt
+ sed -i '263s/^/#/' DRAMSys/library/CMakeLists.txt
+ sed -i '266s/DRAMPower/drampower/' DRAMSys/library/CMakeLists.txt
+ OPT="-DDRAMSYS_WITH_DRAMPOWER:BOOL=ON"
+else
+ OPT="-DDRAMSYS_WITH_DRAMPOWER:BOOL=OFF"
+fi
+
+mkdir -p build
+cd build
+ SYSTEMC_HOME=/usr \
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DBUILD_SHARED_LIBS=ON \
+ -DCMAKE_CXX_STANDARD=17 \
+ $OPT \
+ -DCMAKE_BUILD_TYPE=Release ../DRAMSys
+ make
+# make install/strip DESTDIR=$PKG
+cd ..
+
+# installing
+install -d $PKG/usr/bin
+install -m 0755 build/simulator/DRAMSys $PKG/usr/bin
+install -d $PKG/usr/lib${LIBDIRSUFFIX}
+install -m 0644 build/library/libDRAMSysLibrary.so $PKG/usr/lib${LIBDIRSUFFIX}
+
+mkdir -p $PKG/usr/share/DRAMSys/
+cp -av DRAMSys/library/resources/* $PKG/usr/share/$PRGNAM
+
+
+# Don't ship .la files:
+rm -f $PKG/{,usr/}lib${LIBDIRSUFFIX}/*.la
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+find $PKG -depth -type d -empty -delete || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE.txt README.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
diff --git a/academic/DRAMSys/DRAMSys.info b/academic/DRAMSys/DRAMSys.info
new file mode 100644
index 0000000000..f11822c845
--- /dev/null
+++ b/academic/DRAMSys/DRAMSys.info
@@ -0,0 +1,10 @@
+PRGNAM="DRAMSys"
+VERSION="20220830"
+HOMEPAGE="https://github.com/tukl-msd/DRAMSys"
+DOWNLOAD="https://github.com/tukl-msd/DRAMSys/archive/09f6dcbb91351e6ee7cadfc7bc8b29d97625db8f/DRAMSys-20220830.tar.gz https://github.com/nlohmann/json/archive/efcc826ecb9b55893397f749e5514316ba8629bb/nlohmann-json-efcc826.tar.gz https://github.com/azadkuh/sqlite-amalgamation/archive/9be05e13408dd8cf8dafe8f11b1700a28194e07e/sqlite-amalgamation-9be05e1.tar.gz"
+MD5SUM="812ef08562d99038669c5eb881e85c63 14999edd13ec7697cce179e344615c2a d557d04aa385876917d7d63977b94931"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="SystemC"
+MAINTAINER="William PC"
+EMAIL="w_calandrini[at]hotmail[dot]com"
diff --git a/academic/DRAMSys/README b/academic/DRAMSys/README
new file mode 100644
index 0000000000..c294454387
--- /dev/null
+++ b/academic/DRAMSys/README
@@ -0,0 +1,13 @@
+ DRAMSys4.0 is a flexible DRAM subsystem design space exploration
+framework based on SystemC TLM-2.0. It was developed at the
+Microelectronic Systems Design Research Group and Fraunhofer IESE.
+
+
+ If you want to enable power simulation set the environment variable
+POWER=yes, this requires the package DRAMPower.
+ If you want to run thermal simulations install 3D-ICE with SystemC
+wrapper enabled.
+
+# invocation example
+# DRAMSys /usr/share/DRAMSys/simulations/ddr3-example.json \
+ /usr/share/DRAMSys
diff --git a/academic/DRAMSys/slack-desc b/academic/DRAMSys/slack-desc
new file mode 100644
index 0000000000..b1fe79727d
--- /dev/null
+++ b/academic/DRAMSys/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+DRAMSys: DRAMSys (DRAM subsystem design space exploration framework)
+DRAMSys:
+DRAMSys:
+DRAMSys:
+DRAMSys: DRAMSys4.0 is a flexible DRAM subsystem design space exploration
+DRAMSys: framework based on SystemC TLM-2.0. It was developed at the
+DRAMSys: Microelectronic Systems Design Research Group and Fraunhofer IESE.
+DRAMSys:
+DRAMSys:
+DRAMSys:
+DRAMSys: