summaryrefslogtreecommitdiffstats
path: root/academic
diff options
context:
space:
mode:
author Matteo Bernardini2021-03-27 10:25:10 +0100
committer Matteo Bernardini2021-03-27 10:25:10 +0100
commit2fba1c878b57d3afa631b9369518be5d21221c09 (patch)
treedce412a05dfeb7fbb53d24c934a732c3b522ad0f /academic
parentf4c325577c3399f98410adb164155c38bb8ed86a (diff)
downloadslackbuilds-2fba1c878b57d3afa631b9369518be5d21221c09.tar.gz
20210327.1 global branch merge.current-20210327.1
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'academic')
-rw-r--r--academic/Gridcoin-Research/Gridcoin-Research.SlackBuild6
-rw-r--r--academic/Gridcoin-Research/boost-1.73.patch54
-rw-r--r--academic/antiprism/antiprism.SlackBuild2
-rw-r--r--academic/artha/artha.SlackBuild8
-rw-r--r--academic/artha/artha.info6
-rw-r--r--academic/geda-gaf/geda-gaf.info2
-rw-r--r--academic/gelemental/gcc.patch12
-rw-r--r--academic/gelemental/gelemental.SlackBuild3
-rw-r--r--academic/genius/README2
-rw-r--r--academic/genometools/genometools.SlackBuild2
-rw-r--r--academic/kile/README4
-rw-r--r--academic/kile/doinst.sh13
-rw-r--r--academic/kile/kile.SlackBuild96
-rw-r--r--academic/kile/kile.info10
-rw-r--r--academic/kile/slack-desc19
-rw-r--r--academic/libqalculate/README4
-rw-r--r--academic/libqalculate/libqalculate.SlackBuild102
-rw-r--r--academic/libqalculate/libqalculate.info10
-rw-r--r--academic/libqalculate/slack-desc19
-rw-r--r--academic/primer3/primer3.SlackBuild4
-rw-r--r--academic/pulseview/pulseview.SlackBuild4
-rw-r--r--academic/pulseview/pulseview.info6
-rw-r--r--academic/root/root.SlackBuild9
-rw-r--r--academic/root/root.info8
-rw-r--r--academic/sage/sage.SlackBuild2
-rw-r--r--academic/sage/sage.info6
-rw-r--r--academic/scipy3/scipy3.SlackBuild2
-rw-r--r--academic/scipy3/scipy3.info6
-rw-r--r--academic/tophat/make_pair.patch24
-rw-r--r--academic/tophat/tophat.SlackBuild3
-rw-r--r--academic/ugene/ugene-1.22.0-dont_hardcode_includes.patch24
-rw-r--r--academic/ugene/ugene.SlackBuild3
-rw-r--r--academic/veusz/veusz.SlackBuild3
33 files changed, 163 insertions, 315 deletions
diff --git a/academic/Gridcoin-Research/Gridcoin-Research.SlackBuild b/academic/Gridcoin-Research/Gridcoin-Research.SlackBuild
index 73603623be..354a1e7e40 100644
--- a/academic/Gridcoin-Research/Gridcoin-Research.SlackBuild
+++ b/academic/Gridcoin-Research/Gridcoin-Research.SlackBuild
@@ -70,6 +70,12 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# For boost >= 1.73.0
+patch -p1 < $CWD/boost-1.73.patch
+
+# For qt-5.15.x, thanks to kingbeowulf!
+sed -i '/^#include <QPainter>$/a #include <QPainterPath>' src/qt/trafficgraphwidget.cpp
+
if [ "${QRENC:-no}" = "yes" ]; then
useqr="--with-qrencode"
else
diff --git a/academic/Gridcoin-Research/boost-1.73.patch b/academic/Gridcoin-Research/boost-1.73.patch
new file mode 100644
index 0000000000..d47fe78a6e
--- /dev/null
+++ b/academic/Gridcoin-Research/boost-1.73.patch
@@ -0,0 +1,54 @@
+diff -Naur Gridcoin-Research-4.0.6.0.orig/src/qt/clientmodel.cpp Gridcoin-Research-4.0.6.0/src/qt/clientmodel.cpp
+--- Gridcoin-Research-4.0.6.0.orig/src/qt/clientmodel.cpp 2019-10-22 20:36:49.000000000 +0200
++++ Gridcoin-Research-4.0.6.0/src/qt/clientmodel.cpp 2020-05-12 08:45:16.926818550 +0200
+@@ -270,9 +270,9 @@
+ // Connect signals to client
+ uiInterface.NotifyBlocksChanged.connect(boost::bind(NotifyBlocksChanged, this));
+ uiInterface.BannedListChanged.connect(boost::bind(BannedListChanged, this));
+- uiInterface.NotifyNumConnectionsChanged.connect(boost::bind(NotifyNumConnectionsChanged, this, _1));
+- uiInterface.NotifyAlertChanged.connect(boost::bind(NotifyAlertChanged, this, _1, _2));
+- uiInterface.NotifyScraperEvent.connect(boost::bind(NotifyScraperEvent, this, _1, _2, _3));
++ uiInterface.NotifyNumConnectionsChanged.connect(boost::bind(NotifyNumConnectionsChanged, this, boost::placeholders::_1));
++ uiInterface.NotifyAlertChanged.connect(boost::bind(NotifyAlertChanged, this, boost::placeholders::_1, boost::placeholders::_2));
++ uiInterface.NotifyScraperEvent.connect(boost::bind(NotifyScraperEvent, this, boost::placeholders::_1, boost::placeholders::_2, boost::placeholders::_3));
+ }
+
+ void ClientModel::unsubscribeFromCoreSignals()
+@@ -280,7 +280,7 @@
+ // Disconnect signals from client
+ uiInterface.NotifyBlocksChanged.disconnect(boost::bind(NotifyBlocksChanged, this));
+ uiInterface.BannedListChanged.disconnect(boost::bind(BannedListChanged, this));
+- uiInterface.NotifyNumConnectionsChanged.disconnect(boost::bind(NotifyNumConnectionsChanged, this, _1));
+- uiInterface.NotifyAlertChanged.disconnect(boost::bind(NotifyAlertChanged, this, _1, _2));
+- uiInterface.NotifyScraperEvent.disconnect(boost::bind(NotifyScraperEvent, this, _1, _2, _3));
++ uiInterface.NotifyNumConnectionsChanged.disconnect(boost::bind(NotifyNumConnectionsChanged, this, boost::placeholders::_1));
++ uiInterface.NotifyAlertChanged.disconnect(boost::bind(NotifyAlertChanged, this, boost::placeholders::_1, boost::placeholders::_2));
++ uiInterface.NotifyScraperEvent.disconnect(boost::bind(NotifyScraperEvent, this, boost::placeholders::_1, boost::placeholders::_2, boost::placeholders::_3));
+ }
+diff -Naur Gridcoin-Research-4.0.6.0.orig/src/qt/walletmodel.cpp Gridcoin-Research-4.0.6.0/src/qt/walletmodel.cpp
+--- Gridcoin-Research-4.0.6.0.orig/src/qt/walletmodel.cpp 2019-10-22 20:36:49.000000000 +0200
++++ Gridcoin-Research-4.0.6.0/src/qt/walletmodel.cpp 2020-05-12 08:47:46.494818550 +0200
+@@ -369,17 +369,17 @@
+ void WalletModel::subscribeToCoreSignals()
+ {
+ // Connect signals to wallet
+- wallet->NotifyStatusChanged.connect(boost::bind(&NotifyKeyStoreStatusChanged, this, _1));
+- wallet->NotifyAddressBookChanged.connect(boost::bind(NotifyAddressBookChanged, this, _1, _2, _3, _4, _5));
+- wallet->NotifyTransactionChanged.connect(boost::bind(NotifyTransactionChanged, this, _1, _2, _3));
++ wallet->NotifyStatusChanged.connect(boost::bind(&NotifyKeyStoreStatusChanged, this, boost::placeholders::_1));
++ wallet->NotifyAddressBookChanged.connect(boost::bind(NotifyAddressBookChanged, this, boost::placeholders::_1, boost::placeholders::_2, boost::placeholders::_3, boost::placeholders::_4, boost::placeholders::_5));
++ wallet->NotifyTransactionChanged.connect(boost::bind(NotifyTransactionChanged, this, boost::placeholders::_1, boost::placeholders::_2, boost::placeholders::_3));
+ }
+
+ void WalletModel::unsubscribeFromCoreSignals()
+ {
+ // Disconnect signals from wallet
+- wallet->NotifyStatusChanged.disconnect(boost::bind(&NotifyKeyStoreStatusChanged, this, _1));
+- wallet->NotifyAddressBookChanged.disconnect(boost::bind(NotifyAddressBookChanged, this, _1, _2, _3, _4, _5));
+- wallet->NotifyTransactionChanged.disconnect(boost::bind(NotifyTransactionChanged, this, _1, _2, _3));
++ wallet->NotifyStatusChanged.disconnect(boost::bind(&NotifyKeyStoreStatusChanged, this, boost::placeholders::_1));
++ wallet->NotifyAddressBookChanged.disconnect(boost::bind(NotifyAddressBookChanged, this, boost::placeholders::_1, boost::placeholders::_2, boost::placeholders::_3, boost::placeholders::_4, boost::placeholders::_5));
++ wallet->NotifyTransactionChanged.disconnect(boost::bind(NotifyTransactionChanged, this, boost::placeholders::_1, boost::placeholders::_2, boost::placeholders::_3));
+ }
+
+ // WalletModel::UnlockContext implementation
diff --git a/academic/antiprism/antiprism.SlackBuild b/academic/antiprism/antiprism.SlackBuild
index 271184a166..f3c6c291e6 100644
--- a/academic/antiprism/antiprism.SlackBuild
+++ b/academic/antiprism/antiprism.SlackBuild
@@ -55,7 +55,7 @@ find -L . \
sed "/^docdir/s|= .*|= @docdir@|" -i Makefile.in
CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS -fpermissive" \
./configure \
--prefix=/usr \
--libdir=/usr/lib$LIBDIRSUFFIX \
diff --git a/academic/artha/artha.SlackBuild b/academic/artha/artha.SlackBuild
index 53eb0478d2..dbb2a3bf9c 100644
--- a/academic/artha/artha.SlackBuild
+++ b/academic/artha/artha.SlackBuild
@@ -5,13 +5,13 @@
# Written by Mikhail Zotov <mikhail dot ru at gmail dot com>
PRGNAM=artha
-VERSION=${VERSION:-1.0.3}
+VERSION=${VERSION:-1.0.5}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
- i?86) ARCH=i486 ;;
+ i?86) ARCH=i586 ;;
arm*) ARCH=arm ;;
*) ARCH=$( uname -m ) ;;
esac
@@ -22,8 +22,8 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+if [ "$ARCH" = "i586" ]; then
+ SLKCFLAGS="-O2 -march=i586 -mtune=i686"
LIBDIRSUFFIX=""
elif [ "$ARCH" = "i686" ]; then
SLKCFLAGS="-O2 -march=i686 -mtune=i686"
diff --git a/academic/artha/artha.info b/academic/artha/artha.info
index 1512888a8b..40037f5817 100644
--- a/academic/artha/artha.info
+++ b/academic/artha/artha.info
@@ -1,8 +1,8 @@
PRGNAM="artha"
-VERSION="1.0.3"
+VERSION="1.0.5"
HOMEPAGE="http://artha.sourceforge.net/"
-DOWNLOAD="http://ponce.cc/slackware/sources/repo/artha-1.0.3.tar.bz2"
-MD5SUM="9bc69f5666a1f494e21a0a0add9ebb16"
+DOWNLOAD="https://downloads.sourceforge.net/artha/artha-1.0.5.tar.bz2"
+MD5SUM="a916a7a943ac676a60f03cc839b04f37"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="WordNet"
diff --git a/academic/geda-gaf/geda-gaf.info b/academic/geda-gaf/geda-gaf.info
index 3664fa7fb5..1362c53982 100644
--- a/academic/geda-gaf/geda-gaf.info
+++ b/academic/geda-gaf/geda-gaf.info
@@ -5,6 +5,6 @@ DOWNLOAD="http://ftp.geda-project.org/geda-gaf/stable/v1.8/1.8.2/geda-gaf-1.8.2.
MD5SUM="fa8a807615decf47027e22a217dd0ded"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="guile1.8"
MAINTAINER="Stephen Van Berg"
EMAIL="stephen_van_berg@earlicker.com"
diff --git a/academic/gelemental/gcc.patch b/academic/gelemental/gcc.patch
new file mode 100644
index 0000000000..eeb16293d9
--- /dev/null
+++ b/academic/gelemental/gcc.patch
@@ -0,0 +1,12 @@
+diff -Naur gelemental-1.2.0.orig/src/dialogs.cc gelemental-1.2.0/src/dialogs.cc
+--- gelemental-1.2.0.orig/src/dialogs.cc 2007-09-25 06:49:33.000000000 +0200
++++ gelemental-1.2.0/src/dialogs.cc 2017-07-27 21:45:34.356776770 +0200
+@@ -247,7 +247,7 @@
+ const Gtk::TreePath& tpath, bool)
+ {
+ Gtk::TreeIter iter = store->get_iter (tpath);
+- return iter ? iter->get_value (cols.property) : false;
++ return iter ? static_cast<bool>(iter->get_value (cols.property)) : false;
+ }
+
+
diff --git a/academic/gelemental/gelemental.SlackBuild b/academic/gelemental/gelemental.SlackBuild
index e4b332e18a..d2ae765eb6 100644
--- a/academic/gelemental/gelemental.SlackBuild
+++ b/academic/gelemental/gelemental.SlackBuild
@@ -70,6 +70,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Fix for the newer gcc
+patch -p1 -i $CWD/gcc.patch
+
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS -std=c++11" \
./configure \
diff --git a/academic/genius/README b/academic/genius/README
index d4a270574c..fa2fa4b67b 100644
--- a/academic/genius/README
+++ b/academic/genius/README
@@ -7,5 +7,5 @@ or educational tool. The syntax is very intuitive and
is designed to mimic how mathematics is usually written.
If you would like the GUI interface as well, it requires
-libgnomeui and gtksourceview. If you have these dependencies,
+libgnomeui, gtksourceview and vte2. If you have these dependencies,
pass the variable of GNOME=YES (or anything that isn't NO ;)
diff --git a/academic/genometools/genometools.SlackBuild b/academic/genometools/genometools.SlackBuild
index 0814b7dc9e..6b3c0a762c 100644
--- a/academic/genometools/genometools.SlackBuild
+++ b/academic/genometools/genometools.SlackBuild
@@ -77,7 +77,7 @@ sed -i "s:lib/libgenometools:lib${LIBDIRSUFFIX}/libgenometools:g" Makefile
sed -i "s:\$(prefix)/lib:\$(prefix)/lib${LIBDIRSUFFIX}:g" Makefile
sed -i "s:/share/man/:/man/:g" Makefile
-CFLAGS="$SLKCFLAGS" \
+CFLAGS="$SLKCFLAGS -Wno-error=format-truncation=" \
CXXFLAGS="$SLKCFLAGS" \
make $BUILDARCH \
prefix=/usr
diff --git a/academic/kile/README b/academic/kile/README
deleted file mode 100644
index d083e911fe..0000000000
--- a/academic/kile/README
+++ /dev/null
@@ -1,4 +0,0 @@
-To build Kile, you will need a Latex distribution like TeTeX or
-Tex-Live. Slackware 13.0 (and lower) include the former distribution
-and it is available on the installation disk(s) if you did not do a
-full install.
diff --git a/academic/kile/doinst.sh b/academic/kile/doinst.sh
deleted file mode 100644
index aea0f894eb..0000000000
--- a/academic/kile/doinst.sh
+++ /dev/null
@@ -1,13 +0,0 @@
-if [ -x /usr/bin/update-desktop-database ]; then
- /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
-fi
-
-if [ -x /usr/bin/update-mime-database ]; then
- /usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
-fi
-
-if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
- if [ -x /usr/bin/gtk-update-icon-cache ]; then
- /usr/bin/gtk-update-icon-cache -f usr/share/icons/hicolor >/dev/null 2>&1
- fi
-fi
diff --git a/academic/kile/kile.SlackBuild b/academic/kile/kile.SlackBuild
deleted file mode 100644
index 8b054abe8f..0000000000
--- a/academic/kile/kile.SlackBuild
+++ /dev/null
@@ -1,96 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for Kile
-
-# Copyright 2012 Heinz Wiesinger, Amsterdam, The Netherlands
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=kile
-VERSION=${VERSION:-2.1.3}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-mkdir build && cd build
- cmake \
- -DCMAKE_C_FLAGS="$SLKCFLAGS" \
- -DCMAKE_CXX_FLAGS="$SLKCFLAGS" \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DLIB_SUFFIX="$LIBDIRSUFFIX" \
- ..
- make
- make install DESTDIR=$PKG
-cd -
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS ChangeLog COPYING* README* \
- $PKG/usr/doc/$PRGNAM-$VERSION/
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-cat $CWD/doinst.sh > $PKG/install/doinst.sh
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/academic/kile/kile.info b/academic/kile/kile.info
deleted file mode 100644
index edc969bd33..0000000000
--- a/academic/kile/kile.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="kile"
-VERSION="2.1.3"
-HOMEPAGE="http://kile.sourceforge.net/"
-DOWNLOAD="http://downloads.sourceforge.net/kile/kile-2.1.3.tar.bz2"
-MD5SUM="f3129e73eea21890c40781de80b44808"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Heinz Wiesinger"
-EMAIL="pprkut@liwjatan.at"
diff --git a/academic/kile/slack-desc b/academic/kile/slack-desc
deleted file mode 100644
index a98e5da34c..0000000000
--- a/academic/kile/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-kile: kile (Latex editor)
-kile:
-kile: Kile is a user friendly TeX/LaTeX editor for the KDE
-kile: desktop environment.
-kile: This package is a Beta version for use with KDE 4.
-kile:
-kile: Homepage: http://kile.sourceforge.net/
-kile: License: GNU General Public License v2
-kile:
-kile:
-kile:
diff --git a/academic/libqalculate/README b/academic/libqalculate/README
deleted file mode 100644
index aa40e23964..0000000000
--- a/academic/libqalculate/README
+++ /dev/null
@@ -1,4 +0,0 @@
-Qalculate! is a multi-purpose desktop calculator for GNU/Linux (and Mac
-OS). It is small and simple to use but with much power and versatility
-underneath. Features include customizable functions, units, arbitrary
-precision, plotting, and a user-friendly interface (GTK+ and CLI).
diff --git a/academic/libqalculate/libqalculate.SlackBuild b/academic/libqalculate/libqalculate.SlackBuild
deleted file mode 100644
index 9d906e36f5..0000000000
--- a/academic/libqalculate/libqalculate.SlackBuild
+++ /dev/null
@@ -1,102 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for libqalculate
-
-# Copyright 2016-2020 Larry Hajali <larryhaja[at]gmail[dot]com>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=libqalculate
-VERSION=${VERSION:-3.10.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
-./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --docdir=/usr/doc/$PRGNAM-$VERSION \
- --mandir=/usr/man \
- --disable-silent-rules \
- --enable-static=no \
- --disable-rpath \
- --enable-defs2doc \
- --with-libcurl \
- --with-icu \
- --build=$ARCH-slackware-linux
-
-make
-make install DESTDIR=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-find $PKG/usr/man -type f -exec gzip -9 {} \;
-
-cp -a AUTHORS ChangeLog COPYING NEWS README* TODO $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/academic/libqalculate/libqalculate.info b/academic/libqalculate/libqalculate.info
deleted file mode 100644
index a2ac9c6801..0000000000
--- a/academic/libqalculate/libqalculate.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="libqalculate"
-VERSION="3.10.0"
-HOMEPAGE="https://qalculate.github.io/"
-DOWNLOAD="https://github.com/Qalculate/libqalculate/releases/download/v3.10.0/libqalculate-3.10.0.tar.gz"
-MD5SUM="2f68e3dfeb36de2c88fc7078cb86ab4c"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Larry Hajali"
-EMAIL="larryhaja[at]gmail[dot]com"
diff --git a/academic/libqalculate/slack-desc b/academic/libqalculate/slack-desc
deleted file mode 100644
index 84c06b2451..0000000000
--- a/academic/libqalculate/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-libqalculate: libqalculate (desktop caculator library)
-libqalculate:
-libqalculate: Qalculate! is a multi-purpose desktop calculator for GNU/Linux (and
-libqalculate: Mac OS). It is small and simple to use but with much power and
-libqalculate: versatility underneath. Features include customizable functions,
-libqalculate: units, arbitrary precision, plotting, and a user-friendly interface
-libqalculate: (GTK+ and CLI).
-libqalculate:
-libqalculate: Homepage: http://qalculate.github.io/
-libqalculate:
-libqalculate:
diff --git a/academic/primer3/primer3.SlackBuild b/academic/primer3/primer3.SlackBuild
index d3ae1b399c..514f65fd23 100644
--- a/academic/primer3/primer3.SlackBuild
+++ b/academic/primer3/primer3.SlackBuild
@@ -75,13 +75,11 @@ patch -p1 -i $CWD/gcc-7.patch
cd ./src
# Use our CFLAGS
-sed -i "/^CFLAGS/s/=/+=/" Makefile
+sed -i -e "s|-O2|$SLKCFLAGS|" -e "s|-g -Wall|-fpermissive|" Makefile
# Look for configuration files in /usr/share instead of /opt
sed -i "s:/opt/primer3_config:/usr/share/$PRGNAM/primer3_config:g" thal_main.c primer3_boulder_main.c
-CFLAGS="$SLKCFLAGS" \
-CXXFLAGS="$SLKCFLAGS" \
make
# This is recommended, but the tests take a really long time. Be patient
diff --git a/academic/pulseview/pulseview.SlackBuild b/academic/pulseview/pulseview.SlackBuild
index afeee1876a..65f1943ebf 100644
--- a/academic/pulseview/pulseview.SlackBuild
+++ b/academic/pulseview/pulseview.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=pulseview
-VERSION=${VERSION:-0.4.1}
+VERSION=${VERSION:-20210103_d023660}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -60,7 +60,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+tar xvf $CWD/$PRGNAM-$VERSION.tar.?z
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
diff --git a/academic/pulseview/pulseview.info b/academic/pulseview/pulseview.info
index 631c5fefbc..29f53cc1eb 100644
--- a/academic/pulseview/pulseview.info
+++ b/academic/pulseview/pulseview.info
@@ -1,8 +1,8 @@
PRGNAM="pulseview"
-VERSION="0.4.1"
+VERSION="20210103_d023660"
HOMEPAGE="https://sigrok.org/wiki/PulseView"
-DOWNLOAD="https://sigrok.org/download/source/pulseview/pulseview-0.4.1.tar.gz"
-MD5SUM="6056c6e42cc6eae094110cac2351558a"
+DOWNLOAD="http://ponce.cc/slackware/sources/repo/pulseview-20210103_d023660.tar.xz"
+MD5SUM="b9160d5d5777d723db68b5139a4b4ea6"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="qt5 libsigrok libsigrokdecode"
diff --git a/academic/root/root.SlackBuild b/academic/root/root.SlackBuild
index bb507f0536..e0ec409dca 100644
--- a/academic/root/root.SlackBuild
+++ b/academic/root/root.SlackBuild
@@ -18,7 +18,7 @@
# Modified by the slackbuilds.org project
PRGNAM=root
-VERSION=${VERSION:-5.34.36}
+VERSION=${VERSION:-6.10.02}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -79,9 +79,9 @@ fi
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM
+rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM\_v$VERSION.source.tar.gz
-cd $PRGNAM
+cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
@@ -134,9 +134,8 @@ mkdir -p $PKG$PYTHONDIR
mv \
$PKG$PREFIX/lib$LIBDIRSUFFIX/*.py \
$PKG$PREFIX/lib$LIBDIRSUFFIX/*.pyc \
- $PKG$PREFIX/lib$LIBDIRSUFFIX/python/genreflex \
+ $PKG$PREFIX/lib$LIBDIRSUFFIX/*.pyo \
$PKG$PYTHONDIR
-rm -fr $PKG$PREFIX/lib$LIBDIRSUFFIX/python
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneded 2> /dev/null || true
diff --git a/academic/root/root.info b/academic/root/root.info
index 450e1bde00..7df5c81738 100644
--- a/academic/root/root.info
+++ b/academic/root/root.info
@@ -1,10 +1,10 @@
PRGNAM="root"
-VERSION="5.34.36"
+VERSION="6.10.02"
HOMEPAGE="http://root.cern.ch/drupal/"
-DOWNLOAD="https://root.cern.ch/download/root_v5.34.36.source.tar.gz"
-MD5SUM="6a1ad549b3b79b10bbb1f116b49067ee"
+DOWNLOAD="https://root.cern.ch/download/root_v6.10.02.source.tar.gz"
+MD5SUM="19f2285c845a48355db779938fb4db99"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="ftgl"
+REQUIRES="ftgl unixODBC"
MAINTAINER="Jože Zobec"
EMAIL="jozze.zepl@gmail.com"
diff --git a/academic/sage/sage.SlackBuild b/academic/sage/sage.SlackBuild
index 6cb41edaa4..d8f9bf7128 100644
--- a/academic/sage/sage.SlackBuild
+++ b/academic/sage/sage.SlackBuild
@@ -25,7 +25,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=sage
-VERSION=${VERSION:-9.1}
+VERSION=${VERSION:-9.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
diff --git a/academic/sage/sage.info b/academic/sage/sage.info
index 141f25c9ef..e90ff5d18e 100644
--- a/academic/sage/sage.info
+++ b/academic/sage/sage.info
@@ -1,8 +1,8 @@
PRGNAM="sage"
-VERSION="9.1"
+VERSION="9.2"
HOMEPAGE="http://www.sagemath.org"
-DOWNLOAD="http://mirrors.mit.edu/sage/src/sage-9.1.tar.gz"
-MD5SUM="35e0ecbc6cc2ae4e1a68479598e70b7a"
+DOWNLOAD="http://mirrors.mit.edu/sage/src/sage-9.2.tar.gz"
+MD5SUM="fe61d651df8e12a0b657f8447cb622ad"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/academic/scipy3/scipy3.SlackBuild b/academic/scipy3/scipy3.SlackBuild
index 22cbb37f31..bd54ad5152 100644
--- a/academic/scipy3/scipy3.SlackBuild
+++ b/academic/scipy3/scipy3.SlackBuild
@@ -30,7 +30,7 @@
PRGNAM="scipy3"
SRCNAM="scipy"
-VERSION=${VERSION:-1.1.0}
+VERSION=${VERSION:-1.5.4}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
diff --git a/academic/scipy3/scipy3.info b/academic/scipy3/scipy3.info
index afdc113a2e..12af2fd433 100644
--- a/academic/scipy3/scipy3.info
+++ b/academic/scipy3/scipy3.info
@@ -1,8 +1,8 @@
PRGNAM="scipy3"
-VERSION="1.1.0"
+VERSION="1.5.4"
HOMEPAGE="https://www.scipy.org/"
-DOWNLOAD="https://github.com/scipy/scipy/releases/download/v1.1.0/scipy-1.1.0.tar.gz"
-MD5SUM="aa6bcc85276b6f25e17bcfc4dede8718"
+DOWNLOAD="https://github.com/scipy/scipy/releases/download/v1.5.4/scipy-1.5.4.tar.gz"
+MD5SUM="293401ee7ac354a2f2313373b497f40e"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="numpy3 lapack"
diff --git a/academic/tophat/make_pair.patch b/academic/tophat/make_pair.patch
new file mode 100644
index 0000000000..44b71d1059
--- /dev/null
+++ b/academic/tophat/make_pair.patch
@@ -0,0 +1,24 @@
+diff -uBw -aur tophat-2.1.1/src/juncs_db.cpp tophat-2.1.1-patched/src/juncs_db.cpp
+--- tophat-2.1.1/src/juncs_db.cpp 2016-02-14 19:21:17.354079000 +0100
++++ tophat-2.1.1-patched/src/juncs_db.cpp 2016-06-02 11:26:34.097425159 +0200
+@@ -338,7 +338,7 @@
+ uint32_t left_coord = atoi(scan_left_coord);
+ uint32_t right_coord = atoi(scan_right_coord);
+ bool antisense = *orientation == '-';
+- junctions.insert(make_pair<Junction, JunctionStats>(Junction(ref_id, left_coord, right_coord, antisense), JunctionStats()));
++ junctions.insert(make_pair(Junction(ref_id, left_coord, right_coord, antisense), JunctionStats()));
+ }
+ }
+
+diff -uBw -aur tophat-2.1.1/src/tophat_reports.cpp tophat-2.1.1-patched/src/tophat_reports.cpp
+--- tophat-2.1.1/src/tophat_reports.cpp 2016-02-23 22:20:44.320710000 +0100
++++ tophat-2.1.1-patched/src/tophat_reports.cpp 2016-06-02 11:26:22.057239478 +0200
+@@ -2705,7 +2705,7 @@
+ junction_stat.gtf_match = true;
+ junction_stat.accepted = true;
+
+- gtf_junctions.insert(make_pair<Junction, JunctionStats>(Junction(ref_id, left_coord, right_coord, antisense), junction_stat));
++ gtf_junctions.insert(make_pair(Junction(ref_id, left_coord, right_coord, antisense), junction_stat));
+ }
+ }
+ fprintf(stderr, "Loaded %d GFF junctions from %s.\n", (int)(gtf_junctions.size()), gtf_juncs.c_str());
diff --git a/academic/tophat/tophat.SlackBuild b/academic/tophat/tophat.SlackBuild
index f32fb590f5..e3e97fcc85 100644
--- a/academic/tophat/tophat.SlackBuild
+++ b/academic/tophat/tophat.SlackBuild
@@ -69,6 +69,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Thanks archlinux
+patch -p1 < $CWD/make_pair.patch
+
./autogen.sh
CFLAGS="$SLKCFLAGS" \
diff --git a/academic/ugene/ugene-1.22.0-dont_hardcode_includes.patch b/academic/ugene/ugene-1.22.0-dont_hardcode_includes.patch
new file mode 100644
index 0000000000..6bc26e1f19
--- /dev/null
+++ b/academic/ugene/ugene-1.22.0-dont_hardcode_includes.patch
@@ -0,0 +1,24 @@
+diff -up ugene-1.22.0/src/libs_3rdparty/samtools/samtools.pri.dont_hardcode_includes ugene-1.22.0/src/libs_3rdparty/samtools/samtools.pri
+--- ugene-1.22.0/src/libs_3rdparty/samtools/samtools.pri.dont_hardcode_includes 2016-03-31 07:21:56.000000000 -0500
++++ ugene-1.22.0/src/libs_3rdparty/samtools/samtools.pri 2016-06-02 17:49:02.383069490 -0500
+@@ -3,7 +3,7 @@ UGENE_RELATIVE_DESTDIR = ''
+
+ TEMPLATE = lib
+ CONFIG +=thread debug_and_release staticlib warn_off
+-INCLUDEPATH += src src/samtools ../../include /usr/include
++INCLUDEPATH += src src/samtools ../../include
+ win32 : INCLUDEPATH += src/samtools/win32
+ DEFINES+="_FILE_OFFSET_BITS=64" _LARGEFILE64_SOURCE _USE_KNETFILE
+ win32 : DEFINES += _USE_MATH_DEFINES "inline=__inline" "__func__=__FUNCTION__" "R_OK=4" "atoll=_atoi64" "alloca=_alloca"
+diff -up ugene-1.22.0/src/plugins_3rdparty/variants/variants.pri.dont_hardcode_includes ugene-1.22.0/src/plugins_3rdparty/variants/variants.pri
+--- ugene-1.22.0/src/plugins_3rdparty/variants/variants.pri.dont_hardcode_includes 2016-03-31 07:22:09.000000000 -0500
++++ ugene-1.22.0/src/plugins_3rdparty/variants/variants.pri 2016-06-02 20:26:35.265356432 -0500
+@@ -20,7 +20,7 @@ use_bundled_zlib() {
+ win32 : LIBS += -lwsock32
+
+
+-INCLUDEPATH += src ../../include /usr/include
++INCLUDEPATH += src ../../include
+ INCLUDEPATH += ../../libs_3rdparty/samtools/src/samtools
+ INCLUDEPATH += ../../libs_3rdparty/samtools/src
+ INCLUDEPATH += ../../libs_3rdparty/samtools/src/samtools/bcftools
diff --git a/academic/ugene/ugene.SlackBuild b/academic/ugene/ugene.SlackBuild
index 45a5a5885a..9ebc39636d 100644
--- a/academic/ugene/ugene.SlackBuild
+++ b/academic/ugene/ugene.SlackBuild
@@ -73,6 +73,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Thanks fedora
+patch -p1 < $CWD/ugene-1.22.0-dont_hardcode_includes.patch
+
# Fix libraries and man pages paths
sed -i "s:/lib:/lib${LIBDIRSUFFIX}:g" src/ugene_globals.pri
sed -i "s:/share/man:/man:g" src/ugene_globals.pri
diff --git a/academic/veusz/veusz.SlackBuild b/academic/veusz/veusz.SlackBuild
index b11846a622..6be6101ac4 100644
--- a/academic/veusz/veusz.SlackBuild
+++ b/academic/veusz/veusz.SlackBuild
@@ -69,8 +69,7 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-PYTHONVER=$(python -V 2>&1 | cut -f 2 -d' ' | cut -f 1-2 -d.)
-export SIP_EXE=/usr/bin/python3-sip
+export SIP_EXE=/usr/bin/sip3
python3 setup.py install --root $PKG