summaryrefslogtreecommitdiffstats
path: root/academic
diff options
context:
space:
mode:
author Daniel Prosser2017-04-13 08:48:44 +0200
committer Willy Sudiarto Raharjo2017-04-13 08:48:44 +0200
commite1a91f432c3eb6ecce2afa8a9b7fac277bb3d5b4 (patch)
treee4ec6e84e5335474cd0aa55d0e53f627afcf2a19 /academic
parent548cbb903902b09542a10071d4dadd6cce053f8f (diff)
downloadslackbuilds-e1a91f432c3eb6ecce2afa8a9b7fac277bb3d5b4.tar.gz
academic/avl: Updated for version 3.36.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'academic')
-rw-r--r--academic/avl/Makefile_patches/Makefile.avl.patch130
-rw-r--r--academic/avl/Makefile_patches/Makefile.eispack.patch16
-rw-r--r--academic/avl/avl.SlackBuild17
-rw-r--r--academic/avl/avl.info6
4 files changed, 80 insertions, 89 deletions
diff --git a/academic/avl/Makefile_patches/Makefile.avl.patch b/academic/avl/Makefile_patches/Makefile.avl.patch
index 72f218e36d..2b2a1090cb 100644
--- a/academic/avl/Makefile_patches/Makefile.avl.patch
+++ b/academic/avl/Makefile_patches/Makefile.avl.patch
@@ -1,32 +1,36 @@
---- bin/Makefile 2013-10-06 19:34:54.000000000 -0400
-+++ bin/Makefile.avl 2016-09-27 21:49:02.000000000 -0400
-@@ -2,8 +2,7 @@
- # Makefile for AVL
+--- bin/Makefile.gfortran 2017-02-12 14:25:41.000000000 -0500
++++ bin/Makefile.gfortran.new 2017-04-12 12:51:21.829538710 -0400
+@@ -3,9 +3,7 @@
+ # H.Youngren 2/8/17
#
+-#BINDIR = .
-BINDIR = /home/codes/bin/
-INSTALLCMD = install -s
+BINDIR = $(DESTDIR)/usr/bin/
SRC = ../src
-@@ -18,92 +17,27 @@
- matrix.o spline.o sgutil.o \
+@@ -21,85 +19,24 @@
second.o
+ # libraries needed
-PLTOBJ = ../plotlib/libPlt.a
-EIGOBJ = ../eispack/eispack.a
--## EIGOBJ = eispack.o
--
++PLTOBJ = ../plotlib/libPlt_gDP.a
++EIGOBJ = ../eispack/eispack_gDP.a
+ ## EIGOBJ = eispack.o
+
-###================================================
-### Default compilers and flags
-FC = f77
-FFLAGS = -O
+-DP =
+-DBG =
+-LFLG =
+-
-PLTLIB = -lX11
-FTNLIB =
-+PLTOBJ = ../plotlib/libPlt_gDP.a
-+EIGOBJ = ../eispack/eispack_gDP.a
-
-#Subroutine SECOND source file
-SECOND = second_g77.f
-
@@ -34,90 +38,80 @@
-
-# Uncomment flags for desired machine...
-
+-
-##--------------------------
--### DEC Alpha with OSF and DEC f77/f90 compiler
--#FC = f77
--#FFLAGS = -fast -O4 -tune host
--##--------------------------
--### SGI setup
--#FC = f77
--#FFLAGS = -O2
--##--------------------------
--## Uncomment for RS/6000
--#FFLAGS = -O -qextname
--##--------------------------
--## Uncomment for HP-9000
--#FFLAGS = -O +ppu
--#FTNLIB = -U77
--##--------------------------
--### Absoft Linux f77
--#FC = f77
--#FFLAGS = -O -f -s -W -B108 -N34
--##--------------------------
--### f2c/gcc compiler driver
--#FC = fort77
--#FFLAGS = -O2 -fomit-frame-pointer
--##--------------------------
--### GNU g77
--#FC = g77
--#FFLAGS = -O3
--##--------------------------
--### Intel Fortran Compiler 8.x
--FC = ifort
--FFLAGS = -O
--PLTLIB = -L/usr/X11R6/lib -lX11
--SECOND = second_ifc.f
+-### Intel Fortran Compiler
+-#FC = ifort
+-#OPT = -O
+-##OPT = -O0 -g
+-#ACHK =
+-#PLTLIB = -L/usr/X11R6/lib -lX11
+-#SECOND = second_ifc.f
-#FTNLIB = -Vaxlib
+-#PLTOBJ = ../plotlib/libPlt.a
+-#EIGOBJ = ../eispack/libeispack.a
+-#DP =
-##--------------------------
--### double-precision option (also need double precision Eispack and libPlt)
--FFLAGS = -O -r8
--PLTOBJ = ../plotlib/libPltDP.a
+-### double-precision (also need double precision eispack and libPlt)
+-#DP = -r8
+-#PLTOBJ = ../plotlib/libPltDP.a
+-#FFLAGS = $(OPT) $(ACHK) $(DP)
+-
-
-##---------------------------------------
--## Uncomment for Mac OSX gfortran
+-## Uncomment for gfortran
++# Compiler and flags
FC = gfortran
-
--ACHK = -fbounds-check -finit-real=inf -ffpe-trap=invalid,zero,denormal
--#ACHK =
+-OPT = -O
+-DP =
+-ACHK =
-
-+#ACHK = -fbounds-check -finit-real=inf -ffpe-trap=invalid,zero,denormal
-+ACHK =
-+PLTLIB=-lX11
-+FTNLIB=
-
--#FTNLIB = -Vaxlib
--FTNLIB =
+-PLTLIB = -L/usr/X11R6/lib -lX11
SECOND = second_g77.f
-
--DP =
+-# debug
+-#OPT = -O0
+-#DBG= -g
+-#ACHK = -fbounds-check -finit-real=inf
+-#ACHK = -fbounds-check -finit-real=inf -ffpe-trap=invalid,zero,denormal
+-
-PLTOBJ = ../plotlib/libPlt_gSP.a
--EIGOBJ = ../eispack/eispack_gSP.a
+-EIGOBJ = ../eispack/libeispack.a
-
+-##--------------------------
+-# double precision (compile appropriate eispack and libPlt)
-#DP = -fdefault-real-8
--#PLTOBJ = ../plotlib/libPltDP.a
--#EIGOBJ = ../eispack/eispack_gDP.a
+-#PLTOBJ = ../plotlib/libPlt_gDP.a
+-#EIGOBJ = ../eispack/libeispackDP.a
+-##--------------------------
-
--FFLAGS = -O -m64 $(ACHK) $(DP)
+-# use -m32 for 32-bit binary, -m64 for 64-bit (check your system!)
+-#FFLAGS = $(OPT) -m32 $(ACHK) $(DP)
+-FFLAGS = $(OPT) -m64 $(ACHK) $(DP)
+-# to make static executable
+-#LFLG = -static
-##---------------------------------------
-
+-
++ACHK =
++PLTLIB=-lX11
++FTNLIB=
+DP = -fdefault-real-8
-
+FFLAGS = -O2 $(ACHK) $(DP)
all: $(PROGS)
install: $(PROGS)
- $(INSTALLCMD) $(PROGS) $(BINDIR)
-+ install -d -m 0755 $(BINDIR)
++ install -d -m 0755 $(BINDIR)
+ install -m 0755 $(PROGS) $(BINDIR)
clean:
-/bin/rm $(PROGS)
-@@ -114,7 +48,6 @@
+@@ -110,7 +47,6 @@
avl: $(AOBJS)
- $(FC) -o avl $(AOBJS) $(ALIBS) $(PLTOBJ) $(EIGOBJ) $(PLTLIB) $(FTNLIB)
+ $(FC) -o avl $(AOBJS) $(ALIBS) $(PLTOBJ) $(EIGOBJ) $(PLTLIB) $(FTNLIB) $(LFLG)
- $(INSTALLCMD) avl $(BINDIR)
dtest: dtest.o
- $(FC) -o dtest dtest.o
+ $(FC) -o dtest dtest.o $(LFLG)
diff --git a/academic/avl/Makefile_patches/Makefile.eispack.patch b/academic/avl/Makefile_patches/Makefile.eispack.patch
index eb6aee7ef0..ad81e5b8ea 100644
--- a/academic/avl/Makefile_patches/Makefile.eispack.patch
+++ b/academic/avl/Makefile_patches/Makefile.eispack.patch
@@ -1,15 +1,15 @@
---- eispack/Makefile 2013-10-06 19:33:49.000000000 -0400
-+++ eispack/Makefile.eispack 2016-09-11 19:26:35.000000000 -0400
-@@ -1,14 +1,10 @@
--
+--- eispack/Makefile.gfortran 2014-05-22 12:51:00.000000000 -0400
++++ eispack/Makefile.gfortran.new 2017-04-12 12:23:00.115184305 -0400
+@@ -1,14 +1,11 @@
+
FC = gfortran
--FLG = -O
+-FLG = -O -m64
+FLG = -O2
AR = ar r
RAN = ranlib
-DP =
--EISLIB = eispack_gSP.a
+-EISLIB = libeispack.a
-
-#DP = -fdefault-real-8
-#EISLIB = eispack_gDP.a
@@ -18,11 +18,11 @@
$(EISLIB): eispack.f
-@@ -17,6 +13,5 @@
+@@ -17,6 +14,6 @@
$(RAN) $(EISLIB)
clean:
- /bin/rm *.o *.a
--
+ rm *.o *.a
+
diff --git a/academic/avl/avl.SlackBuild b/academic/avl/avl.SlackBuild
index 268fa689c5..424ffaa5d1 100644
--- a/academic/avl/avl.SlackBuild
+++ b/academic/avl/avl.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for avl
-# Copyright 2016 Daniel Prosser, Lexington Park, MD
+# Copyright 2017 Daniel Prosser, Lexington Park, MD
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=avl
-VERSION=${VERSION:-3.35}
+VERSION=${VERSION:-3.36}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -70,24 +70,20 @@ find -L . \
-o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Patches to create correct Makefiles
-patch -p0 < $CWD/Makefile_patches/config.make.plotlib.patch
patch -p0 < $CWD/Makefile_patches/Makefile.eispack.patch
patch -p0 < $CWD/Makefile_patches/Makefile.avl.patch
cd plotlib
- make
+ make gfortranDP
cd -
cd eispack
- make
+ make -f Makefile.gfortran
cd -
cd bin
- make
- make install DESTDIR="$PKG"
+ make -f Makefile.gfortran
+ make -f Makefile.gfortran install DESTDIR=$PKG
cd -
-# This file seems to be useless, and it's weird name causes problems for removepkg
-rm runs/?[A
-
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
@@ -102,6 +98,7 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
mkdir -p $PKG/usr/share/$PRGNAM
cp -a runs $PKG/usr/share/$PRGNAM
+cp -a movie $PKG/usr/share/$PRGNAM
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/academic/avl/avl.info b/academic/avl/avl.info
index 9b339a97e5..bbc693271c 100644
--- a/academic/avl/avl.info
+++ b/academic/avl/avl.info
@@ -1,8 +1,8 @@
PRGNAM="avl"
-VERSION="3.35"
+VERSION="3.36"
HOMEPAGE="http://web.mit.edu/drela/Public/web/avl/"
-DOWNLOAD="http://web.mit.edu/drela/Public/web/avl/avl3.35.tgz"
-MD5SUM="c2afea857271f1cde9c42257acbea350"
+DOWNLOAD="http://web.mit.edu/drela/Public/web/avl/avl3.36.tgz"
+MD5SUM="61cf7ed7629142567ac8a9c9e1ba4981"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""