summaryrefslogtreecommitdiffstats
path: root/academic
diff options
context:
space:
mode:
author Kyle Guinn2014-01-25 03:25:48 +0100
committer Robby Workman2014-01-31 07:53:23 +0100
commite9391302d0525ae4127b22f31e560882cbe14d11 (patch)
treef4560ad3b9e8fefcdc40ed555613f2da528fe5e9 /academic
parenta9ed977d47a6693781415821eef7b7e71b6f2266 (diff)
downloadslackbuilds-e9391302d0525ae4127b22f31e560882cbe14d11.tar.gz
academic/amd: Renamed and moved from libraries
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'academic')
-rw-r--r--academic/amd/README6
-rw-r--r--academic/amd/amd.SlackBuild108
-rw-r--r--academic/amd/amd.info10
-rw-r--r--academic/amd/autotoolize.diff211
-rw-r--r--academic/amd/slack-desc19
5 files changed, 354 insertions, 0 deletions
diff --git a/academic/amd/README b/academic/amd/README
new file mode 100644
index 0000000000..07e4dcafc0
--- /dev/null
+++ b/academic/amd/README
@@ -0,0 +1,6 @@
+AMD is a set of routines for ordering a sparse matrix prior to Cholesky
+factorization (or for LU factorization with diagonal pivoting). There are
+versions in both C and Fortran. Note that this software has nothing to do
+with AMD the company. This package runs on any platform.
+
+This package is part of SuiteSparse.
diff --git a/academic/amd/amd.SlackBuild b/academic/amd/amd.SlackBuild
new file mode 100644
index 0000000000..86fb3dfc9a
--- /dev/null
+++ b/academic/amd/amd.SlackBuild
@@ -0,0 +1,108 @@
+#!/bin/sh
+
+# Slackware build script for AMD
+
+# Copyright 2013 Kyle Guinn <elyk03@gmail.com>, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=amd
+SRCNAM=AMD
+VERSION=${VERSION:-2.3.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$(uname -m)" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$(uname -m) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCS="README.txt Doc/ChangeLog Doc/License Doc/lesser.txt"
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+# Recommended by SuiteSparse
+SLKCFLAGS="$SLKCFLAGS -fexceptions -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE"
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+patch -p1 < $CWD/autotoolize.diff
+autoreconf -vif
+
+CFLAGS="$SLKCFLAGS" \
+FFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --infodir=/usr/info \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --enable-shared \
+ --disable-static \
+ --disable-dependency-tracking \
+ --build=$ARCH-slackware-linux
+
+make
+make check
+make install-strip DESTDIR=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/academic/amd/amd.info b/academic/amd/amd.info
new file mode 100644
index 0000000000..aa8d4028d1
--- /dev/null
+++ b/academic/amd/amd.info
@@ -0,0 +1,10 @@
+PRGNAM="amd"
+VERSION="2.3.1"
+HOMEPAGE="https://www.cise.ufl.edu/research/sparse/amd/"
+DOWNLOAD="https://www.cise.ufl.edu/research/sparse/amd/AMD-2.3.1.tar.gz"
+MD5SUM="ee402611aa672257752611cfac10d7cd"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="suitesparseconfig"
+MAINTAINER="Kyle Guinn"
+EMAIL="elyk03@gmail.com"
diff --git a/academic/amd/autotoolize.diff b/academic/amd/autotoolize.diff
new file mode 100644
index 0000000000..92a4b25e38
--- /dev/null
+++ b/academic/amd/autotoolize.diff
@@ -0,0 +1,211 @@
+diff --git a/Demo/Makefile.am b/Demo/Makefile.am
+new file mode 100644
+--- /dev/null
++++ b/Demo/Makefile.am
+@@ -0,0 +1,53 @@
++AM_CPPFLAGS = -I$(top_srcdir)/Include $(SUITESPARSECONFIG_CFLAGS)
++LDADD = $(top_builddir)/Source/libamd.la
++
++EXTRA_DIST = \
++ amd_demo.out \
++ amd_demo2.out \
++ amd_l_demo.out \
++ amd_simple.out \
++ amd_f77cross.out \
++ amd_f77demo.out \
++ amd_f77simple.out
++
++# Disable the .out implicit pattern rule. Prevents GNU make from
++# adding bogus dependencies for the .out files listed above.
++%.out: %
++
++check_PROGRAMS = \
++ amd_demo \
++ amd_demo2 \
++ amd_l_demo \
++ amd_simple \
++ amd_f77cross \
++ amd_f77demo \
++ amd_f77simple
++
++amd_demo_SOURCES = amd_demo.c
++amd_demo2_SOURCES = amd_demo2.c
++amd_l_demo_SOURCES = amd_l_demo.c
++amd_simple_SOURCES = amd_simple.c
++
++check_LTLIBRARIES = libamd_f77wrapper.la
++libamd_f77wrapper_la_SOURCES = amd_f77wrapper.c
++libamd_f77wrapper_la_CPPFLAGS = $(AM_CPPFLAGS) -DDINT
++
++amd_f77cross_SOURCES = amd_f77cross.f
++amd_f77cross_LDADD = $(LDADD) $(top_builddir)/Source/libamdf77.la libamd_f77wrapper.la
++amd_f77demo_SOURCES = amd_f77demo.f
++amd_f77demo_LDADD = $(LDADD) $(top_builddir)/Source/libamdf77.la
++amd_f77simple_SOURCES = amd_f77simple.f
++amd_f77simple_LDADD = $(LDADD) $(top_builddir)/Source/libamdf77.la
++
++check-local: $(check_PROGRAMS) $(check_PROGRAMS:=.out)
++ @for i in $(check_PROGRAMS); do \
++ echo "Testing $$i"; \
++ ./$$i$(EXEEXT) > my_$$i.out; \
++ if diff -u $(srcdir)/$$i.out my_$$i.out; then \
++ echo "Test $$i PASSED."; \
++ else \
++ echo "Test $$i FAILED."; \
++ fi; \
++ done
++
++CLEANFILES = my_*.out
+diff --git a/Doc/Makefile.am b/Doc/Makefile.am
+new file mode 100644
+--- /dev/null
++++ b/Doc/Makefile.am
+@@ -0,0 +1,27 @@
++EXTRA_DIST = ChangeLog License lesser.txt
++
++dist_noinst_DATA = AMD_UserGuide.tex AMD_UserGuide.bib
++dist_pdf_DATA = AMD_UserGuide.pdf
++
++AMD_UserGuide.pdf AMD_UserGuide.aux: amd_h.tex
++.INTERMEDIATE: AMD_UserGuide.aux amd_h.tex
++
++%_h.tex: $(top_srcdir)/Include/%.h
++ echo '\begin{verbatim}' > $@
++ expand -8 $< >> $@
++ echo '\end{verbatim}' >> $@
++
++TEX = TEXINPUTS="$(srcdir):" pdflatex -interaction nonstopmode -file-line-error
++BIB = BIBINPUTS="$(srcdir):" bibtex
++%.pdf: %.tex %.bbl
++ $(TEX) $*
++ while grep -q "Rerun to get cross-references right" $*.log; do \
++ $(TEX) $*; \
++ done
++%.bbl: %.aux %.bib
++ $(BIB) $*
++%.aux: %.tex
++ $(TEX) $*
++
++CLEANFILES = *.aux *.bbl *.blg *.log *.toc *_h.tex
++MAINTAINERCLEANFILES = $(dist_pdf_DATA)
+diff --git a/Include/Makefile.am b/Include/Makefile.am
+new file mode 100644
+--- /dev/null
++++ b/Include/Makefile.am
+@@ -0,0 +1 @@
++pkginclude_HEADERS = amd.h amd_internal.h
+diff --git a/Makefile.am b/Makefile.am
+new file mode 100644
+--- /dev/null
++++ b/Makefile.am
+@@ -0,0 +1,5 @@
++SUBDIRS = Include Source Demo Doc
++EXTRA_DIST = README.txt
++
++pkgconfigdir = $(libdir)/pkgconfig
++pkgconfig_DATA = amd.pc
+diff --git a/Source/Makefile.am b/Source/Makefile.am
+new file mode 100644
+--- /dev/null
++++ b/Source/Makefile.am
+@@ -0,0 +1,33 @@
++AM_CPPFLAGS = -I$(top_srcdir)/Include $(SUITESPARSECONFIG_CFLAGS)
++
++AMDSRC = \
++ amd_1.c \
++ amd_2.c \
++ amd_aat.c \
++ amd_control.c \
++ amd_defaults.c \
++ amd_dump.c \
++ amd_info.c \
++ amd_order.c \
++ amd_postorder.c \
++ amd_post_tree.c \
++ amd_preprocess.c \
++ amd_valid.c
++
++lib_LTLIBRARIES = libamd.la libamdf77.la
++noinst_LTLIBRARIES = libamdi.la libamdl.la
++
++libamdi_la_SOURCES = $(AMDSRC)
++libamdi_la_LIBADD = -lm
++libamdi_la_CPPFLAGS = $(AM_CPPFLAGS) -DDINT
++
++libamdl_la_SOURCES = $(AMDSRC)
++libamdl_la_LIBADD = -lm
++libamdl_la_CPPFLAGS = $(AM_CPPFLAGS) -DDLONG
++
++libamd_la_SOURCES = amd_global.c
++libamd_la_LIBADD = libamdl.la libamdi.la
++libamd_la_LDFLAGS = -no-undefined -version-number 2:3:1
++
++libamdf77_la_SOURCES = amd.f amdbar.f
++libamdf77_la_LDFLAGS = -no-undefined -version-number 2:3:1
+diff --git a/amd.pc.in b/amd.pc.in
+new file mode 100644
+--- /dev/null
++++ b/amd.pc.in
+@@ -0,0 +1,13 @@
++prefix=@prefix@
++exec_prefix=@exec_prefix@
++libdir=@libdir@
++includedir=@includedir@
++
++Name: @PACKAGE_NAME@
++Description: Approximate minimum degree ordering
++Version: @PACKAGE_VERSION@
++URL: @PACKAGE_URL@
++Requires.private: suitesparseconfig
++Libs: -L${libdir} -lamd
++Libs.private: -lm
++Cflags: -I${includedir}/amd
+diff --git a/configure.ac b/configure.ac
+new file mode 100644
+--- /dev/null
++++ b/configure.ac
+@@ -0,0 +1,44 @@
++# -*- Autoconf -*-
++# Process this file with autoconf to produce a configure script.
++
++AC_PREREQ([2.69])
++AC_INIT([AMD],[2.3.1],[DrTimothyAldenDavis@gmail.com],[amd],[http://www.suitesparse.com/])
++AC_CONFIG_SRCDIR([Source/amd_global.c])
++AC_CONFIG_HEADERS([config.h])
++AM_INIT_AUTOMAKE([foreign])
++LT_INIT
++
++# Checks for programs.
++AC_PROG_INSTALL
++AC_PROG_CC
++AC_PROG_F77
++
++LIBS_SAVED=$LIBS
++
++# Checks for libraries.
++AC_CHECK_LIB([m], [sqrt])
++
++PKG_PROG_PKG_CONFIG
++PKG_CHECK_MODULES([SUITESPARSECONFIG],[suitesparseconfig],
++ [],
++ [AC_MSG_ERROR([cannot find suitesparseconfig])])
++
++# Checks for header files.
++AC_CHECK_HEADERS([limits.h stddef.h stdlib.h])
++
++# Checks for typedefs, structures, and compiler characteristics.
++AC_TYPE_SIZE_T
++
++# Checks for library functions.
++AC_CHECK_FUNCS([sqrt])
++
++LIBS=$LIBS_SAVED
++
++AC_CONFIG_FILES([
++ amd.pc
++ Makefile
++ Demo/Makefile
++ Doc/Makefile
++ Include/Makefile
++ Source/Makefile])
++AC_OUTPUT
diff --git a/academic/amd/slack-desc b/academic/amd/slack-desc
new file mode 100644
index 0000000000..426c7eef82
--- /dev/null
+++ b/academic/amd/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+amd: AMD (sparse matrix ordering routines)
+amd:
+amd: AMD is a set of routines for ordering a sparse matrix prior to
+amd: Cholesky factorization (or for LU factorization with diagonal
+amd: pivoting). There are versions in both C and Fortran. Note that
+amd: this software has nothing to do with AMD the company. This package
+amd: runs on any platform.
+amd:
+amd:
+amd:
+amd: