summaryrefslogtreecommitdiffstats
path: root/academic
diff options
context:
space:
mode:
author Kyle Guinn2014-01-25 04:30:51 +0100
committer Robby Workman2014-01-31 07:54:17 +0100
commitd585a61a7b7404aeb36fdbb9171a5f15b2ec7c68 (patch)
tree1f94f83d088783e9dbaae738cdeef86564f701cd /academic
parent6f6e9bf6e8e94e54a08e46e20357eb513af48a9d (diff)
downloadslackbuilds-d585a61a7b7404aeb36fdbb9171a5f15b2ec7c68.tar.gz
academic/klu: Renamed and moved from libraries.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'academic')
-rw-r--r--academic/klu/README7
-rw-r--r--academic/klu/autotoolize.diff283
-rw-r--r--academic/klu/klu.SlackBuild107
-rw-r--r--academic/klu/klu.info10
-rw-r--r--academic/klu/slack-desc19
5 files changed, 426 insertions, 0 deletions
diff --git a/academic/klu/README b/academic/klu/README
new file mode 100644
index 0000000000..fe8941f406
--- /dev/null
+++ b/academic/klu/README
@@ -0,0 +1,7 @@
+KLU is a sparse LU factorization algorithm well-suited for use in circuit
+simulation.
+
+This package is part of SuiteSparse.
+
+CHOLMOD is an optional dependency and will be used if found.
+It is primarily used for this package's test suite.
diff --git a/academic/klu/autotoolize.diff b/academic/klu/autotoolize.diff
new file mode 100644
index 0000000000..a29a03a0ba
--- /dev/null
+++ b/academic/klu/autotoolize.diff
@@ -0,0 +1,283 @@
+diff --git a/Demo/Makefile.am b/Demo/Makefile.am
+new file mode 100644
+--- /dev/null
++++ b/Demo/Makefile.am
+@@ -0,0 +1,46 @@
++AM_CPPFLAGS = -I$(top_srcdir)/Include $(AMD_CFLAGS) $(COLAMD_CFLAGS) $(BTF_CFLAGS) $(CHOLMOD_CFLAGS)
++LDADD = $(top_builddir)/Source/libklu.la
++
++EXTRA_DIST = \
++ klu_simple.out \
++ kludemo.out
++
++# Disable the .out implicit pattern rule. Prevents GNU make from
++# adding bogus dependencies for the .out files listed above.
++%.out: %
++
++check_PROGRAMS = klu_simple
++TESTS = klu_simple
++klu_simple_SOURCES = klu_simple.c
++
++if CHOLMOD
++check_PROGRAMS += kludemo kluldemo
++
++kludemo_SOURCES = kludemo.c
++kludemo_LDADD = $(LDADD) $(CHOLMOD_LIBS) -lm
++
++kluldemo_SOURCES = kluldemo.c
++kluldemo_LDADD = $(LDADD) $(CHOLMOD_LIBS) -lm
++
++MATRICES = \
++ $(top_srcdir)/Matrix/1c.mtx \
++ $(top_srcdir)/Matrix/arrowc.mtx \
++ $(top_srcdir)/Matrix/arrow.mtx \
++ $(top_srcdir)/Matrix/impcol_a.mtx \
++ $(top_srcdir)/Matrix/w156.mtx \
++ $(top_srcdir)/Matrix/ctina.mtx
++
++check-local: kludemo kluldemo $(MATRICES)
++ -./kludemo < $(top_srcdir)/Matrix/1c.mtx
++ -./kludemo < $(top_srcdir)/Matrix/arrowc.mtx
++ -./kludemo < $(top_srcdir)/Matrix/arrow.mtx
++ -./kludemo < $(top_srcdir)/Matrix/impcol_a.mtx
++ -./kludemo < $(top_srcdir)/Matrix/w156.mtx
++ -./kludemo < $(top_srcdir)/Matrix/ctina.mtx
++ -./kluldemo < $(top_srcdir)/Matrix/1c.mtx
++ -./kluldemo < $(top_srcdir)/Matrix/arrowc.mtx
++ -./kluldemo < $(top_srcdir)/Matrix/arrow.mtx
++ -./kluldemo < $(top_srcdir)/Matrix/impcol_a.mtx
++ -./kluldemo < $(top_srcdir)/Matrix/w156.mtx
++ -./kluldemo < $(top_srcdir)/Matrix/ctina.mtx
++endif
+diff --git a/Doc/Makefile.am b/Doc/Makefile.am
+new file mode 100644
+--- /dev/null
++++ b/Doc/Makefile.am
+@@ -0,0 +1,48 @@
++EXTRA_DIST = ChangeLog lesser.txt
++
++dist_noinst_DATA = KLU_UserGuide.tex KLU_UserGuide.bib
++dist_pdf_DATA = KLU_UserGuide.pdf palamadai_e.pdf
++
++SRC = \
++ klu_h.tex \
++ btf_h.tex \
++ klu_simple_c.tex
++
++KLU_UserGuide.pdf KLU_UserGuide.aux: $(SRC)
++.INTERMEDIATE: KLU_UserGuide.aux $(SRC)
++
++define verbatim =
++echo '\begin{verbatim}' > $@
++expand -8 $< >> $@
++echo '\end{verbatim}' >> $@
++endef
++
++klu_h.tex: $(top_srcdir)/Include/klu.h
++ $(verbatim)
++
++# FIXME: We don't know the location of btf.h.
++# Insert a placeholder for now.
++#btf_h.tex: /usr/include/btf.h
++# $(verbatim)
++btf_h.tex:
++ echo '\begin{verbatim}' > $@
++ echo 'See your btf.h local install' >> $@
++ echo '\end{verbatim}' >> $@
++
++klu_simple_c.tex: $(top_srcdir)/Demo/klu_simple.c
++ $(verbatim)
++
++TEX = TEXINPUTS="$(srcdir):" pdflatex -interaction nonstopmode -file-line-error
++BIB = BIBINPUTS="$(srcdir):" bibtex
++%.pdf: %.tex %.bbl
++ $(TEX) $*
++ while grep -q "Rerun to get cross-references right" $*.log; do \
++ $(TEX) $*; \
++ done
++%.bbl: %.aux %.bib
++ $(BIB) $*
++%.aux: %.tex
++ $(TEX) $*
++
++CLEANFILES = *.aux *.bbl *.blg *.log *.toc $(SRC)
++MAINTAINERCLEANFILES = $(dist_pdf_DATA)
+diff --git a/Include/Makefile.am b/Include/Makefile.am
+new file mode 100644
+--- /dev/null
++++ b/Include/Makefile.am
+@@ -0,0 +1 @@
++pkginclude_HEADERS = klu.h klu_internal.h klu_version.h
+diff --git a/Makefile.am b/Makefile.am
+new file mode 100644
+--- /dev/null
++++ b/Makefile.am
+@@ -0,0 +1,5 @@
++SUBDIRS = Include Source User Matrix Demo Doc
++EXTRA_DIST = README.txt
++
++pkgconfigdir = $(libdir)/pkgconfig
++pkgconfig_DATA = klu.pc
+diff --git a/Matrix/Makefile.am b/Matrix/Makefile.am
+new file mode 100644
+--- /dev/null
++++ b/Matrix/Makefile.am
+@@ -0,0 +1,11 @@
++dist_noinst_DATA = \
++ 1c.mtx \
++ GD99_cc.mtx \
++ arrow.mtx \
++ arrowc.mtx \
++ ctina.mtx \
++ impcol_a.mtx \
++ one.mtx \
++ onec.mtx \
++ two.mtx \
++ w156.mtx
+diff --git a/Source/Makefile.am b/Source/Makefile.am
+new file mode 100644
+--- /dev/null
++++ b/Source/Makefile.am
+@@ -0,0 +1,40 @@
++AM_CPPFLAGS = -I$(top_srcdir)/Include $(AMD_CFLAGS) $(COLAMD_CFLAGS) $(BTF_CFLAGS)
++
++noinst_LTLIBRARIES = libklud.la libkluz.la libklul.la libkluzl.la
++
++KLUSRC = \
++ klu.c \
++ klu_diagnostics.c \
++ klu_dump.c \
++ klu_extract.c \
++ klu_factor.c \
++ klu_free_numeric.c \
++ klu_kernel.c \
++ klu_refactor.c \
++ klu_scale.c \
++ klu_solve.c \
++ klu_sort.c \
++ klu_tsolve.c
++
++CKLUSRC = \
++ klu_analyze.c \
++ klu_analyze_given.c \
++ klu_defaults.c \
++ klu_free_symbolic.c \
++ klu_memory.c
++
++libklud_la_SOURCES = $(KLUSRC) $(CKLUSRC)
++
++libkluz_la_SOURCES = $(KLUSRC)
++libkluz_la_CPPFLAGS = $(AM_CPPFLAGS) -DCOMPLEX
++
++libklul_la_SOURCES = $(KLUSRC) $(CKLUSRC)
++libklul_la_CPPFLAGS = $(AM_CPPFLAGS) -DDLONG
++
++libkluzl_la_SOURCES = $(KLUSRC)
++libkluzl_la_CPPFLAGS = $(AM_CPPFLAGS) -DDLONG -DCOMPLEX
++
++lib_LTLIBRARIES = libklu.la
++libklu_la_SOURCES =
++libklu_la_LIBADD = libklud.la libkluz.la libklul.la libkluzl.la $(AMD_LIBS) $(COLAMD_LIBS) $(BTF_LIBS)
++libklu_la_LDFLAGS = -no-undefined -version-number 1:2:1
+diff --git a/User/Makefile.am b/User/Makefile.am
+new file mode 100644
+--- /dev/null
++++ b/User/Makefile.am
+@@ -0,0 +1,12 @@
++AM_CPPFLAGS = -I$(top_srcdir)/Include $(AMD_CFLAGS) $(COLAMD_CFLAGS) $(BTF_CFLAGS) $(CHOLMOD_CFLAGS) $(SUITESPARSECONFIG_CFLAGS)
++
++EXTRA_DIST = README.txt
++
++if CHOLMOD
++pkginclude_HEADERS = klu_cholmod.h
++
++lib_LTLIBRARIES = libklu_cholmod.la
++libklu_cholmod_la_SOURCES = klu_cholmod.c klu_l_cholmod.c
++libklu_cholmod_la_LIBADD = $(CHOLMOD_LIBS)
++libklu_cholmod_la_LDFLAGS = -no-undefined -version-number 1:2:1
++endif
+diff --git a/configure.ac b/configure.ac
+new file mode 100644
+--- /dev/null
++++ b/configure.ac
+@@ -0,0 +1,62 @@
++# -*- Autoconf -*-
++# Process this file with autoconf to produce a configure script.
++
++AC_PREREQ([2.69])
++AC_INIT([KLU],[1.2.1],[DrTimothyAldenDavis@gmail.com],[klu],[http://www.suitesparse.com/])
++AC_CONFIG_SRCDIR([Source/klu.c])
++AC_CONFIG_HEADERS([config.h])
++AM_INIT_AUTOMAKE([foreign])
++LT_INIT
++
++# Checks for programs.
++AC_PROG_INSTALL
++AC_PROG_CC
++
++LIBS_SAVED=$LIBS
++
++# Checks for libraries.
++AC_CHECK_LIB([m], [sqrt])
++
++PKG_PROG_PKG_CONFIG
++PKG_CHECK_MODULES([SUITESPARSECONFIG],[suitesparseconfig],
++ [],
++ [AC_MSG_ERROR([cannot find suitesparseconfig])])
++PKG_CHECK_MODULES([AMD],[amd],
++ [],
++ [AC_MSG_ERROR([cannot find amd])])
++PKG_CHECK_MODULES([COLAMD],[colamd],
++ [],
++ [AC_MSG_ERROR([cannot find colamd])])
++PKG_CHECK_MODULES([BTF],[btf],
++ [],
++ [AC_MSG_ERROR([cannot find btf])])
++PKG_CHECK_MODULES([CHOLMOD],[cholmod],
++ [cholmod="yes"],
++ [cholmod="no"])
++if test "x$cholmod" != "xyes"; then
++ AC_MSG_WARN([cannot find cholmod, disabling some functionality])
++fi
++
++# Checks for header files.
++AC_CHECK_HEADERS([limits.h stdlib.h])
++
++# Checks for typedefs, structures, and compiler characteristics.
++AC_TYPE_SIZE_T
++
++# Checks for library functions.
++AC_CHECK_FUNCS([sqrt])
++
++LIBS=$LIBS_SAVED
++
++AM_CONDITIONAL([CHOLMOD], [test "x$cholmod" = "xyes"])
++
++AC_CONFIG_FILES([
++ klu.pc
++ Makefile
++ Demo/Makefile
++ Doc/Makefile
++ Include/Makefile
++ Matrix/Makefile
++ Source/Makefile
++ User/Makefile])
++AC_OUTPUT
+diff --git a/klu.pc.in b/klu.pc.in
+new file mode 100644
+--- /dev/null
++++ b/klu.pc.in
+@@ -0,0 +1,13 @@
++prefix=@prefix@
++exec_prefix=@exec_prefix@
++libdir=@libdir@
++includedir=@includedir@
++
++Name: @PACKAGE_NAME@
++Description: Sparse LU factorization for circuit simulation
++Version: @PACKAGE_VERSION@
++URL: @PACKAGE_URL@
++Requires.private: amd colamd btf
++Libs: -L${libdir} -lklu
++Libs.private: -lm
++Cflags: -I${includedir}/klu
diff --git a/academic/klu/klu.SlackBuild b/academic/klu/klu.SlackBuild
new file mode 100644
index 0000000000..237c7c02e6
--- /dev/null
+++ b/academic/klu/klu.SlackBuild
@@ -0,0 +1,107 @@
+#!/bin/sh
+
+# Slackware build script for KLU
+
+# Copyright 2013 Kyle Guinn <elyk03@gmail.com>, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=klu
+SRCNAM=KLU
+VERSION=${VERSION:-1.2.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$(uname -m)" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$(uname -m) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCS="README.txt Doc/ChangeLog Doc/lesser.txt"
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+# Recommended by SuiteSparse
+SLKCFLAGS="$SLKCFLAGS -fexceptions -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE"
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+patch -p1 < $CWD/autotoolize.diff
+autoreconf -vif
+
+CFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --infodir=/usr/info \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --enable-shared \
+ --disable-static \
+ --disable-dependency-tracking \
+ --build=$ARCH-slackware-linux
+
+make
+make check
+make install-strip DESTDIR=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/academic/klu/klu.info b/academic/klu/klu.info
new file mode 100644
index 0000000000..ed6b9b1eb1
--- /dev/null
+++ b/academic/klu/klu.info
@@ -0,0 +1,10 @@
+PRGNAM="klu"
+VERSION="1.2.1"
+HOMEPAGE="https://www.cise.ufl.edu/research/sparse/klu/"
+DOWNLOAD="https://www.cise.ufl.edu/research/sparse/klu/KLU-1.2.1.tar.gz"
+MD5SUM="3ab15b997a5c8fd37d33c290e03b29e5"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="%README% suitesparseconfig amd colamd btf"
+MAINTAINER="Kyle Guinn"
+EMAIL="elyk03@gmail.com"
diff --git a/academic/klu/slack-desc b/academic/klu/slack-desc
new file mode 100644
index 0000000000..fc5f4f2bf6
--- /dev/null
+++ b/academic/klu/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+klu: KLU (sparse matrix factoring routines)
+klu:
+klu: KLU is a sparse LU factorization algorithm well-suited for use in
+klu: circuit simulation.
+klu:
+klu:
+klu:
+klu:
+klu:
+klu:
+klu: