summaryrefslogtreecommitdiffstats
path: root/academic
diff options
context:
space:
mode:
author Petar Petrov2013-12-14 15:34:09 +0100
committer Erik Hanson2013-12-14 17:53:07 +0100
commitc732454ecf95097afba466a66d2cef0e14730d36 (patch)
tree7429ea32d811285d90fb1056749fb5443289cacd /academic
parent94efe73619e8e160c989db0a726e0623b220ec25 (diff)
downloadslackbuilds-c732454ecf95097afba466a66d2cef0e14730d36.tar.gz
academic/cistrome-CEAS: Added (Cis-regulatory Element Annotation).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'academic')
-rw-r--r--academic/cistrome-CEAS/README14
-rw-r--r--academic/cistrome-CEAS/References2
-rw-r--r--academic/cistrome-CEAS/cistrome-CEAS.SlackBuild94
-rw-r--r--academic/cistrome-CEAS/cistrome-CEAS.info10
-rw-r--r--academic/cistrome-CEAS/slack-desc19
5 files changed, 139 insertions, 0 deletions
diff --git a/academic/cistrome-CEAS/README b/academic/cistrome-CEAS/README
new file mode 100644
index 0000000000..ca8504e954
--- /dev/null
+++ b/academic/cistrome-CEAS/README
@@ -0,0 +1,14 @@
+CEAS: Cis-regulatory Element Annotation System
+
+This is a tool designed to characterize genome-wide protein-DNA
+interaction patterns from ChIP-chip and ChIP-Seq of both sharp and
+broad binding factors. As a stand-alone extension of our web
+application CEAS, it provides statistics on ChIP enrichment at
+important genome features such as specific chromosome, promoters, gene
+bodies, or exons, and infers genes most likely to be regulated by a
+binding factor. CEAS also enables biologists to visualize the average
+ChIP enrichment signals over specific genomic features, allowing
+continuous and broad ChIP enrichment to be perceived which might be
+too subtle to detect from ChIP peaks alone.
+
+A recommended package to install is R.
diff --git a/academic/cistrome-CEAS/References b/academic/cistrome-CEAS/References
new file mode 100644
index 0000000000..993650dd13
--- /dev/null
+++ b/academic/cistrome-CEAS/References
@@ -0,0 +1,2 @@
+Shin H, Liu T, Manrai AK, Liu XS. CEAS: Cis-regulatory element
+annotation system. Bioinformatics 2009;25(19):2605-6.
diff --git a/academic/cistrome-CEAS/cistrome-CEAS.SlackBuild b/academic/cistrome-CEAS/cistrome-CEAS.SlackBuild
new file mode 100644
index 0000000000..a06e7ed225
--- /dev/null
+++ b/academic/cistrome-CEAS/cistrome-CEAS.SlackBuild
@@ -0,0 +1,94 @@
+#!/bin/sh
+
+# Slackware build script for cistrome-CEAS
+
+# Copyright 2013 Petar Petrov, petar.petrov@student.oulu.fi
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=cistrome-CEAS
+VERSION=${VERSION:-1.0.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+SRCNAM=CEAS-Package
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ Artistic_License.pdf ChangeLog PKG-INFO\
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+cat $CWD/References > $PKG/usr/doc/$PRGNAM-$VERSION/References
+
+# Ugene expects this to have the py suffix
+cd $PKG/usr/bin
+ln -s ceas ceas.py
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/academic/cistrome-CEAS/cistrome-CEAS.info b/academic/cistrome-CEAS/cistrome-CEAS.info
new file mode 100644
index 0000000000..a61c58a620
--- /dev/null
+++ b/academic/cistrome-CEAS/cistrome-CEAS.info
@@ -0,0 +1,10 @@
+PRGNAM="cistrome-CEAS"
+VERSION="1.0.2"
+HOMEPAGE="http://liulab.dfci.harvard.edu/CEAS/"
+DOWNLOAD="http://liulab.dfci.harvard.edu/CEAS/src/CEAS-Package-1.0.2.tar.gz"
+MD5SUM="faf202ff613794ab9cd07f282c6e2663"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Petar Petrov"
+EMAIL="petar.petrov@student.oulu.fi"
diff --git a/academic/cistrome-CEAS/slack-desc b/academic/cistrome-CEAS/slack-desc
new file mode 100644
index 0000000000..818d214454
--- /dev/null
+++ b/academic/cistrome-CEAS/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+cistrome-CEAS: cistrome-CEAS (CEAS: Cis-regulatory Element Annotation System)
+cistrome-CEAS:
+cistrome-CEAS: This is a tool designed to characterize genome-wide protein-DNA
+cistrome-CEAS: interaction patterns from ChIP-chip and ChIP-Seq of both sharp
+cistrome-CEAS: broad binding factors.
+cistrome-CEAS:
+cistrome-CEAS: Home: http://liulab.dfci.harvard.edu/CEAS/
+cistrome-CEAS: References: /usr/doc/cistrome-CEAS-1.0.2/References
+cistrome-CEAS:
+cistrome-CEAS:
+cistrome-CEAS: