summaryrefslogtreecommitdiffstats
path: root/academic
diff options
context:
space:
mode:
author Heinz Wiesinger2013-11-25 12:23:31 +0100
committer Heinz Wiesinger2013-11-25 13:11:59 +0100
commit926b93d445e92be03e62efcd742b2ac88f0d96ed (patch)
treea9e1e616e37f2f7187d0b0ab2d8e83b3ad8eed63 /academic
parent7bc7feac90a3966ebaea1b1ad87431764a560344 (diff)
downloadslackbuilds-926b93d445e92be03e62efcd742b2ac88f0d96ed.tar.gz
various: Replace chmod command with find command from template.
Signed-off-by: Heinz Wiesinger <pprkut@slackbuilds.org>
Diffstat (limited to 'academic')
-rw-r--r--academic/chemtool/chemtool.SlackBuild6
-rw-r--r--academic/geda-gaf/geda-gaf.SlackBuild6
-rw-r--r--academic/ggobi/ggobi.SlackBuild6
-rw-r--r--academic/metis/metis.SlackBuild6
-rw-r--r--academic/octave/octave.SlackBuild6
-rw-r--r--academic/xoscope/xoscope.SlackBuild6
6 files changed, 30 insertions, 6 deletions
diff --git a/academic/chemtool/chemtool.SlackBuild b/academic/chemtool/chemtool.SlackBuild
index 402573c482..52acf74472 100644
--- a/academic/chemtool/chemtool.SlackBuild
+++ b/academic/chemtool/chemtool.SlackBuild
@@ -63,7 +63,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R a-s,u+w,go+r-w .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
diff --git a/academic/geda-gaf/geda-gaf.SlackBuild b/academic/geda-gaf/geda-gaf.SlackBuild
index fa4a2f07c3..790eb328a6 100644
--- a/academic/geda-gaf/geda-gaf.SlackBuild
+++ b/academic/geda-gaf/geda-gaf.SlackBuild
@@ -48,7 +48,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go-w,a+rX-st .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
LDFLAGS="$LDFLAGS -lm" \
CFLAGS="$SLKCFLAGS" \
diff --git a/academic/ggobi/ggobi.SlackBuild b/academic/ggobi/ggobi.SlackBuild
index 6a302ccf14..dc3cbc3f86 100644
--- a/academic/ggobi/ggobi.SlackBuild
+++ b/academic/ggobi/ggobi.SlackBuild
@@ -45,7 +45,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-s .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
CXXFLAGS="$SLKCFLAGS" \
CFLAGS="$SLKCFLAGS" \
diff --git a/academic/metis/metis.SlackBuild b/academic/metis/metis.SlackBuild
index 8c58628e72..114e6cf475 100644
--- a/academic/metis/metis.SlackBuild
+++ b/academic/metis/metis.SlackBuild
@@ -49,7 +49,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-st .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
patch -p1 < $CWD/autotoolize.diff
autoreconf -vif
diff --git a/academic/octave/octave.SlackBuild b/academic/octave/octave.SlackBuild
index 3f85721317..9ed28fb1b2 100644
--- a/academic/octave/octave.SlackBuild
+++ b/academic/octave/octave.SlackBuild
@@ -80,7 +80,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go-w,a+rX-st .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
CFLAGS="$SLKCFLAGS" \
CXXFLAGS="$SLKCFLAGS" \
diff --git a/academic/xoscope/xoscope.SlackBuild b/academic/xoscope/xoscope.SlackBuild
index 35ca9ba425..eeecdc1755 100644
--- a/academic/xoscope/xoscope.SlackBuild
+++ b/academic/xoscope/xoscope.SlackBuild
@@ -46,7 +46,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tgz
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-st .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Allow DEPRECATED functions or build fails on gtk+2-2.24.3.
sed -i -e '/-DG.*_DISABLE_DEPRECATED/d' gtkdatabox-0.6.0.0/gtk/Makefile.am