summaryrefslogtreecommitdiffstats
path: root/academic
diff options
context:
space:
mode:
author Petar Petrov2013-12-14 02:46:00 +0100
committer Erik Hanson2013-12-14 17:53:06 +0100
commit8c35f38c042e85a39712cd73a895b1f566d1050d (patch)
treef235bb47aee8d7c7994613c13b46f9308154937a /academic
parent4ac706e0939700e07495fa69c66670fed121edc2 (diff)
downloadslackbuilds-8c35f38c042e85a39712cd73a895b1f566d1050d.tar.gz
academic/paml: Added (Phylogenetic Analysis by Maximum Likelihood).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'academic')
-rw-r--r--academic/paml/LICENSE3
-rw-r--r--academic/paml/README18
-rw-r--r--academic/paml/References6
-rw-r--r--academic/paml/paml.SlackBuild158
-rw-r--r--academic/paml/paml.info10
-rw-r--r--academic/paml/slack-desc19
6 files changed, 214 insertions, 0 deletions
diff --git a/academic/paml/LICENSE b/academic/paml/LICENSE
new file mode 100644
index 0000000000..b58e250862
--- /dev/null
+++ b/academic/paml/LICENSE
@@ -0,0 +1,3 @@
+PAML is maintained and distributed for academic use free of charge by
+Ziheng Yang. ANSI C source codes are distributed for UNIX/Linux/Mac
+OSX, and executables are provided for MS Windows.
diff --git a/academic/paml/README b/academic/paml/README
new file mode 100644
index 0000000000..5703a8d4d0
--- /dev/null
+++ b/academic/paml/README
@@ -0,0 +1,18 @@
+PAML: Phylogenetic Analysis by Maximum Likelihood
+
+PAML is a package of programs for phylogenetic analyses of DNA or
+protein sequences using maximum likelihood. PAML is not good for tree
+making. It may be used to estimate parameters and test hypotheses to
+study the evolutionary process, when you have reconstructed trees
+using other programs such as PAUP*, PHYLIP, MOLPHY, PhyML, RaxML, etc.
+
+Notes about running of PAML programs and the package:
+
+- Example datasets are included in /usr/share/paml/examples
+- Control files for PAML programs are in /usr/share/paml
+- Dcumentation can be found in /usr/doc/paml-$VERSION
+- Additional executables are placed in /usr/libexec/paml
+
+Suggested citation:
+Yang, Z. 2007. PAML 4: a program package for phylogenetic analysis by
+maximum likelihood. Molecular Biology and Evolution 24: 1586-1591
diff --git a/academic/paml/References b/academic/paml/References
new file mode 100644
index 0000000000..edc41e24aa
--- /dev/null
+++ b/academic/paml/References
@@ -0,0 +1,6 @@
+Suggested citations:
+Yang, Z. 1997. PAML: a program package for phylogenetic analysis by
+maximum likelihood Computer Applications in BioSciences 13:555-556.
+Yang, Z. 2007. PAML 4: a program package for phylogenetic analysis by
+maximum likelihood. Molecular Biology and Evolution 24: 1586-1591
+(http://abacus.gene.ucl.ac.uk/software/paml.html).
diff --git a/academic/paml/paml.SlackBuild b/academic/paml/paml.SlackBuild
new file mode 100644
index 0000000000..ab866fd536
--- /dev/null
+++ b/academic/paml/paml.SlackBuild
@@ -0,0 +1,158 @@
+#!/bin/sh
+
+# Slackware build script for paml
+
+# Copyright 2013 Petar Petrov, petar.petrov@student.oulu.fi
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=paml
+VERSION=${VERSION:-4.7a}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf ${PRGNAM}${VERSION}
+tar xvf $CWD/${PRGNAM}${VERSION}.tgz
+cd ${PRGNAM}${VERSION}
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Use our CFLAGS
+sed -i "/^C.*.*FLAGS/s/=/+=/" src/Makefile
+
+# These are the main components, and most likely this will be all you
+# need. Check the next sections if you need some optional components.
+# They will be installed to /usr/libexec/paml in case you want them.
+cd src
+CFLAGS="$SLKCFLAGS" \
+make -f Makefile
+
+install -D -m755 baseml $PKG/usr/bin/baseml
+install -D -m755 basemlg $PKG/usr/bin/basemlg
+install -D -m755 chi2 $PKG/usr/bin/chi2
+install -D -m755 codeml $PKG/usr/bin/codeml
+install -D -m755 evolver $PKG/usr/bin/evolver
+install -D -m755 mcmctree $PKG/usr/bin/mcmctree
+install -D -m755 pamp $PKG/usr/bin/pamp
+install -D -m755 yn00 $PKG/usr/bin/yn00
+
+# Compile and install Evolver variations
+cc $SLKCFLAGS -DCodonNSbranches -o evolverNSbranches evolver.c tools.c -lm
+cc $SLKCFLAGS -DCodonNSsites -o evolverNSsites evolver.c tools.c -lm
+cc $SLKCFLAGS -DCodonNSbranchsites -o evolverNSbranchsites evolver.c tools.c -lm
+
+install -D -m755 evolverNSbranches $PKG/usr/libexec/$PRGNAM/evolverNSbranches
+install -D -m755 evolverNSbranchsites $PKG/usr/libexec/$PRGNAM/evolverNSbranchsites
+install -D -m755 evolverNSsites $PKG/usr/libexec/$PRGNAM/evolverNSsites
+
+# Compile and install TreeTime
+cc $SLKCFLAGS -o TreeTimeJeff TreeTimeJeff.c tools.c -lm
+install -D -m755 TreeTimeJeff $PKG/usr/libexec/$PRGNAM/TreeTimeJeff
+
+# Rename the local README, so we include it in the package.
+mv README.txt README-compiling.txt
+
+# Compile and install NEB, BEB and BranchSite
+cd ../Technical/Simulation/Codon
+cc $SLKCFLAGS -DNEB -o PositiveSitesNEB PositiveSites.c -lm
+cc $SLKCFLAGS -DBEB -o PositiveSitesBEB PositiveSites.c -lm
+cc $SLKCFLAGS -DBranchSite -o PositiveSitesBS PositiveSites.c -lm
+
+install -D -m755 PositiveSitesBEB $PKG/usr/libexec/$PRGNAM/PositiveSitesBEB
+install -D -m755 PositiveSitesBS $PKG/usr/libexec/$PRGNAM/PositiveSitesBS
+install -D -m755 PositiveSitesNEB $PKG/usr/libexec/$PRGNAM/PositiveSitesNEB
+
+# Rename this README too so we include it in the package.
+mv README.txt README-codon.txt
+
+# Compile and install Multiruns
+cd ..
+cc -o multiruns $SLKCFLAGS multiruns.c -lm
+install -D -m755 multiruns $PKG/usr/libexec/$PRGNAM/multiruns
+
+cd $TMP/${PRGNAM}${VERSION}
+
+# Include sample system files and example experimental data.
+mkdir -p $PKG/usr/share/$PRGNAM/{aa,codon,ctl,dat,nuc,paup,trees}
+cp -a *.dat dat/* $PKG/usr/share/$PRGNAM/dat
+cp -a Technical/Simulation/Codon/{codeml.ctl,*.dat} \
+ $PKG/usr/share/$PRGNAM/codon
+cp -a examples $PKG/usr/share/$PRGNAM
+cp -a *.aa $PKG/usr/share/$PRGNAM/aa
+cp -a *.ctl $PKG/usr/share/$PRGNAM/ctl
+cp -a *.nuc $PKG/usr/share/$PRGNAM/nuc
+cp -a paup* $PKG/usr/share/$PRGNAM/paup
+cp -a *.trees $PKG/usr/share/$PRGNAM/trees
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a \
+ README.txt GeneticCode.txt doc/* src/README-compiling.txt \
+ Technical/{Pt/eigenQREV.pdf,Simulation/{multiruns.txt,Codon/README-codon.txt}}\
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+cat $CWD/LICENSE > $PKG/usr/doc/$PRGNAM-$VERSION/LICENSE
+
+# Fix permissions.
+find $PKG/usr/{doc,share} -type d -exec chmod 755 {} \; -o \
+ -type f -exec chmod 644 {} \;
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/academic/paml/paml.info b/academic/paml/paml.info
new file mode 100644
index 0000000000..653abc3609
--- /dev/null
+++ b/academic/paml/paml.info
@@ -0,0 +1,10 @@
+PRGNAM="paml"
+VERSION="4.7a"
+HOMEPAGE="http://abacus.gene.ucl.ac.uk/software/paml.html"
+DOWNLOAD="http://abacus.gene.ucl.ac.uk/software/paml4.7a.tgz"
+MD5SUM="59b330e6ba15b1e79a02ff3817b96346"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Petar Petrov"
+EMAIL="petar.petrov@student.oulu.fi"
diff --git a/academic/paml/slack-desc b/academic/paml/slack-desc
new file mode 100644
index 0000000000..86ae56d94f
--- /dev/null
+++ b/academic/paml/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+paml: paml (PAML: Phylogenetic Analysis by Maximum Likelihood)
+paml:
+paml: PAML is a package of programs for phylogenetic analyses of DNA or
+paml: protein sequences using maximum likelihood. PAML is not good for
+paml: tree making. It may be used to estimate parameters and test
+paml: hypotheses to study the evolutionary process, when you have
+paml: reconstructed trees using other programs such as PAUP*, PHYLIP,
+paml: MOLPHY, PhyML, RaxML, etc.
+paml:
+paml: Home: http://abacus.gene.ucl.ac.uk/software/paml.html
+paml: References: /usr/doc/paml-4.7a/References