summaryrefslogtreecommitdiffstats
path: root/academic
diff options
context:
space:
mode:
author Kyle Guinn2014-01-25 04:04:57 +0100
committer Robby Workman2014-01-31 07:53:58 +0100
commit43292a63d56528fb5887a93b0263b92744784de4 (patch)
tree9fde217469c19b7ad75c7dafef5eefbc43e7320b /academic
parenta953dce0103e3053aa98c01fdac58303c240fc75 (diff)
downloadslackbuilds-43292a63d56528fb5887a93b0263b92744784de4.tar.gz
academic/btf: Renamed and moved from libraries.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'academic')
-rw-r--r--academic/btf/README5
-rw-r--r--academic/btf/autotoolize.diff94
-rw-r--r--academic/btf/btf.SlackBuild107
-rw-r--r--academic/btf/btf.info10
-rw-r--r--academic/btf/slack-desc19
5 files changed, 235 insertions, 0 deletions
diff --git a/academic/btf/README b/academic/btf/README
new file mode 100644
index 0000000000..3666aedf6b
--- /dev/null
+++ b/academic/btf/README
@@ -0,0 +1,5 @@
+BTF permutes an unsymmetric matrix (square or rectangular) into its block
+upper triangular form (more precisely, it computes a Dulmage-Mendelsohn
+decomposition).
+
+This package is part of SuiteSparse.
diff --git a/academic/btf/autotoolize.diff b/academic/btf/autotoolize.diff
new file mode 100644
index 0000000000..29d555f8d1
--- /dev/null
+++ b/academic/btf/autotoolize.diff
@@ -0,0 +1,94 @@
+diff --git a/Include/Makefile.am b/Include/Makefile.am
+new file mode 100644
+--- /dev/null
++++ b/Include/Makefile.am
+@@ -0,0 +1,2 @@
++pkginclude_HEADERS = btf.h
++noinst_HEADERS = btf_internal.h
+diff --git a/Makefile.am b/Makefile.am
+new file mode 100644
+--- /dev/null
++++ b/Makefile.am
+@@ -0,0 +1,5 @@
++SUBDIRS = Include Source
++EXTRA_DIST = README.txt Doc/ChangeLog Doc/lesser.txt
++
++pkgconfigdir = $(libdir)/pkgconfig
++pkgconfig_DATA = btf.pc
+diff --git a/Source/Makefile.am b/Source/Makefile.am
+new file mode 100644
+--- /dev/null
++++ b/Source/Makefile.am
+@@ -0,0 +1,18 @@
++AM_CPPFLAGS = -I$(top_srcdir)/Include $(SUITESPARSECONFIG_CFLAGS)
++
++BTFSRC = \
++ btf_maxtrans.c \
++ btf_order.c \
++ btf_strongcomp.c
++
++lib_LTLIBRARIES = libbtf.la
++noinst_LTLIBRARIES = libbtfi.la libbtfl.la
++
++libbtfi_la_SOURCES = $(BTFSRC)
++
++libbtfl_la_SOURCES = $(BTFSRC)
++libbtfl_la_CPPFLAGS = $(AM_CPPFLAGS) -DDLONG
++
++libbtf_la_SOURCES =
++libbtf_la_LIBADD = libbtfi.la libbtfl.la
++libbtf_la_LDFLAGS = -no-undefined -version-number 1:2:0
+diff --git a/btf.pc.in b/btf.pc.in
+new file mode 100644
+--- /dev/null
++++ b/btf.pc.in
+@@ -0,0 +1,12 @@
++prefix=@prefix@
++exec_prefix=@exec_prefix@
++libdir=@libdir@
++includedir=@includedir@
++
++Name: @PACKAGE_NAME@
++Description: Permutation to block triangular form
++Version: @PACKAGE_VERSION@
++URL: @PACKAGE_URL@
++Requires.private: suitesparseconfig
++Libs: -L${libdir} -lbtf
++Cflags: -I${includedir}/btf
+diff --git a/configure.ac b/configure.ac
+new file mode 100644
+--- /dev/null
++++ b/configure.ac
+@@ -0,0 +1,32 @@
++# -*- Autoconf -*-
++# Process this file with autoconf to produce a configure script.
++
++AC_PREREQ([2.69])
++AC_INIT([BTF],[1.2.0],[DrTimothyAldenDavis@gmail.com],[btf],[http://www.suitesparse.com/])
++AC_CONFIG_SRCDIR([Source/btf_order.c])
++AC_CONFIG_HEADERS([config.h])
++AM_INIT_AUTOMAKE([foreign])
++LT_INIT
++
++# Checks for programs.
++AC_PROG_INSTALL
++AC_PROG_CC
++
++# Checks for libraries.
++PKG_PROG_PKG_CONFIG
++PKG_CHECK_MODULES([SUITESPARSECONFIG],[suitesparseconfig],
++ [],
++ [AC_MSG_ERROR([cannot find suitesparseconfig])])
++
++# Checks for header files.
++
++# Checks for typedefs, structures, and compiler characteristics.
++
++# Checks for library functions.
++
++AC_CONFIG_FILES([
++ btf.pc
++ Makefile
++ Include/Makefile
++ Source/Makefile])
++AC_OUTPUT
diff --git a/academic/btf/btf.SlackBuild b/academic/btf/btf.SlackBuild
new file mode 100644
index 0000000000..69de19a523
--- /dev/null
+++ b/academic/btf/btf.SlackBuild
@@ -0,0 +1,107 @@
+#!/bin/sh
+
+# Slackware build script for BTF
+
+# Copyright 2013 Kyle Guinn <elyk03@gmail.com>, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=btf
+SRCNAM=BTF
+VERSION=${VERSION:-1.2.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$(uname -m)" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$(uname -m) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCS="README.txt Doc/ChangeLog Doc/lesser.txt"
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+# Recommended by SuiteSparse
+SLKCFLAGS="$SLKCFLAGS -fexceptions -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE"
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+patch -p1 < $CWD/autotoolize.diff
+autoreconf -vif
+
+CFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --infodir=/usr/info \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --enable-shared \
+ --disable-static \
+ --disable-dependency-tracking \
+ --build=$ARCH-slackware-linux
+
+make
+make check
+make install-strip DESTDIR=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/academic/btf/btf.info b/academic/btf/btf.info
new file mode 100644
index 0000000000..d8b34f8de8
--- /dev/null
+++ b/academic/btf/btf.info
@@ -0,0 +1,10 @@
+PRGNAM="btf"
+VERSION="1.2.0"
+HOMEPAGE="https://www.cise.ufl.edu/research/sparse/btf/"
+DOWNLOAD="https://www.cise.ufl.edu/research/sparse/btf/BTF-1.2.0.tar.gz"
+MD5SUM="00ece872530408f3f5598b0eaa83c7fc"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="suitesparseconfig"
+MAINTAINER="Kyle Guinn"
+EMAIL="elyk03@gmail.com"
diff --git a/academic/btf/slack-desc b/academic/btf/slack-desc
new file mode 100644
index 0000000000..43e265cfee
--- /dev/null
+++ b/academic/btf/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+btf: BTF (matrix permuting routines)
+btf:
+btf: BTF permutes an unsymmetric matrix (square or rectangular) into its
+btf: block upper triangular form (more precisely, it computes a
+btf: Dulmage-Mendelsohn decomposition).
+btf:
+btf:
+btf:
+btf:
+btf:
+btf: