summaryrefslogtreecommitdiffstats
path: root/academic
diff options
context:
space:
mode:
author Kyle Guinn2014-01-25 04:09:24 +0100
committer Robby Workman2014-01-31 07:54:03 +0100
commit3ae8fba936fb6d319d7270902c9933a581a1bad7 (patch)
treeb691cd82877102dc4b8e630d8e59c50766656f5b /academic
parent428355651d90f82044f8eb8b40961a668eec3b19 (diff)
downloadslackbuilds-3ae8fba936fb6d319d7270902c9933a581a1bad7.tar.gz
academic/ldl: Renamed and moved from libraries.
Signed-off-by: Robby Workman <rworkman@slackbuilds.org>
Diffstat (limited to 'academic')
-rw-r--r--academic/ldl/README11
-rw-r--r--academic/ldl/autotoolize.diff208
-rw-r--r--academic/ldl/ldl.SlackBuild107
-rw-r--r--academic/ldl/ldl.info10
-rw-r--r--academic/ldl/slack-desc19
5 files changed, 355 insertions, 0 deletions
diff --git a/academic/ldl/README b/academic/ldl/README
new file mode 100644
index 0000000000..b3628fc188
--- /dev/null
+++ b/academic/ldl/README
@@ -0,0 +1,11 @@
+LDL is a set of concise routines for factorizing symmetric
+positive-definite sparse matrices, with some applicability to symmetric
+indefinite matrices. Its primary purpose is to illustrate much of the
+basic theory of sparse matrix algorithms in as concise a code as possible,
+including an elegant new method of sparse symmetric factorization that
+computes the factorization row-by-row but stores it column-by-column.
+
+This package is part of SuiteSparse.
+
+AMD is an optional dependency and will be used if found.
+It is primarily used for this package's test suite.
diff --git a/academic/ldl/autotoolize.diff b/academic/ldl/autotoolize.diff
new file mode 100644
index 0000000000..6fbfe7ce29
--- /dev/null
+++ b/academic/ldl/autotoolize.diff
@@ -0,0 +1,208 @@
+diff --git a/Demo/Makefile.am b/Demo/Makefile.am
+new file mode 100644
+--- /dev/null
++++ b/Demo/Makefile.am
+@@ -0,0 +1,57 @@
++AM_CPPFLAGS = -I$(top_srcdir)/Include $(AMD_CFLAGS) $(SUITESPARSECONFIG_CFLAGS)
++LDADD = $(top_builddir)/Source/libldl.la
++
++EXTRA_DIST = \
++ ldlamd.out \
++ ldllamd.out \
++ ldlmain.out \
++ ldllmain.out \
++ ldlsimple.out \
++ ldllsimple.out
++
++# Disable the .out implicit pattern rule. Prevents GNU make from
++# adding bogus dependencies for the .out files listed above.
++%.out: %
++
++check_PROGRAMS = \
++ ldlmain \
++ ldllmain \
++ ldlsimple \
++ ldllsimple
++
++if AMD
++check_PROGRAMS += \
++ ldlamd \
++ ldllamd
++
++ldlamd_SOURCES = ldlmain.c
++ldlamd_CPPFLAGS = $(AM_CPPFLAGS) -DUSE_AMD
++ldlamd_LDADD = $(LDADD) $(AMD_LIBS)
++
++ldllamd_SOURCES = ldlmain.c
++ldllamd_CPPFLAGS = $(AM_CPPFLAGS) -DUSE_AMD -DLDL_LONG
++ldllamd_LDADD = $(LDADD) $(AMD_LIBS)
++endif
++
++ldlmain_SOURCES = ldlmain.c
++
++ldllmain_SOURCES = ldlmain.c
++ldllmain_CPPFLAGS = $(AM_CPPFLAGS) -DLDL_LONG
++
++ldlsimple_SOURCES = ldlsimple.c
++
++ldllsimple_SOURCES = ldlsimple.c
++ldllsimple_CPPFLAGS = $(AM_CPPFLAGS) -DLDL_LONG
++
++check-local: $(check_PROGRAMS) $(check_PROGRAMS:=.out)
++ @for i in $(check_PROGRAMS); do \
++ echo "Testing $$i"; \
++ (cd $(srcdir) && $(abs_builddir)/$$i$(EXEEXT)) > my_$$i.out; \
++ if diff -u $(srcdir)/$$i.out my_$$i.out; then \
++ echo "Test $$i PASSED."; \
++ else \
++ echo "Test $$i FAILED."; \
++ fi; \
++ done
++
++CLEANFILES = my_*.out
+diff --git a/Doc/Makefile.am b/Doc/Makefile.am
+new file mode 100644
+--- /dev/null
++++ b/Doc/Makefile.am
+@@ -0,0 +1,23 @@
++EXTRA_DIST = ChangeLog lesser.txt
++
++dist_noinst_DATA = ldl_userguide.tex ldl.bib
++dist_pdf_DATA = ldl_userguide.pdf
++
++.INTERMEDIATE: ldl_userguide.bib
++ldl_userguide.bib: ldl.bib
++ $(LN_S) -f $< $@
++
++TEX = TEXINPUTS="$(srcdir):" pdflatex -interaction nonstopmode -file-line-error
++BIB = BIBINPUTS="$(srcdir):" bibtex
++%.pdf: %.tex %.bbl
++ $(TEX) $*
++ while grep -q "Rerun to get cross-references right" $*.log; do \
++ $(TEX) $*; \
++ done
++%.bbl: %.aux %.bib
++ $(BIB) $*
++%.aux: %.tex
++ $(TEX) $*
++
++CLEANFILES = *.aux *.bbl *.blg *.log *.toc
++MAINTAINERCLEANFILES = $(dist_pdf_DATA)
+diff --git a/Include/Makefile.am b/Include/Makefile.am
+new file mode 100644
+--- /dev/null
++++ b/Include/Makefile.am
+@@ -0,0 +1 @@
++pkginclude_HEADERS = ldl.h
+diff --git a/Makefile.am b/Makefile.am
+new file mode 100644
+--- /dev/null
++++ b/Makefile.am
+@@ -0,0 +1,5 @@
++SUBDIRS = Include Source Matrix Demo Doc
++EXTRA_DIST = README.txt
++
++pkgconfigdir = $(libdir)/pkgconfig
++pkgconfig_DATA = ldl.pc
+diff --git a/Matrix/Makefile.am b/Matrix/Makefile.am
+new file mode 100644
+--- /dev/null
++++ b/Matrix/Makefile.am
+@@ -0,0 +1,4 @@
++dist_noinst_DATA = \
++ A01 A02 A03 A04 A05 A06 A07 A08 A09 A10 \
++ A11 A12 A13 A14 A15 A16 A17 A18 A19 A20 \
++ A21 A22 A23 A24 A25 A26 A27 A28 A29 A30
+diff --git a/Source/Makefile.am b/Source/Makefile.am
+new file mode 100644
+--- /dev/null
++++ b/Source/Makefile.am
+@@ -0,0 +1,16 @@
++AM_CPPFLAGS = -I$(top_srcdir)/Include $(SUITESPARSECONFIG_CFLAGS)
++
++LDLSRC = \
++ ldl.c
++
++lib_LTLIBRARIES = libldl.la
++noinst_LTLIBRARIES = libldli.la libldll.la
++
++libldli_la_SOURCES = $(LDLSRC)
++
++libldll_la_SOURCES = $(LDLSRC)
++libldll_la_CPPFLAGS = $(AM_CPPFLAGS) -DLDL_LONG
++
++libldl_la_SOURCES =
++libldl_la_LIBADD = libldli.la libldll.la
++libldl_la_LDFLAGS = -no-undefined -version-number 2:1:0
+diff --git a/configure.ac b/configure.ac
+new file mode 100644
+--- /dev/null
++++ b/configure.ac
+@@ -0,0 +1,50 @@
++# -*- Autoconf -*-
++# Process this file with autoconf to produce a configure script.
++
++AC_PREREQ([2.69])
++AC_INIT([LDL],[2.1.0],[DrTimothyAldenDavis@gmail.com],[ldl],[http://www.suitesparse.com/])
++AC_CONFIG_SRCDIR([Source/ldl.c])
++AC_CONFIG_HEADERS([config.h])
++AM_INIT_AUTOMAKE([foreign])
++LT_INIT
++
++# Checks for programs.
++AC_PROG_INSTALL
++AC_PROG_CC
++AC_PROG_LN_S
++
++LIBS_SAVED=$LIBS
++
++# Checks for libraries.
++PKG_PROG_PKG_CONFIG
++PKG_CHECK_MODULES([SUITESPARSECONFIG],[suitesparseconfig],
++ [],
++ [AC_MSG_ERROR([cannot find suitesparseconfig])])
++PKG_CHECK_MODULES([AMD],[amd],
++ [amd="yes"],
++ [amd="no"])
++if test "x$amd" != "xyes"; then
++ AC_MSG_WARN([cannot find amd, disabling some functionality])
++fi
++
++# Checks for header files.
++AC_CHECK_HEADERS([stdlib.h])
++
++# Checks for typedefs, structures, and compiler characteristics.
++
++# Checks for library functions.
++AC_FUNC_MALLOC
++
++LIBS=$LIBS_SAVED
++
++AM_CONDITIONAL([AMD], [test "x$amd" = "xyes"])
++
++AC_CONFIG_FILES([
++ ldl.pc
++ Makefile
++ Demo/Makefile
++ Doc/Makefile
++ Include/Makefile
++ Matrix/Makefile
++ Source/Makefile])
++AC_OUTPUT
+diff --git a/ldl.pc.in b/ldl.pc.in
+new file mode 100644
+--- /dev/null
++++ b/ldl.pc.in
+@@ -0,0 +1,12 @@
++prefix=@prefix@
++exec_prefix=@exec_prefix@
++libdir=@libdir@
++includedir=@includedir@
++
++Name: @PACKAGE_NAME@
++Description: A simple LDL^T factorization
++Version: @PACKAGE_VERSION@
++URL: @PACKAGE_URL@
++Requires.private: suitesparseconfig
++Libs: -L${libdir} -lldl
++Cflags: -I${includedir}/ldl
diff --git a/academic/ldl/ldl.SlackBuild b/academic/ldl/ldl.SlackBuild
new file mode 100644
index 0000000000..f3ec66fe8c
--- /dev/null
+++ b/academic/ldl/ldl.SlackBuild
@@ -0,0 +1,107 @@
+#!/bin/sh
+
+# Slackware build script for LDL
+
+# Copyright 2013 Kyle Guinn <elyk03@gmail.com>, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=ldl
+SRCNAM=LDL
+VERSION=${VERSION:-2.1.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$(uname -m)" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$(uname -m) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCS="README.txt Doc/ChangeLog Doc/lesser.txt"
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+# Recommended by SuiteSparse
+SLKCFLAGS="$SLKCFLAGS -fexceptions -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE"
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+patch -p1 < $CWD/autotoolize.diff
+autoreconf -vif
+
+CFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --infodir=/usr/info \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --enable-shared \
+ --disable-static \
+ --disable-dependency-tracking \
+ --build=$ARCH-slackware-linux
+
+make
+make check
+make install-strip DESTDIR=$PKG
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/academic/ldl/ldl.info b/academic/ldl/ldl.info
new file mode 100644
index 0000000000..28cd837e6b
--- /dev/null
+++ b/academic/ldl/ldl.info
@@ -0,0 +1,10 @@
+PRGNAM="ldl"
+VERSION="2.1.0"
+HOMEPAGE="https://www.cise.ufl.edu/research/sparse/ldl/"
+DOWNLOAD="https://www.cise.ufl.edu/research/sparse/ldl/LDL-2.1.0.tar.gz"
+MD5SUM="654e7b8a45a123b7cab7182dd01a2dc9"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="%README% suitesparseconfig"
+MAINTAINER="Kyle Guinn"
+EMAIL="elyk03@gmail.com"
diff --git a/academic/ldl/slack-desc b/academic/ldl/slack-desc
new file mode 100644
index 0000000000..42141e8566
--- /dev/null
+++ b/academic/ldl/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+ldl: LDL (sparse matrix factoring routines)
+ldl:
+ldl: LDL is a set of concise routines for factorizing symmetric
+ldl: positive-definite sparse matrices, with some applicability to
+ldl: symmetric indefinite matrices.
+ldl:
+ldl:
+ldl:
+ldl:
+ldl:
+ldl: