summaryrefslogtreecommitdiffstats
path: root/academic
diff options
context:
space:
mode:
author Erwin van Zanten2012-12-14 06:36:01 +0100
committer Matteo Bernardini2012-12-15 15:13:34 +0100
commit5f9b716ecfbef39b92f602b1af48cffe4b972174 (patch)
tree5a07381258d3a4e26eb5d3a80acf3b3f974ad25e /academic
parent18c5c1bccdd528e3ad75a64cac36645fba7ca5ba (diff)
downloadslackbuilds-5f9b716ecfbef39b92f602b1af48cffe4b972174.tar.gz
academic/gresistor: Added (resistor color code calculator).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'academic')
-rw-r--r--academic/gresistor/README11
-rw-r--r--academic/gresistor/gresistor.SlackBuild75
-rw-r--r--academic/gresistor/gresistor.info10
-rw-r--r--academic/gresistor/slack-desc19
4 files changed, 115 insertions, 0 deletions
diff --git a/academic/gresistor/README b/academic/gresistor/README
new file mode 100644
index 0000000000..e543019154
--- /dev/null
+++ b/academic/gresistor/README
@@ -0,0 +1,11 @@
+gresistor is a Gnome resistor color code calculator.
+
+To allow for identification, resistors are usually marked
+with colored bands. Often refered to as color codes, these
+markngs are indicative of their resistance, tolerance and
+temperature coefficient.
+gResistor helps you translate resistor color codes into a
+readable value. All you have to do is watch the colors on
+the resistor and then enter them in the program. As you
+enter colours you'll see that the resistor value changing
+accordingly.
diff --git a/academic/gresistor/gresistor.SlackBuild b/academic/gresistor/gresistor.SlackBuild
new file mode 100644
index 0000000000..a7d8dd96c7
--- /dev/null
+++ b/academic/gresistor/gresistor.SlackBuild
@@ -0,0 +1,75 @@
+#!/bin/sh
+
+# Slackware build script for gresistor
+# Written by Erwin van Zanten <e.van.zanten.evz@gmail.com>
+
+PRGNAM=gresistor
+VERSION=${VERSION:-0.0.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+# Automatically determine the architecture we're building on:
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ # Unless $ARCH is already set, use uname -m for all other archs:
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM-$VERSION
+OUTPUT=${OUTPUT:-/tmp}
+
+DOCS="README"
+
+if [ $ARCH = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ $ARCH = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ $ARCH = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar -xzvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+python ./setup.py install --root=$PKG
+
+find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+# Normalize line endings
+sed -i "s/\xd$//g" README
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/academic/gresistor/gresistor.info b/academic/gresistor/gresistor.info
new file mode 100644
index 0000000000..c6caf62c9c
--- /dev/null
+++ b/academic/gresistor/gresistor.info
@@ -0,0 +1,10 @@
+PRGNAM="gresistor"
+VERSION="0.0.1"
+HOMEPAGE="http://xtronic.org/download/gresistor/"
+DOWNLOAD="http://www.roroid.ro/progs/gresistor/gresistor-0.0.1.tar.gz"
+MD5SUM="d77bee79eb7b17c0d20e18dde04392da"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Erwin van Zanten"
+EMAIL="e.van.zanten.evz@gmail.com"
diff --git a/academic/gresistor/slack-desc b/academic/gresistor/slack-desc
new file mode 100644
index 0000000000..86c8eb89d8
--- /dev/null
+++ b/academic/gresistor/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+gresistor: gresistor (a Gnome resistor color code calculator)
+gresistor:
+gresistor: gResistor helps you translate resistor color codes into
+gresistor: a readable value.
+gresistor:
+gresistor: homepage: http://xtronic.org/download/gresistor/
+gresistor:
+gresistor:
+gresistor:
+gresistor:
+gresistor: