summaryrefslogtreecommitdiffstats
path: root/academic/xoscope
diff options
context:
space:
mode:
author Heinz Wiesinger2013-11-25 12:23:31 +0100
committer Heinz Wiesinger2013-11-25 13:11:59 +0100
commit926b93d445e92be03e62efcd742b2ac88f0d96ed (patch)
treea9e1e616e37f2f7187d0b0ab2d8e83b3ad8eed63 /academic/xoscope
parent7bc7feac90a3966ebaea1b1ad87431764a560344 (diff)
downloadslackbuilds-926b93d445e92be03e62efcd742b2ac88f0d96ed.tar.gz
various: Replace chmod command with find command from template.
Signed-off-by: Heinz Wiesinger <pprkut@slackbuilds.org>
Diffstat (limited to 'academic/xoscope')
-rw-r--r--academic/xoscope/xoscope.SlackBuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/academic/xoscope/xoscope.SlackBuild b/academic/xoscope/xoscope.SlackBuild
index 35ca9ba425..eeecdc1755 100644
--- a/academic/xoscope/xoscope.SlackBuild
+++ b/academic/xoscope/xoscope.SlackBuild
@@ -46,7 +46,11 @@ rm -rf $PRGNAM-$VERSION
tar xvf $CWD/$PRGNAM-$VERSION.tgz
cd $PRGNAM-$VERSION
chown -R root:root .
-chmod -R u+w,go+r-w,a-st .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Allow DEPRECATED functions or build fails on gtk+2-2.24.3.
sed -i -e '/-DG.*_DISABLE_DEPRECATED/d' gtkdatabox-0.6.0.0/gtk/Makefile.am