summaryrefslogtreecommitdiffstats
path: root/academic/tilem2/patches
diff options
context:
space:
mode:
author JK Wood2013-01-13 15:38:56 +0100
committer dsomero2013-01-20 15:03:04 +0100
commitf757ebccbd9750755be813c8a1646540ed929fb1 (patch)
treee5c3a0152b5508640e6fa6cf0ee49fca2a6c790e /academic/tilem2/patches
parent23af0556d2e0b2e1484e638f2c03b28024b1962f (diff)
downloadslackbuilds-f757ebccbd9750755be813c8a1646540ed929fb1.tar.gz
academic/tilem2: Added (TI-calculator emulator for linux).
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
Diffstat (limited to 'academic/tilem2/patches')
-rw-r--r--academic/tilem2/patches/add_-lm_to_libs_r661.patch76
-rw-r--r--academic/tilem2/patches/desktop_file_fix_r668.patch10
-rw-r--r--academic/tilem2/patches/tilem-2.0-64bit.patch12
3 files changed, 98 insertions, 0 deletions
diff --git a/academic/tilem2/patches/add_-lm_to_libs_r661.patch b/academic/tilem2/patches/add_-lm_to_libs_r661.patch
new file mode 100644
index 0000000000..771103558f
--- /dev/null
+++ b/academic/tilem2/patches/add_-lm_to_libs_r661.patch
@@ -0,0 +1,76 @@
+diff --git a/configure b/configure
+index cc4e5ad..26af532 100755
+--- a/configure
++++ b/configure
+@@ -3456,6 +3456,48 @@ fi
+ # Checks for libraries
+
+
++{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for pow in -lm" >&5
++$as_echo_n "checking for pow in -lm... " >&6; }
++if ${ac_cv_lib_m_pow+:} false; then :
++ $as_echo_n "(cached) " >&6
++else
++ ac_check_lib_save_LIBS=$LIBS
++LIBS="-lm $LIBS"
++cat confdefs.h - <<_ACEOF >conftest.$ac_ext
++/* end confdefs.h. */
++
++/* Override any GCC internal prototype to avoid an error.
++ Use char because int might match the return type of a GCC
++ builtin and then its argument prototype would still apply. */
++#ifdef __cplusplus
++extern "C"
++#endif
++char pow ();
++int
++main ()
++{
++return pow ();
++ ;
++ return 0;
++}
++_ACEOF
++if ac_fn_c_try_link "$LINENO"; then :
++ ac_cv_lib_m_pow=yes
++else
++ ac_cv_lib_m_pow=no
++fi
++rm -f core conftest.err conftest.$ac_objext \
++ conftest$ac_exeext conftest.$ac_ext
++LIBS=$ac_check_lib_save_LIBS
++fi
++{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_cv_lib_m_pow" >&5
++$as_echo "$ac_cv_lib_m_pow" >&6; }
++if test "x$ac_cv_lib_m_pow" = xyes; then :
++ LIBS="-lm $LIBS"
++fi
++
++
++
+
+ # GLib and GTK+
+
+@@ -3728,8 +3770,7 @@ fi
+ save_libs="$LIBS"
+ CFLAGS="$CFLAGS $GTK_CFLAGS"
+ LIBS="$LIBS $GTK_LIBS"
+-
+-ac_fn_c_check_func "$LINENO" "gtk_init" "ac_cv_func_gtk_init"
++ ac_fn_c_check_func "$LINENO" "gtk_init" "ac_cv_func_gtk_init"
+ if test "x$ac_cv_func_gtk_init" = xyes; then :
+ have_gtk=yes
+ else
+diff --git a/configure.ac b/configure.ac
+index 88e2306..456e4c7 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -37,6 +37,8 @@ AC_CHECK_PROG([UPDATE_MIME_DATABASE],
+
+ # Checks for libraries
+
++AC_CHECK_LIB(m, pow, [ LIBS="-lm $LIBS" ])
++
+ m4_define(with_flags, [
+ save_cflags="$CFLAGS"
+ save_libs="$LIBS"
diff --git a/academic/tilem2/patches/desktop_file_fix_r668.patch b/academic/tilem2/patches/desktop_file_fix_r668.patch
new file mode 100644
index 0000000000..77aaa3ff85
--- /dev/null
+++ b/academic/tilem2/patches/desktop_file_fix_r668.patch
@@ -0,0 +1,10 @@
+diff --git a/data/desktop/tilem2.desktop b/data/desktop/tilem2.desktop
+index 8118c97..2432f5f 100644
+--- a/data/desktop/tilem2.desktop
++++ b/data/desktop/tilem2.desktop
+@@ -7,4 +7,4 @@ MimeType=application/x-tigroup;application/x-ti73-variables;application/x-ti73-p
+ StartupNotify=true
+ Terminal=false
+ Type=Application
+-Categories=Education;Science;Math;Emulator;
++Categories=Education;Science;Math;System;Emulator;
diff --git a/academic/tilem2/patches/tilem-2.0-64bit.patch b/academic/tilem2/patches/tilem-2.0-64bit.patch
new file mode 100644
index 0000000000..33d56b87bf
--- /dev/null
+++ b/academic/tilem2/patches/tilem-2.0-64bit.patch
@@ -0,0 +1,12 @@
+diff -ur tilem-2.0/gui/macro.c tilem-2.0-64bit/gui/macro.c
+--- tilem-2.0/gui/macro.c 2011-11-26 21:47:07.000000000 +0100
++++ tilem-2.0-64bit/gui/macro.c 2012-07-23 22:48:24.000000000 +0200
+@@ -134,7 +134,7 @@
+ char * lengthchar = g_new0(char, 4);
+ int length = strlen(emu->macro->actions[i]->value);
+ fwrite("file=", 1, 5, fp);
+- sprintf(lengthchar, "%04d", strlen(emu->macro->actions[i]->value));
++ sprintf(lengthchar, "%04zd", strlen(emu->macro->actions[i]->value));
+ fwrite(lengthchar, 1, sizeof(int), fp);
+ fwrite("-", 1, 1, fp);
+ fwrite(emu->macro->actions[i]->value, 1, length, fp);